KB2960989 - FIX: Error when you use DQS Cleansing component with large batch in an SSIS 2012 or SSIS 2014 package

Applies To
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Assume that you are using Data Quality Services (DQS) Cleansing component with large batch in a Microsoft SQL Server 2012 Integration Services (SSIS 2012) or SQL Server 2014 Integration Services (SSIS 2014) package. When you try to execute the package, you may receive the following results:

  • You receive the following error within SSIS package

    Note

    OnError,<MachineName>,<UserName>,Data Flow Task - Pass data through DQS,{9C749B1D-3FAF-4E3B-B0B9-C8BA626428F5},{B8582806-2FDB-43EF-8E69-B43E6A375DD2},<Date><Time>,<Date><Time>,0,0x,The value '<StringValue>' in column <ColumnName>' does not fit the current buffer. The value length is 11, but the output column length is 1.
    OnError,<MachineName>,<UserNname>,DQS_Test,{AF400590-A48A-4483-87A0-A5CC5AC8BF09},{B8582806-2FDB-43EF-8E69-B43E6A375DD2},<Date><Time>,<Date><Time>,0,0x,The value '<StringValue>' in column <ColumnName>' does not fit the current buffer. The value length is 11, but the output column length is 1.
    OnError,<MachineName>,<UserName>,Data Flow Task - Pass data through DQS,{9C749B1D-3FAF-4E3B-B0B9-C8BA626428F5},{B8582806-2FDB-43EF-8E69-B43E6A375DD2},<Date><Time>,<Date><Time>,0,0x,An unexpected error occurred in the DQS infrastructure.
    Microsoft.SqlServer.Dts.Pipeline.DoesNotFitBufferException: The value is too large to fit in the column data area of the buffer.
       at Microsoft.SqlServer.Dts.Pipeline.PipelineBuffer.SetString(Int32 columnIndex, String value)
       at Microsoft.Ssdqs.Component.Common.Utilities.ComponentUtility.SetValue(IDTSComponentMetaData100 componentMetadata, PipelineBuffer buffer, Int32 fieldIndex, DataType type, Int32 length, String columnName, Object value) at Microsoft.Ssdqs.Component.DataCorrection.Logic.DataCorrectionComponent.ProcessChunk(ReadOnlyCollection`1 fieldMappings, ReadOnlyCollection`1 records, CorrectedRecordsStatusStatistics& correctedRecordsTotalStatusStatistics)

  • When the package is completed, open up the project generated in DQS client and examine one of the domains. If you sort the domain by value, you may see values from other domains.

Note The failure rate of this issue depends on the batch size. When the size of batch is larger, the failure rate will be larger.

Resolution

The issue was first fixed in the following cumulative update of SQL Server.

Cumulative Update 1 for SQL Server 2012 SP2 /en-us/help/2976982

Cumulative Update 2 for SQL Server 2014 /en-us/help/2967546

Cumulative Update 10 for SQL Server 2012 SP1 /en-us/help/2954099

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

      

Workaround

To work around this issue, decrease the batch size to resolve or relieve the issue.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.