Symptoms
Assume that you configure Oracle Publishing in Microsoft SQL Server 2008 R2, SQL Server 2012, SQL Server 2014, SQL Server 2016. When HREPL_SEQ goes beyond INT capacity of 2147483647, Log Reader Agent fails. Additionally, you receive the following error:
Note
ORA-01455: converting column overflows integer datatype (Source: MSSQL_REPL_ORACLE, Error number: 1455)
Get help: http://help/1455
Heterogeneous Logreader encountered an error in call to LoadReplCmds when processing state 'FETCH'. (Source: MSSQL_REPL, Error number: MSSQL_REPL22037)
Get help: http://help/MSSQL_REPL22037
Resolution
The issue was first fixed in the following cumulative updates of SQL Server.
- Cumulative Update 1 for SQL Server 2016
- Cumulative Update 1 for SQL Server 2012 SP2
- Cumulative Update 2 for SQL Server 2014
- Cumulative Update 10 for SQL Server 2012 SP1
- Cumulative Update 12 for SQL Server 2008 R2 SP2
About cumulative updates for SQL Server
Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:
- Latest cumulative update for SQL Server 2016
- Latest cumulative update for SQL Server 2012 SP2
- Latest cumulative update for SQL Server 2014
- Latest cumulative update for SQL Server 2012 SP1
- Latest cumulative update for SQL Server 2008 R2 SP2
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.