KB3028322 - FIX: It takes longer time than usual to render a report in SSRS 2012 or SSRS 2014

Symptoms

Assume that you render a report in Microsoft SQL Server 2012 Reporting Services (SSRS 2012) or SSRS 2014, and that the report has some small errors, for example:

Note

library!ReportServer_0-8!4798!12/16/2014-16:33:01:: i INFO: RenderForNewSession('/MyReport')
processing!ReportServer_0-8!4798!12/16/2014-16:33:03:: e ERROR: Throwing Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: , Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: There is no data for the field at position 8.;
processing!ReportServer_0-8!4798!12/16/2014-16:33:33:: e ERROR: Throwing Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: , Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: There is no data for the field at position 9.;

In this situation, the report runs successfully. However, it might take longer time than usual to render the report. Each error may cause a 30-second delay.

Cause

This issue occurs because Reporting Services is blocked from loading the unnecessary error-handling object.

Resolution

This issue was first fixed in the following cumulative update of SQL Server.

Cumulative Update 1 for SQL Server 2014 SP1 /en-us/help/3067839

Cumulative Update 5 for SQL Server 2012 SP2 /en-us/help/3037255

Cumulative Update 6 for SQL Server 2014 /en-us/help/3031047

Cumulative Update 14 for SQL Server 2012 SP1 /en-us/help/3023636

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.