Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

PROBLEM

When you use In-Place eDiscovery & Hold in Exchange Online to search a large number of mailboxes, the search status is displayed as partially complete. Additionally, one or more mailboxes returns the following error message:

The server cannot service this request right now. Try again later.

When you search again, you receive the same error message but on different mailboxes.

CAUSE

An organization’s Exchange Online mailboxes may be distributed across multiple Office 365 servers. Some mailboxes may be homed on a server that's processing an unusual volume of higher-priority requests, such as requests that are related to mail flow. In this scenario, that server will be unable to respond to eDiscovery requests in a timely manner.

WORKAROUND

Use one of the following methods, as appropriate for your situation:

  • If you're using eDiscovery search to establish an In-Place Hold or to export search results, this issue does not affect the actions that you're performing.

  • To obtain search results for the mailboxes that didn’t succeed, create a new search query, and then add those mailboxes to it to search only those mailboxes.

STATUS

This is a known issue with In-Place eDiscovery search that may be corrected in a future update. 

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×