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Symptoms

When you use the QUERY USER command to obtain information from a remote server, it reports that the user does not exist.

For example:

query user username /server:remoteserverThe following error may also be displayed:

No user exists for username

Cause

This problem occurs when you use the QUERY USER command and specify a user name. The Query command assumes this to be local and only looks at the local server for this user.

Using QUERY USER /SERVER:REMOTESERVER does report this information but lists all users currently logged on to the remote server.

Resolution

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack

WORKAROUND

To work around this problem, use one of the following methods:

  • Query the remote server and do not type username. This command lists all users on that server.

    query user /server:remoteserver

  • To obtain a single user listing, you could send the output of the above command through find:

    query user /server:remoteserver | find "username"

  • Create a batch file to query for a single user.

    Batch File Name: Q.bat
    Type the following text in the batch file, and then save the file:

    query user /server:%1 | find "%2"Type the following at a command prompt:

    q remoteserver username
    NOTE: REMOTESERVER and USERNAME are the respective server and user that you are are trying to query.

Status

Microsoft has confirmed that this is a problem in Microsoft Windows NT Server versions 4.0, 4.0 SP, Terminal Server Edition.

This problem was first corrected in Windows NT Server 4.0, Terminal Server Edition, Service Pack 5.

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