Error message when a user inputs a integer value response in a Microsoft Dynamics CRM 2011 Dialog form

You may see an error when a four digit number is entered into a response box for an Int value (Single Line/Integer) field in a dialog form in Dynamics CRM 2011:

An exception System.FormatException was thrown while trying to convert input value '2,000' to attribute 'new_custom.new_year'. Expected type of attribute value: System.Int32. Exception raised: Input string was not in a correct format.

Symptoms

The issue is cause when CRM attempts to apply local culture formatting to the response (ie. add a comma) 

Cause

This issue is resolved with the latest Update Rollup for Dynamics CRM 2011 which can be downloaded from the following location: http://support.microsoft.com/kb/2555051

However, dialog processes that were created before Update Rollup 5 will need to be manually updated to stop the error message from occurring.

Correct the Dialog with these steps:

1. Deactivate the offending dialog.

2. Open all "possible offending query steps" in the dialog.

3. Hit Save and Close without making any changes. This will automatically update the dialog for correct functioning.


Resolution

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