Support for TLS 1.2 protocol in BizTalk Server

Symptoms

This update adds support for Transport Layer Security (TLS) protocol version 1.2 to BizTalk Server.

Resolution

This update is included in the following updates for BizTalk Server:

Cumulative Update 5 for BizTalk Server 2016

Cumulative Update 8 for BizTalk Server 2013 R2

Cumulative Update 7 for BizTalk Server 2013

Prerequisites

SQL Server 2012 Native Client version 11 should be installed on all BizTalk Server systems before you apply this update. If the SQL Native Client is not installed before you apply cumulative update, the installation may not complete.

More information

TLS 1.2 is now fully supported in BizTalk Server. This includes all the adapters and accelerators. You can also disable SSL, TLS 1.0, and TLS 1.1 in BizTalk Server.

Key information:

  • Any external systems that communicate with BizTalk Server must also support TLS 1.2.

  • Any custom code, such as functoids, may have to be updated to support TLS 1.2.

For information about how to set up a TLS 1.2 environment, go to the "Option 1: Switch to the TLS 1.2 protocol" section of the following article in the Microsoft Knowledge Base:

3155464 MS16-065: Description of the TLS/SSL protocol information disclosure vulnerability (CVE-2016-0149): May 10, 2016

References

Service pack and cumulative update list for BizTalk Server

Information about BizTalk Server hotfixes and cumulative update support

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×