Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptom

On a Windows 10 or Windows 11 device with a built-in display, when you connect an external monitor with a USB-C, DisplayPort, or HDMI connection, the wallpaper on the external monitor might not correctly fill the screen.

Cause

This problem might occur on Windows 10 or Windows 11 if the screen resolution of the built-in display differs from the screen resolution of the external display.  When the screen resolution of the built-in display is smaller than the external, then the wallpaper on the external display might appear to be too small and doesn't fill the whole screen. When the screen resolution of the built-in display is larger than the external, then the wallpaper on the external display might appear to be too big and will be cut off on the right and bottom sides.

Resolution

You can resolve this issue by temporarily changing the screen resolution of the external display.  To do this:

  1. Select Start  > Settings > System > Display, and look at the section that shows your displays.  Open your Display settings

  2. Select the external display.

  3. In the Display resolution row, select the dropdown and choose any screen resolution that differs from the display’s current resolution.

  4. Once the resolution changes, you will be asked if you would like to “Keep these display settings?”  Select Revert. (The screen resolution will automatically revert if you take no action.)

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×