When you run the Validate a Configuration Wizard on a Windows Server 2008-based computer or on a Windows Vista-based computer, the validation does not pass

Symptoms

You run the Validate a Configuration Wizard from within Failover Cluster Management Administrative Tool on one of the following computers:

  • A Windows Server 2008-based computer

  • A Windows Vista-based computer that has Remote Server Administration Tools (RSAT) installed

When you do this, the validation does not pass the Validate Operating System Versions test in the System Configuration group. Additionally, you receive the following error message:

The operating system SKU is not compatible

This occurs even though the computer is running a supported installation of Windows Server 2008. This problem occurs when you run the Validate a Configuration Wizard on computers that have the following Windows installations:

  • A full installation of Windows Server 2008 Enterprise without Hyper-V

  • A full installation of Windows Server 2008 Datacenter without Hyper-V

  • A Server Core installation of Windows Server 2008 Enterprise without Hyper-V

  • A Server Core installation of Windows Server 2008 Datacenter without Hyper-V

  • A Windows Vista installation that has Remote Server Administration Tools (RSAT) installed

Cause

This problem occurs because the Validate a Configuration Wizard incorrectly identifies these operating system versions as incompatible.

Resolution

To resolve this problem, you must apply an update on the computer on which you want to run the Validate a Configuration Wizard. We recommend that you apply this update on any nodes on which you might run the Validate a Configuration Wizard.

Update information

The following files are available for download from the Microsoft Download Center:

Download Download the Update for Windows Server 2008 (KB950179) package now.

Download Download the Update for Windows Server 2008 x64 Edition (KB950179) package now.

Download Download the Update for Windows Server 2008 for Itanium-based Systems (KB950179) package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

You can apply this update on Windows Server 2008-based computers that have the Failover Clustering feature installed or on Windows Vista-based computers that have Remote Server Administration Tools installed.

Restart requirement

You do not have to restart the computer after you apply this update. However, you must restart the Validate a Configuration Wizard.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2008, 32-bit editions

File name

File version

File size

Date

Time

Platform

Failoverclusters.agent.interop.dll

6.0.6001.22189

11,264

29-May-2008

03:25

x86

Failoverclusters.validation.common.dll

6.0.6001.22189

24,576

29-May-2008

03:25

x86

Failoverclusters.validation.generaltests.dll

6.0.6001.22189

262,144

29-May-2008

03:25

x86

Failoverclusters.validation.storagetests.dll

6.0.6001.22189

152,576

29-May-2008

03:25

x86

Failoverclusters.validation.wizard.dll

6.0.6001.22189

147,456

29-May-2008

03:25

x86

Windows Server 2008, Itanium-based versions

File name

File version

File size

Date

Time

Platform

Failoverclusters.agent.interop.dll

6.0.6001.22189

11,264

29-May-2008

03:56

IA-64

Failoverclusters.validation.common.dll

6.0.6001.22189

24,576

29-May-2008

03:56

x86

Failoverclusters.validation.generaltests.dll

6.0.6001.22189

262,144

29-May-2008

03:56

x86

Failoverclusters.validation.storagetests.dll

6.0.6001.22189

169,472

29-May-2008

03:56

IA-64

Failoverclusters.validation.wizard.dll

6.0.6001.22189

147,456

29-May-2008

03:56

x86

Windows Server 2008, 64-bit editions

File name

File version

File size

Date

Time

Platform

Failoverclusters.agent.interop.dll

6.0.6001.22189

11,264

29-May-2008

03:58

x64

Failoverclusters.validation.common.dll

6.0.6001.22189

24,576

29-May-2008

03:58

x86

Failoverclusters.validation.generaltests.dll

6.0.6001.22189

262,144

29-May-2008

03:58

x86

Failoverclusters.validation.storagetests.dll

6.0.6001.22189

156,160

29-May-2008

03:58

x64

Failoverclusters.validation.wizard.dll

6.0.6001.22189

147,456

29-May-2008

03:58

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

The Validate a Configuration Wizard performs tests, and then it checks on the nodes of a cluster to verify that they will function correctly in a failover cluster. One of the checks is related to the version of the operating systems. The wizard verifies that each server has a valid version to run the Windows Server Failover Cluster and that these versions will function correctly together in a failover cluster. Some version requirements must be met to pass this validation. After you apply this update, you may still receive an error that indicates incorrect configuration of the servers that are validated. For example, this error occurs if you have a mix of Server Core and full installations of Windows Server 2008 in a failover cluster.

The following is an example of the message that may appear during cluster validation when an operating system does not meet validation requirements:

Validate that the operating systems on the servers support clustering and will interoperate.
Validating that all servers have the same operating system version...
node1.domain.com has version 6.0.6001 of Microsoft Windows installed.
node1.domain.com has the following operating system suite type(s): Enterprise Server, Terminal Server, Single User.
node2.domain.com has version 6.0.6001 of Microsoft Windows installed.
node2.domain.com has the following operating system suite type(s): Enterprise Server, Terminal Server, Single User.
Validating that all servers have valid operating system product suite types...
node1.domain.com is running a Windows operating system that supports Failover Clusters.
Validating that all servers have valid operating system product suite types...
node2.domain.com is running a Windows operating system that supports Failover Clusters.
The operating system SKU is not compatible.For more information about how to validate a failover cluster, visit the following Microsoft Web sites:

http://technet.microsoft.com/en-us/library/bb676379(EXCHG.80).aspx

http://technet2.microsoft.com/windowsserver/en/library/32c40202-1043-4211-8dba-bb57356f46811033.mspx

http://microsoft.com/windowsserver2008/en/us/clustering-program.aspxFor more information about the Microsoft support policy for Windows Server 2008 failover clusters, click the following article number to view the article in the Microsoft Knowledge Base:

943984 The Microsoft Support Policy for Windows Server 2008 Failover Clusters

References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×