Symptoms
Consider the following scenario:
-
You install the Remote Desktop Gateway (RD Gateway) service on a computer that is running Windows Server 2008 R2.
-
There are multiple certificate bindings on the port 443 of this computer.
In this scenario, the RD Gateway may not work correctly. The incorrect behavior depends on the certificate store name of the selected certificate binding. The following two values of the certificate store name for the binding causes different issues:
-
Certificate store name is not NULL for the binding
In this case, all connections go through except in the following scenarios:-
Smart card authentication is configured on the RD Gateway-side.
-
Network Access Protection health checks are enforced on the client-side.
-
-
Certificate store name is NULL for the binding
In this case, all connections fail together, and you receive the following error message:Your computer can't connect to the remote computer because no certificate was configured to use at the Remote Desktop Gateway server. Contact your network administrator for assistance.
At the same time, the following TerminalServices-Gateway event that has the ID 306 is added to the TerminalServices-Gateway log:
Note To check whether the certificate store name is NULL, follow these steps:-
At the command prompt, type the following command, and then press ENTER:
netsh http show sslcert
-
Check the value for Certificate Store Name of the first binding that is listening on port 443. A value of (null) indicates that the certificate store name is NULL for that particular binding.
-
Cause
The issues occur because the RD Gateway service retrieves an incorrect certificate binding.
Resolution
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.
Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, the computer must be running Windows Server 2008 R2.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone
tab in the
Date and Time
item in Control Panel.
For all supported x64-based versions of Windows Server 2008 R2
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Aaedge.dll |
6.1.7600.20546 |
304,128 |
10-Oct-2009 |
06:12 |
x64 |
Aaedge.mof |
Not Applicable |
1,268 |
10-Jun-2009 |
20:31 |
Not Applicable |
Aatspp.dll |
6.1.7600.16385 |
65,024 |
14-Jul-2009 |
01:39 |
x64 |
Aatspp.mof |
Not Applicable |
1,271 |
10-Jun-2009 |
20:31 |
Not Applicable |
Rap.xml |
Not Applicable |
895 |
10-Jun-2009 |
20:31 |
Not Applicable |
Tsgateway.xml |
Not Applicable |
429 |
10-Jun-2009 |
20:31 |
Not Applicable |
Tsgclean.exe |
6.1.7600.16385 |
428,032 |
14-Jul-2009 |
01:39 |
x64 |
Tsproxy-edgeadapter-ppdlic.xrm-ms |
Not Applicable |
3,018 |
10-Oct-2009 |
08:55 |
Not Applicable |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information for Windows Server 2008 R2
Additional files for all supported x64-based versions of Windows Server 2008 R2
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Amd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.20546_none_9ab543bbff629cbd.manifest |
Not Applicable |
99,560 |
11-Oct-2009 |
19:00 |
Not Applicable |
Package_for_kb976484_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mum |
Not Applicable |
1,458 |
11-Oct-2009 |
19:00 |
Not Applicable |