Una actualización está disponible para equipos basados en Windows Server 2008 para resolver problemas con la copia de seguridad y restauración de máquinas virtuales de Hyper-V

Se aplica a: Windows Server 2008 DatacenterWindows Server 2008 EnterpriseWindows Server 2008 Standard

Síntomas


Este artículo describe los problemas corregidos en esta actualización de Hyper-V para equipos basados en Windows Server 2008 que ha habilitado la función de Hyper-V.

Problema 1

Si copia una máquina virtual Hyper-V que tiene varios volúmenes, puede fallar la copia de seguridad. Si activa el registro de sucesos de VMM después de que se produzca el error de copia de seguridad, se registra el suceso siguiente:

Problema 2

El escritor de VSS de Microsoft Hyper-V puede entrar un estado inestable si se produce un error en una copia de seguridad de la máquina virtual de Hyper-V. Si ejecuta el comando vssadmin escritores de lista , el escritor de VSS de Microsoft Hyper-V no aparece. Para devolver el escritor de VSS de Hyper-V de Microsoft a un estado estable, debe reiniciarse el servicio de administración de máquinas virtuales de Hyper-V.

Problema 3

No puede restaurar una máquina virtual Hyper-V si la máquina virtual se ha configurado para utilizar un adaptador de red heredado.

Solución


Para resolver este problema, instale el service pack o la actualización que se describe en esta sección. Después de instalar la actualización en el equipo Host, deberá instalar los componentes de integración actualizados en cada equipo invitado antes de esta actualización, pasa a ser totalmente efectiva. Para ello, abra la conexión de máquina Virtual para el equipo invitado en el Administrador de Hyper-V y, a continuación, seleccione la opción de Insertar un disco de instalación de servicios de integración en el menú acción . Instalación de los servicios de integración se inicia automáticamente en el equipo invitado, pero debe hacer clic en para continuar.


Notas:
  • En un equipo basado en Windows Server 2008, los servicios de integración actualizados aparecen como KB960242 en el elemento programas y características en el Panel de Control.
  • En un equipo basado en Windows Vista, los servicios de integración actualizados aparecen como KB960243 en el elemento programas y características en el Panel de Control.

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Server 2008. Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
968849 cómo obtener el service pack más reciente para Windows Server 2008

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Revisiones importantes de Windows Vista y Windows Server 2008 se incluyen en los mismos paquetes. Sin embargo, sólo uno de estos productos puede aparecer en la página "Solicitud de revisión". Para solicitar el paquete de revisiones que se aplica a Windows Vista y Windows Server 2008, seleccione el producto que aparece en la página.

Requisitos previos

Antes de aplicar esta actualización, debe instalarse la versión de lanzamiento de Hyper-V. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
950050 descripción de la actualización de la versión de la tecnología Hyper-V para Windows Server 2008

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones publicadas anteriormente.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.

Notas sobre la información de archivo de Windows Server 2008

Los archivos .manifest y .mum instalados en cada entorno están enumerados por separado en la sección "información adicional de archivos para las versiones de 64 bits de Windows Server 2008". Estos archivos y sus archivos asociados .cat (catálogo de seguridad) son esenciales para el mantenimiento del estado del componente actualizado. Los archivos .cat están firmados con una firma digital de Microsoft. No se enumeran los atributos de estos archivos de seguridad.
Windows Server 2008, versiones de 64 bits
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Vmms.exe6.0.6001.223523,872,25613-Jan-200902:42x64
Blank.vfdNo aplicable1,474,56018-Dec-200721:18No aplicable
Vid.dll6.0.6001.2235237,88813-Jan-200905:01x64
Vmbuspipe.dll6.0.6001.2235215.87213-Jan-200905:01x64
Vmbusvdev.dll6.0.6001.2235283,96813-Jan-200905:01x64
Vmguest.isoNo aplicable42,584,06421-Dec-200823:20No aplicable
Vmprox.dllNo aplicable178,68813-Jan-200905:01x64
Vmwpctrl.dll66.0.6001.2235287,04013-Jan-200905:01x64
Windowsvirtualization.mofNo aplicable406,53613-Jan-200900:52No aplicable
Windowsvirtualizationuninstall.mofNo aplicable57211-Jul-200820:06No aplicable

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos para las versiones de 64 bits de Windows Server 2008

Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Amd64_5ea2a0e012fba496634951da2e3c633f_31bf3856ad364e35_6.0.6001.22352_none_898535921950c54c.manifestNo aplicable70314-Jan-200900:09No aplicable
Amd64_08d4dc4f14b70e82efea40a20802f63d_31bf3856ad364e35_6.0.6001.22352_none_c03e75641cbceedb.manifestNo aplicable69814-Jan-200900:09No aplicable
Amd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.0.6001.22327_none_932fa5e93071aa4d.manifestNo aplicable249,72313-Jan-20095:28No aplicable
Amd64_microsoft-hyper-v-vstack_31bf3856ad364e35_6.0.6001.22327_none_c157114ac5a25cab.manifestNo aplicable45,50813-Jan-20095:23No aplicable
Package_1_for_kb959962~31bf3856ad364e35~amd64~~6.0.3.0.mumNo aplicable2,56314-Jan-200900:09No aplicable
Package_2_for_kb959962~31bf3856ad364e35~amd64~~6.0.3.0.mumNo aplicable2,56314-Jan-200900:09No aplicable
Package_for_kb959962_sc_0~31bf3856ad364e35~amd64~~6.0.3.0.mumNo aplicable1.52814-Jan-200900:09No aplicable
Package_for_kb959962_sc~31bf3856ad364e35~amd64~~6.0.3.0.mumNo aplicable1.43014-Jan-200900:09No aplicable
Package_for_kb959962_server_0~31bf3856ad364e35~amd64~~6.0.3.0.mumNo aplicable1,53214-Jan-200900:09No aplicable
Package_for_kb959962_server~31bf3856ad364e35~amd64~~6.0.3.0.mumNo aplicable1,43814-Jan-200900:09No aplicable