Cómo sumar y dar formato a un intervalo de horas, minutos o segundos en Excel

Resumen

Para dar formato automáticamente a las horas que cuando se suman superan 24 horas, 60 minutos o 60 segundos, puede utilizar los siguientes formatos de número personalizados y la función SUMA de Excel:
  • Horas = [h]:mm:ss
  • Minutos = [m]:ss
  • Segundos = [ss]

Más información

En Microsoft Excel, el formato de horas personalizado ya está creado. Sin embargo, debe crear los formatos de minutos y segundos para cada libro que los necesite.

Para mostrar correctamente las horas totales mayores que 24 y los minutos y segundos totales mayores que 60, use los métodos siguientes.

Ejemplo para las horas

Para dar formato a las sumas de horas mayores de 24 horas, siga estos pasos:
  1. Cree una nueva hoja de cálculo y escriba los valores siguientes. Asegúrese de que separa los números con el carácter "dos puntos" (:).

    A1: 12:35:58
    A2: 12:24:30
    A3: 11:18:23
  2. Escriba la fórmula siguiente en la celda A4. Excel da formato automáticamente al resultado correcto si está sumando horas.

    A4: =SUMA(A1:A3)
Excel muestra 36:18:51 como el total.

Ejemplo de minutos y segundos

Para dar formato a sumas de minutos o segundos mayores que 60, siga estos pasos:
  1. Cree una nueva hoja de cálculo y escriba los valores siguientes. Asegúrese de incluir los ceros (00) a la izquierda y de usar "dos puntos" (:) para separar los números.

    A1: 00:42:58
    A2: 00:19:30
    A3: 00:37:23
  2. Escriba la fórmula siguiente en la celda A4:

    A4: =SUMA(A1:A3)
    Excel muestra 1:39:51 como el total. Para mostrar este total como minutos y segundos, o solo segundos, siga estos pasos para crear y aplicar el formato adecuado:
    1. Haga clic con el botón derecho en la celda A4 y, después, haga clic en Formato de celdas.
    2. Haga clic en la pestaña Número.
    3. En la lista Categoría, haga clic en Personalizada.
    4. En el cuadro Tipo, modifique los códigos de formato de número para crear el formato que desea.
      • Para el formato de minutos, escriba
        [m]:ss
      • Para el formato de minutos, escriba
        [ss]
    5. Seleccione el formato que desea aplicar y, después, haga clic en Aceptar.
    Después de aplicar el formato de minutos, Excel muestra 99:51 como el total.

    Después de aplicar el formato de segundos, Excel muestra 5981 como el total.
NOTA: Cuando modifica un formato integrado, Excel crea un nuevo formato, pero no sustituye el formato existente.

Cómo aplicar los formatos a celdas adicionales

Después de crear los formatos personalizados de minutos y de segundos, siga estos pasos para aplicarlos a cualquier celda adicional del libro:
  1. Haga clic con el botón derecho en las celdas que desea mostrar en el formato recién creado y haga clic en Formato de celdas.
  2. En el cuadro de diálogo, haga clic en la ficha Número y, después, en Personalizar.
  3. En la lista personalizada de formatos, haga clic en el formato apropiado y, después, haga clic en Aceptar.
Propiedades

Id. de artículo: 266691 - Última revisión: 30 jun. 2016 - Revisión: 1

Comentarios