La instalación de .NET Framework 4.7 está bloqueada en Windows 7, Windows Server 2008 R2 y Windows Server 2012 debido a la falta de actualización de d3dcompiler

Se aplica a: Microsoft .NET Framework 4.7

Síntomas


Cuando intenta instalar Microsoft .NET Framework 4.7 en un equipo que ejecuta Windows 7 Service Pack 1 (SP1), Windows Server 2008 R2 SP1 o Windows Server 2012, la instalación está bloqueada y no puede continuar.

.netFramework

Este problema se produce cuando el equipo no tiene instalada la actualización para D3DComplier (D3DCompiler_47. dll).

Causa


.NET Framework 4.7 en Windows 7 SP1, Windows Server 2008 R2 SP1 y Windows Server 2012 tiene una nueva dependencia en un archivo %windir%\system32\d3dcompiler_47.dll para WPF. Este archivo debe instalarse antes de que se pueda instalar el producto .NET Framework 4.7.

Solución alternativa


Para solucionar este problema, instale la actualización d3dcompiler de los siguientes vínculos antes de instalar .NET Framework 4.7. La actualización también está disponible en el Catálogo de Microsoft Update y a través de Windows Update.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".