Experimenta rendimiento lento cuando realiza consultas de RetrieveMultiple en grandes conjuntos de datos en el año 2011 de Microsoft Dynamics CRM

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 2535245
Síntomas
Al realizar consultas de RetrieveMultiple en grandes conjuntos de datos en Microsoft Dynamics CRM 2011, experimenta un rendimiento lento.
Causa
Este problema se produce porque los planes de consulta de SQL de Microsoft para las consultas de RetrieveMultiple de la caché de grandes conjuntos de datos. La optimización de RetrieveMultiple para la profundidad básica es necesaria para la "profundidad local" privilegio de lectura y para la "profundidad profunda" privilegio de lectura.
Solución
Importante Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para mayor protección, hacer la copia del registro antes de modificarlo. Luego puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo realizar copias de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro en Windows


Este problema se corrige en el paquete de continuación de la actualización acumulativa más reciente para 2011 de Microsoft Dynamics CRM. Para obtener más información acerca de la actualización acumulativa de rollup más reciente para 2011 de Microsoft Dynamics CRM, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2466086 Está disponible el paquete acumulativo de actualizaciones 2 para 2011 de Microsoft Dynamics CRM

Si se instala la actualización de Rollup 8 o un paquete de continuación de upudate anterior, siga estos pasos para habilitar esta revisión en el equipo que ejecuta Microsoft Dynamics CRM 2011:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedit en el Abrir cuadro y haga clic en ACEPTAR.
  2. Busque y, a continuación, haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\
  3. En el Editar menú, elija Nuevoy, a continuación, haga clic en Valor DWORD.
  4. Nombre de la entrada de Registro DWORD recién creado escribiendoEnableRetrieveMultipleOptimization.
  5. Con el botón derecho EnableRetrieveMultipleOptimizationy, a continuación, haga clic en Modificar.
  6. En el Información del valor cuadro, escriba 2y, a continuación, haga clic en ACEPTAR.

    Nota
    El valor predeterminado es 0.
  7. En el Archivo menú, haga clic en Salir.
Si Update Rollup 10 o un conjunto de actualizaciones posterior está instalado, consulte la sección "Optimizar el rendimiento de las consultas contra grandes conjuntos de datos" de las notas de "Optimizar y mantener el rendimiento de una Microsoft Dynamics CRM 2011 servidor infraestructura". Para descargar el documento técnico, visite el siguiente sitio Web de centro de descarga de Microsoft:
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".
Más información
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Para obtener más información acerca de la terminología de paquete de actualización y revisión del software Microsoft Business Solutions CRM, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
887283Estándares de nomenclatura de paquete de actualizaciones y revisiones de software de Microsoft Business Solutions CRM

Propiedades

Id. de artículo: 2535245 - Última revisión: 08/15/2012 22:44:00 - Revisión: 2.0

Microsoft Dynamics CRM 2011

  • kbqfe kbfix kbmbsmigrate kbexpertiseinter kbsurveynew kbmt KB2535245 KbMtes
Comentarios