Estás trabajando sin conexión, espera a que vuelva la conexión a Internet

Experimenta un rendimiento deficiente al usar Buscar horas disponibles en el año 2011 de Microsoft Dynamics CRM

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 2651621
Síntomas
Cuando intenta utilizar la característica de programación de recursos buscar horas disponibles en Microsoft Dynamics CRM, experimenta un rendimiento deficiente. Si volver a utilizar Buscar horas disponibles y comenzar una nueva consulta, mejora el rendimiento y los resultados necesitan mucho menos tiempo.
Causa
Este problema se produce porque la implementación de Microsoft Dynamics CRM contiene muchas entidades relacionadas con la programación y se ejecutan varias consultas SQL para recuperar los registros individuales durante el proceso de programación de recursos de encontrar tiempo disponible.
Solución
Para resolver este problema, descargue e instale Update Rollup 8 para Microsoft Dynamics CRM. Para ello, consulte el siguiente artículo en Microsoft Knowledge Base:
2600644 Está disponible el paquete acumulativo de actualizaciones 8 para Microsoft Dynamics CRM 2011

Después de instalar el paquete de actualización, debe crear la siguiente clave del registro en el servidor CRM para las entidades relacionadas con la programación:
SchedulingEngine.CacheConfiguration
Después de hacer esto, estas entidades se agregará a la caché para optimizar el rendimiento.

Para crear la clave del registro, siga estos pasos:
  1. En el servidor de Microsoft Dynamics CRM, elija la Inicio menú y, a continuación, escriba Regedit en el cuadro de búsqueda para abrir el Editor del registro.
  2. Busque la siguiente subclave del registro:
    HKEY_Local_Machine\Software\Microsoft\MSCRM
  3. Con el botón secundario MSCRM, seleccione Nuevoy, a continuación, haga clic en Valor de cadena.
  4. Tipo SchedulingEngine.CacheConfiguration.
  5. (Ratón) en la nueva clave y, a continuación, haga clic en Modificar. Las modificaciones que realice se asemejará a lo siguiente XML. Sin embargo, las modificaciones realizadas dependerá de las entidades y las opciones que desee utilizar. Consulte la sección "Más información" para obtener información detallada.
    <CachingModes><CachingMode name="BookCaching"><Calendar>DefaultCache</Calendar><CalendarRule>DefaultCache</CalendarRule><Commitment>DefaultCache</Commitment><ConstraintGroup>DefaultCache</ConstraintGroup><Equipment>Direct</Equipment><PluginType>DefaultCache</PluginType><Resource>Direct</Resource><ResourceGroup>DefaultCache</ResourceGroup><ResourceExpansion>DefaultCache</ResourceExpansion><ResourceGroupExpansion>DefaultCache</ResourceGroupExpansion><ResourceSpec>Direct</ResourceSpec><Schedule>DefaultCache</Schedule><Service>DefaultCache</Service><SystemUser>Direct</SystemUser><Team>DefaultCache</Team></CachingMode> <CachingMode name="SearchCaching"><Calendar>DefaultCache</Calendar>... (and other entities like above)</CachingMode><CachingMode name="PublishResourceGroupsCaching"><Calendar>Direct</Calendar>
    (y otras entidades similares)
    </CachingMode></CachingModes>
Más información
Para cada entidad que se agrega a la caché, hay dos valores posibles: Directa y DefaultCache.
  • Un valor de DefaultCacheintenta optimizar en el número de consultas SQL y recupera todos los registros a la vez mediante el uso de una sola consulta. Después de recuperarán todos los registros, los datos se almacenan en la caché HTTP.
  • Un valor de Directa consultas para cada registro mediante el uso de una consulta SQL independiente.

Nota Si agrega más entidades a la caché, uso de memoria puede aumentar ligeramente debido a un tamaño de caché mayor.

Hay tres tipos de modo:
  • SearchCaching. Cuando utiliza "Buscar horas disponibles" o se ejecuta la validación de la cita de servicio
  • BookCaching.Utilizado cuando se va a guardar una cita de servicio
  • PublishResourceGroupCaching. Utilizado cuando se reorganizan los grupos de recursos y se lleva a cabo "publicar el árbol de recursos"
El modo de algunas entidades se puede establecer colectivamente mediante el uso de la etiqueta de los recursos y la etiqueta ResourceGroups . O bien, las entidades se pueden establecer por separado en un nivel muy detallado.

Las entidades de los recursos incluyen los siguientes subtipos:
  • Equipo
  • SystemUsers
  • ResourceSpec
ResourceGroups entidades incluyen los siguientes subtipos:
  • ConstraintBasedGroup
  • Equipo
Programación de servicios, rendimiento, memoria caché

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 2651621 - Última revisión: 05/13/2012 15:50:00 - Revisión: 1.0

Microsoft Dynamics CRM 2011

  • kbautohotfix kbqfe kbhotfixserver kbfix kbmt KB2651621 KbMtes
Comentarios
.com/c.gif?DI=4050&did=1&t=">=4050&did=1&t=">>/html>