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No se puede cambiar los permisos de acceso de una carpeta de calendario en un entorno de Exchange Server 2010

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Haga clic aquí para ver el artículo original (en inglés): 2674445
Síntomas
Tenga en cuenta la situación siguiente:
  • Tiene una aplicación de terceros que establece un orden incorrecto de la lista de control de acceso de una carpeta de calendario en un buzón.
  • Mover el buzón que contiene la carpeta de calendario a un servidor de buzón Microsoft Exchange Server 2010. La operación se completa correctamente.
  • Intente cambiar el permiso de acceso de la carpeta calendario mediante una aplicación de servicio Web de Exchange (EWS), o mediante una aplicación MAPI, como Microsoft Outlook.
En este escenario, no puede cambiar los permisos de acceso de la carpeta Calendario.
Causa
Este problema se produce debido a un error cuando el almacén de Exchange valida las listas de control de acceso canónica. Por lo tanto, la aplicación MAPI o EWS no puede recuperar la tabla de lista de control de acceso de la carpeta Calendario.
Solución
Para resolver este problema, instale el paquete siguiente:
2685289 Descripción del paquete acumulativo de actualizaciones 3 para Service Pack 2 de Exchange Server 2010

Después de instalar la actualización, puede habilitar la validación de las ACL canónicas configurando una clave del registro. Para que habilitar la validación de las ACL canónicas para usted, vaya a la "Corregir por mí"sección. Si desea habilitar la validación de las ACL canónicas usted mismo, vaya a la "Voy a arreglarlo yo mismo"sección.

Corregir por mí



Para habilitar la validación de las ACL canónicas automáticamente, haga clic en el Corregirlo botón o vínculo. A continuación, haga clic en Ejecutar en el Descarga de archivos diálogo cuadro y siga los pasos del Asistente para corregirlo .




Notas
  • Instalar la actualización que se describe en el artículo de Microsoft Knowledge Base (KB) 2685289 antes de ejecutar esto corregirlo solución.
  • Este asistente puede estar sólo en inglés. Sin embargo, la corrección automática también funciona para otras versiones de idioma de Windows.
  • Si no está en el equipo que tiene el problema, guarde la solución la solución a una unidad flash o un CD y, a continuación, ejecutarla en el equipo que tiene el problema.

A continuación, vaya a la "¿Esto soluciona el problema?"sección.



Voy a arreglarlo yo mismo

Para habilitar la validación de las ACL canónicas configurando una clave del registro, siga estos pasos:
  1. Abra el Editor del registro. Para ello, haga clic en Inicio, tipo Regedit en el Iniciar búsqueda cuadro y, a continuación, presione ENTRAR.
  2. Busque y, a continuación, haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
  3. En el Editar menú, elija Nuevoy, a continuación, haga clic en DWORD (32 bits) de valor.
  4. Tipo CheckCanonicalACLDuringMove, y, a continuación, presione ENTRAR.
  5. En el Editar menú, haga clic en Modificar.
  6. En el Valor de datos cuadro, escriba 1y, a continuación, haga clic en Aceptar.
  7. Salga del Editor del registro.
Después de habilita la validación de la característica de listas de control de acceso canónica, no se puede mover las carpetas en el que no está en un orden canónico la lista de control de acceso. Además, recibirá el siguiente mensaje de error cuando intenta mover la carpeta:
Error: MapiExceptionInvalidParameter: no se puede establecer las propiedades de objeto. (hr = 0 x 80070057, CE =-2147024809)
Contexto de diagnóstico:
Tapa: 55847 EMSMDBPOOL.EcPoolSessionDoRpc llamado [longitud = 267]
Tapa: 43559 EMSMDBPOOL.EcPoolSessionDoRpc devolvió [CE = 0 x 0] [longitud = 232] [latencia = 0]
Tapa: inicio de análisis ROP 23226------
Tapa: 27962 ROP: ropSetProps [10]
Tapa: 17082 ROP Error: 0 x 80070057
Tapa: 30561
Tapa: 21921 StoreEc: 0 x 80070057
Tapa: 27962 ROP: ropExtendedError [250]
Tapa: 1494---contexto remoto Beg---
Tapa: 26426 ROP: ropSetProps [10]
Tapa: 21970 StoreEc: 0x8004010F protag: 0x668F0040
Tapa: 25000
Tapa: 24936
Tapa: 24952
Tapa: 47113
Tapa: 7915 StoreEc: 0 x 80070057
Tapa: 5263 StoreEc: 0 x 80070057
Tapa: 19768
Tapa: 4559 StoreEc: 0 x 80070057
Tapa: 1750---final de contexto remoto---
Tapa: 26849
Tapa: 21817 ROP error: 0 x 80070057
Tapa: 25761
Tapa: 1940 StoreEc: 0 x 80070057
Tapa: 25297
Tapa: 21201 StoreEc: 0 x 80070057

¿Esto soluciona el problema?

  • Compruebe si el problema está solucionado. Si se soluciona el problema, ya ha terminado con esta sección. Si no se soluciona el problema, puede Póngase en contacto con soporte técnico.
  • Agradeceríamos sus comentarios. Para proporcionar comentarios o informar de cualquier problema con esta solución, deja un comentario en el "Corregir por mí"blog o envíenos un correo electrónico.
Más información
Para obtener más información acerca de las listas de control de acceso, vaya al sitio Web de Microsoft siguiente:Para obtener más información acerca de las entradas de control de acceso, vaya al sitio Web de Microsoft siguiente:Para obtener más información acerca de cómo utilizar Visual Basic y ADsSecurity.dll para ordenar adecuadamente las ACE de una ACL, vaya al sitio Web de Microsoft siguiente:
FixIt corregirlo fixme

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 2674445 - Última revisión: 10/12/2012 10:07:00 - Revisión: 2.0

Microsoft Exchange Server 2010 Service Pack 2

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