Estás trabajando sin conexión, espera a que vuelva la conexión a Internet

Cómo agregar campos de búsqueda en una tabla de Microsoft Access

Ha finalizado el soporte técnico para Office 2003

Microsoft puso fin al soporte técnico para Office 2003 el 8 de abril de 2014. Este cambio ha afectado a las actualizaciones de software y las opciones de seguridad. Sepa qué significa esto en su caso y cómo puede mantenerse protegido.

Principiante: se requieren conocimientos de la interfaz de usuario en equipos de usuario único.

Para obtener una versión de Microsoft Access 2000 de este artículo, consulte 304463.
Para obtener una versión de Microsoft Access 97 de este artículo, consulte 304464.
Resumen
En Microsoft Access puede agregar un campo a una tabla para buscar información en otra tabla. Esta técnica se utiliza normalmente cuando desea crear relaciones entre tablas. Por ejemplo, quizás tenga una tabla Productos con un campo Categoría que busque el nombre de categoría en una tabla Categorías. Mediante esta técnica puede almacenar el valor de clave principal sólo en la tabla Categorías y mostrar el nombre más útil Categoría.

En este artículo se muestra cómo agregar campos de búsqueda a una tabla de Microsoft Access. Primero muestra cómo utilizar un asistente para agregar el campo de búsqueda y después muestra cómo agregar manualmente el campo de búsqueda.
Más información

Utilizar un asistente para crear un campo de búsqueda

  1. Inicie Access.
  2. En el menú Ayuda, haga clic en Bases de datos de ejemplo y, a continuación, haga clic en Base de datos de ejemplo Northwind. Cierre el formulario Panel de control principal cuando aparezca.

    Nota: en Access 2007, haga clic en Ejemplo en el panel Categorías de plantillas, haga clic en Northwind 2007 y, a continuación, haga clic en Descargar.
  3. En el menú Ver, haga clic en Objetos de la base de datos y, después, haga clic en Tablas.

    Nota: en Access 2007, en el grupo Tablas de la ficha Crear, haga clic en Diseño de tabla.
  4. Haga doble clic en Crear una tabla en vista Diseño para crear una nueva tabla.

    Nota: en Access 2007, omita este paso.
  5. Escriba BuscarEmpleado en la primera fila bajo Nombre de campo.
  6. En la columna Tipo de datos, seleccione Asistente para búsquedas.
  7. En la primera página del Asistente para búsquedas, haga clic para activar la casilla Deseo que la columna de búsqueda busque los valores en una tabla o consulta y, a continuación, haga clic en Siguiente.
  8. Haga clic en la tabla Employees en la lista de tablas y, a continuación, haga clic en Siguiente.
  9. Haga doble clic en los campos EmployeeID, LastName y FirstName para agregar los campos a la lista de campos seleccionados y, a continuación, haga clic en Siguiente dos veces.
  10. Asegúrese de que la casilla Ocultar la columna clave esté activada y haga clic en Siguiente.
  11. Haga clic en Finalizar en la última página del Asistente para búsquedas.
  12. Haga clic en para guardar la tabla cuando se le pida confirmación y asigne el nombre ProbarAsistenteBúsquedas a la tabla.
  13. Haga clic en para agregar una clave principal a la tabla cuando se le pida.

    Observe que el asistente creará una relación entre la nueva tabla y la tabla Employees de la base de datos de ejemplo Northwind.
  14. En el menú Ver, haga clic en Vista Hoja de datos.

    Nota: en Access 2007, abra la tabla en la vista Hoja de datos.
  15. Haga clic en la flecha desplegable del campo BuscarEmpleado.

    Observe que aparecen dos columnas en el cuadro combinado.

Crear manualmente un campo de búsqueda

  1. Inicie Access.
  2. En el menú Ayuda, haga clic en Bases de datos de ejemplo y, a continuación, haga clic en Base de datos de ejemplo Northwind. Cierre el formulario Panel de control principal cuando aparezca.

    Nota: en Access 2007, haga clic en Ejemplo en el panel Categorías de plantillas, haga clic en Northwind 2007 y, a continuación, haga clic en Descargar.
  3. En el menú Ver, haga clic en Objetos de la base de datos y, después, haga clic en Tablas.

    Nota: en Access 2007, en el grupo Tablas de la ficha Crear, haga clic en Diseño de tabla.
  4. Haga doble clic en Crear una tabla en vista Diseño para crear una nueva tabla.

    Nota: en Access 2007, omita este paso.
  5. Escriba BuscarEmpleado en la primera fila bajo Nombre de campo.
  6. En la columna Tipo de datos, haga clic en Número.
  7. En la ventana Propiedades del campo, haga clic en la ficha Búsqueda.
  8. En la lista .PresentarControl, haga clic en Cuadro combinado.
  9. Haga clic en el cuadro de la propiedad OrigenDeLaFila, haga clic en la flecha que aparecerá, haga clic en Employees en la lista y, a continuación, haga clic en Generar para abrir el Generador de consultas.
  10. Haga doble clic en los campos EmployeeID, LastName y FirstName para agregar los campos a la cuadrícula de la consulta.
  11. En el grupo Cerrar de la ficha Diseño, haga clic en Cerrar para salir del Generador de consultas.
  12. Haga clic en cuando se le pregunte si desea guardar los cambios a la instrucción SQL.
  13. Asegúrese de que la propiedad ColumnaDependiente esté establecida en 1.

    Nota: esta propiedad corresponde al campo del origen de la fila que está guardado en el campo. En este ejemplo, el campo BuscarEmpleado almacena el valor EmployeeID de la tabla Employees.
  14. Cambie el valor de la propiedad NúmeroDeColumnas a 3.

    Nota: este valor representa el número de campos seleccionados en el origen de la fila.
  15. Escriba 0";1";1" en el cuadro AnchuraDeColumnas.

    Nota: la propiedad AnchuraDeColumnas es una lista delimitada por signos de punto y coma de los anchos de cada columna del origen de la fila. Establezca un ancho de columna en 0" si desea ocultar la columna.
  16. Escriba 2" en el cuadro AnchuraDeLaLista.
  17. En el menú Ver, haga clic en Vista Hoja de datos.

    Nota: en Access 2007, abra la tabla en la vista Hoja de datos.
  18. Haga clic en para guardar la tabla cuando se le pida confirmación y asigne el nombre ProbarAsistenteBúsquedas2 a la tabla.
  19. Haga clic en para agregar una clave principal a la tabla cuando se le pida.
  20. Haga clic en la flecha desplegable del campo BuscarEmpleado.

    Observe que aparecen dos columnas en el cuadro combinado.
OfficeKBHowTo inf Acc2002 Acc2003 ACC2007
Propiedades

Id. de artículo: 304462 - Última revisión: 12/27/2007 10:16:49 - Revisión: 5.1

Microsoft Office Access 2007, Microsoft Office Access 2003, Microsoft Access 2002 Standard Edition

  • kbinfo kbexpertisebeginner kbdesign kbdatabase kbhowto KB304462
Comentarios