La fórmula de matriz derramada que está intentando introducir se extenderá más allá del rango de la hoja de cálculo. Inténtalo de nuevo con un rango o matriz más pequeño.

En el ejemplo siguiente, mover la fórmula a la celda F1 resolverá el error y la fórmula se reproducirá correctamente.

#SPILL! error en el que =ORDENAR(D:D) en la celda F2 se extenderá más allá de los bordes del libro. Muévelo a la celda F1 y funcionará correctamente.

Causas comunes: referencias de columna completas

A menudo es un método mal entendido de crear fórmulas de BUSCARV mediante la especificación del argumento lookup_value . Antes de que la matriz dinámica admita Excel, Excel solo tendría en cuenta el valor de la misma fila que la fórmula y omitiría cualquier otra, puesto que BUSCARV esperaba solo un único valor. Con la introducción de las matrices dinámicas, Excel considera todos los valores proporcionados al lookup_value. Esto significa que si se proporciona una columna completa como el lookup_value argumento, Excel intentará buscar todos los valores de 1.048.576 en la columna. Una vez que lo haya hecho, intentará enviarlos a la cuadrícula y es muy probable que el final de la cuadrícula se quede en un #SPILL. .  

Por ejemplo, cuando se coloca en la celda E2 como en el ejemplo siguiente, la fórmula = BUSCARV (A:A, A:C, 2, falso) solo buscaría el identificador en la celda a2. Sin embargo, en la matriz dinámica de Excel, la fórmula provocará un #SPILL. error porque Excel buscará en toda la columna, devolverá resultados de 1.048.576 y saltará al final de la cuadrícula de Excel.

#SPILL! error causado con =BUSCARV(A:A,A:D,2,FALSO) en la celda E2, porque los resultados se desbordaban más allá del borde de la hoja de cálculo. Mueva la fórmula a la celda E1 y funcionará correctamente.

Hay tres formas sencillas para resolver este problema:

#

Llegando

Fórmula

1

Haga referencia solo a los valores de búsqueda que le interesan. Este estilo de fórmula devolverá una matriz dinámica, pero no funciona con tablas de Excel

Use =BUSCARV(A2:A7,A:C,2,FALSO) para devolver una matriz dinámica que no dará como resultado una #SPILL. .

= BUSCARV (a2: A7, A:C, 2, falso)

2

Haga referencia solo al valor en la misma fila y, a continuación, copie la fórmula hacia abajo. Este estilo de fórmula tradicional funciona en tablas, pero no devolverá una matriz dinámica.

Use el BUSCARV tradicional con una única referencia lookup_value: =BUSCARV(A2,A:C,32,FALSO). Esta fórmula no devolverá una matriz dinámica, pero se puede usar con Excel tablas.

= BUSCARV (a2; A:C; 2; falso)

3

Solicite que Excel realice una intersección implícita con el operador @ y, a continuación, copie la fórmula hacia abajo. Este estilo de fórmula funciona en tablas, pero no devolverá una matriz dinámica.

Use el operador @ y copie hacia abajo: =BUSCARV(@A:A,A:C,2,FALSO). Este estilo de referencia funcionará en tablas, pero no devolverá una matriz dinámica.

= BUSCARV (@A: A, A:C, 2, falso)

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Función FILTRAR

Función MATRIZALEAT

Función SECUENCIA

Función ORDENAR

Función ORDENARPOR

Función UNICOS

Errores #SPILL! en Excel

Matrices dinámicas y comportamiento de matriz desbordada

Operador de intersección implícita: @

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×