Cómo corregir un #REF! error

Cómo corregir un #REF! error

El error #¡REF! muestra cuándo una fórmula se refiere a una celda que no es válida. Esto ocurre la mayoría de las veces cuando las celdas a las que se hace referencia mediante fórmulas se eliminan o se pegan encima.

Ejemplo: el error #¡REF! se ha provocado al eliminar una columna

En el siguiente ejemplo se usa la fórmula =SUMA(B2,C2,D2) en la columna E.

Una fórmula que usa referencias de celda explícitas como =SUMA(B2,C2,D2) puede provocar un error #¡REF! si se elimina una columna.

Si eliminara las columnas B, C o D, se produciría un #REF! . En este caso, eliminaremos la columna C (Ventas de 2007) y la fórmula ahora dice =SUMA(B2,#REF!,C2). Cuando usa referencias de celda explícitas como esta (donde hace referencia a cada celda individualmente, separadas por una coma) y elimina una fila o columna a la que se hace referencia, Excel no puede resolverla, por lo que devuelve el #REF. . Este es el motivo principal por el que no se recomienda usar referencias de celda explícitas en funciones.

Ejemplo del error #¡REF! que se ha provocado al eliminar una columna.

Solución

  • Si, por error, ha eliminado filas o columnas, puede hacer clic inmediatamente en el botón Deshacer de la Barra de herramientas de acceso rápido (o presionar CTRL+Z) para restaurarlas.

  • Ajuste la fórmula de forma que use una referencia de rango en lugar de celdas individuales, como =SUMA(B2:D2). Ahora puede eliminar cualquier columna dentro del rango de suma y Excel ajustará automáticamente la fórmula. También puede usar =SUMA(B2:B5) para sumar las filas.

Ejemplo: BUSCARV con referencias de rango incorrectas

En el siguiente ejemplo, =BUSCARV(A8,A2:D5,5,FALSO) devolverá un error #¡REF! porque está buscando un valor para devolver de la columna 5 pero el rango de referencia es A:D, que solo tiene 4 columnas.

Ejemplo de una fórmula BUSCARV con un rango incorrecto.  La fórmula es =VLOOKU(A8;A2:D5;5;FALSO).  No hay ninguna quinta columna en el rango BUSCARV, por lo que 5 causa un #REF! .

Solución

Ajuste el rango para que sea superior o reduzca el valor de búsqueda de la columna para que coincida con el rango de referencia. =BUSCARV(A8,A2:E5,5,FALSO) sería un rango de referencia válido, al igual que =BUSCARV(A8,A2:D5,4,FALSO).

Ejemplo: INDICE con una referencia de columna o fila incorrecta

En este ejemplo, la fórmula =INDICE(B2:E5,5,5) devuelve un error #¡REF! porque el rango de INDICE es de 4 filas por 4 columnas, pero la fórmula solicita que se devuelva lo que está en la quinta fila y en la quinta columna.

Ejemplo de una fórmula INDICE con una referencia de rango no válida.  La fórmula es =INDICE(B2:E5,5,5) pero el rango solo tiene 4 filas y 4 columnas.

Solución

Ajuste las referencias de fila o columna de forma que estén dentro del rango de búsqueda de INDICE. =INDICE(B2:E5,4,4) devolverá un resultado válido.

Ejemplo: hacer referencia a un libro cerrado con INDIRECTO.

En el ejemplo siguiente, una función INDIRECTO está intentando hacer referencia a un libro cerrado, lo que provoca un #REF! .

Ejemplo de un error #¡REF! que se ha provocado por INDIRECTO al hacer referencia a un libro cerrado.

Solución

Abra el libro al que se hace referencia. Encontrará el mismo error si hace referencia a un libro cerrado con una función de matriz dinámica.

Problemas de OLE

Si ha usado un vínculo de vinculación e inserción de objetos (OLE) que devuelve un #REF! y, a continuación, inicie el programa al que llama el vínculo.

Nota: OLE es una tecnología que puede usar para compartir información entre programas.

Problemas de DDE

Si ha usado un tema de Intercambio dinámico de datos (DDE) que devuelve un #REF! en primer lugar, compruebe que hace referencia al tema correcto. Si sigues recibiendo una #REF! compruebe la configuración del Centro de confianza para el contenido externo tal como se describe en Bloquear o desbloquear contenido externo en documentos de Office.

Nota: Intercambio dinámico de datos (DDE)es un protocolo establecido para intercambiar datos entre programas basados en Microsoft Windows.

Problemas de macros

Si se escribe una macro en una función de una hoja de cálculo que haga referencia a una celda situada encima de la función y la celda que contiene la función está en la fila 1, la función devolverá un error #¡REF! porque no existen celdas encima de la fila 1. Compruebe la función para ver si un argumento hace referencia a una celda o a un rango de celdas que no es válido. Esto puede requerir la edición de la macro en el Editor de Visual Basic (VBE) para tener en cuenta la situación.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en fórmulas

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×