Crear fórmulas condicionales

Probar si las condiciones son verdaderas o falsas y realizar comparaciones lógicas entre expresiones son comunes a muchas tareas. Puede usar las funciones AND, OR, NOTy SI para crear fórmulas condicionales.

Por ejemplo, la función SI usa los siguientes argumentos.

Fórmula con la función Si

Fórmula que usa la función SI

Imagen de botón logical_test: la condición que desea comprobar.

Imagen del botón value_if_true: Es el valor que se devolverá si la condición es True.

Imagen del botón value_if_false: el valor que se devolverá si la condición es False.

Para obtener más información sobre cómo crear fórmulas, vea Crear o eliminar una fórmula.

¿Qué desea hacer?

Crear una fórmula condicional que da como resultado un valor lógico (VERDADERO o FALSO)

Para realizar esta tarea, use las funciones Y, Oy NO, como se muestra en el ejemplo siguiente.

Ejemplo

El ejemplo será más fácil de entender si lo copia a una hoja de cálculo en blanco.

¿Cómo se copia un ejemplo?

  1. Seleccione el ejemplo de este artículo.

    Importante: No seleccione los encabezados de columna o de fila.

    seleccionar un ejemplo de la ayuda de Excel 2013 para Windows

    Seleccionar un ejemplo de la Ayuda

  2. Presione CTRL+C.

  3. En Excel, cree un libro o una hoja de cálculo en blanco.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante: Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  1. Para cambiar entre la visualización de resultados y la de las fórmulas que devuelven los resultados, pulse ALT+º (ordinal masculino) o, en la pestaña Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Datos

15

9

8

Sprockets

Widgets

Fórmula

Descripción (resultado)

=Y(A2>A3, A2<A4)

Determina si el valor de la celda A2 es mayor que el valor de A3 y también si el valor de A2 es menor que el valor de A4. (FALSO)

=O(A2>A3, A2<A4)

Determina si el valor de la celda A2 es mayor que el valor de A3 o si el valor de A2 es menor que el valor de A4. (VERDADERO)

=NO(A2+A3=24)

Determina si la suma de los valores de las celdas A2 y A3 no es igual a 24. (FALSO)

=NOT(A5="Sprockets")

Determina si el valor de la celda A5 no es igual a "Sprockets". (FALSO)

=O(A5<>"Sprockets",A6 = "Widgets")

Determina si el valor de la celda A5 no es igual a "Rueda dentada" o si el valor de A6 es igual a "Widgets". (VERDADERO)

Para obtener más información sobre cómo usar estas funciones, vea Función Y, Función Oy Función NO.

Principio de página

Crear una fórmula condicional que da como resultado otro cálculo o en valores distintos de VERDADERO o FALSO

Para realizar esta tarea, use las funciones yoperadores SI , Yy O, como se muestra en el ejemplo siguiente.

Ejemplo

El ejemplo será más fácil de entender si lo copia a una hoja de cálculo en blanco.

¿Cómo se copia un ejemplo?

  1. Seleccione el ejemplo de este artículo.

Importante: No seleccione los encabezados de columna o de fila.

seleccionar un ejemplo de la ayuda de Excel 2013 para Windows

Seleccionar un ejemplo de la Ayuda

  1. Presione CTRL+C.

  2. En Excel, cree un libro o una hoja de cálculo en blanco.

  3. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante: Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  1. Para cambiar entre la visualización de resultados y la de las fórmulas que devuelven los resultados, pulse ALT+º (ordinal masculino) o, en la pestaña Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Datos

15

9

8

Sprockets

Widgets

Fórmula

Descripción (resultado)

=SI(A2=15, "Aceptar", "No está bien")

Si el valor de la celda A2 es igual a 15, devuelva "Aceptar". En caso contrario, devuelva "No está bien". (Aceptar)

=SI(A2<>15, "Aceptar", "No está bien")

Si el valor de la celda A2 no es igual a 15, devuelva "Aceptar". En caso contrario, devuelva "No está bien". (No está bien)

=SI(NO(A2<=15), "Aceptar", "No está bien")

Si el valor de la celda A2 no es menor o igual que 15, devuelva "Aceptar". En caso contrario, devuelva "No está bien". (No está bien)

=SI(A5<>"SPROCKETS", "Aceptar", "No está bien")

Si el valor de la celda A5 no es igual a "SPROCKETS", devuelva "Aceptar". En caso contrario, devuelva "No está bien". (No está bien)

=SI(Y(A2>A3, A2<A4), "Aceptar", "No está bien")

Si el valor de la celda A2 es mayor que el valor de A3 y el valor de A2 también es menor que el valor de A4, devuelva "Aceptar". En caso contrario, devuelva "No está bien". (No está bien)

=SI(Y(A2<>A3, A2<>A4), "Aceptar", "No está bien")

Si el valor de la celda A2 no es igual a A3 y el valor de A2 tampoco es igual al valor de A4, devuelva "Aceptar". En caso contrario, devuelva "No está bien". (Aceptar)

=SI(O(A2>A3, A2<A4), "Aceptar", "No está bien")

Si el valor de la celda A2 es mayor que el valor de A3 o si el valor de A2 es menor que el valor de A4, devuelva "Aceptar". En caso contrario, devuelva "No está bien". (Aceptar)

=SI(O(A5<>"Sprockets", A6<>"Widgets"), "Aceptar", "No está bien")

Si el valor de la celda A5 no es igual a "Piñones" o el valor de A6 no es igual a "Widgets", devuelva "Aceptar". En caso contrario, devuelva "No está bien". (No está bien)

=SI(O(A2<>A3, A2<>A4), "Aceptar", "No está bien")

Si el valor de la celda A2 no es igual al valor de A3 o si el valor de A2 no es igual al valor de A4, devuelva "Aceptar". En caso contrario, devuelva "No está bien". (Aceptar)

Para obtener más información sobre cómo usar estas funciones, vea Función SI, Función ANDy Función O.

Principio de página

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×