En este artículo se describe el proceso básico de inicio de Access y creación de una base de datos que se usará en equipos de escritorio, no a través de la web. Se explica cómo crear una base de datos de escritorio mediante una plantilla y cómo crear una base de datos desde cero creando sus propias tablas, formularios, informes y otros objetos de base de datos. También se explican algunas técnicas que puede usar para llevar los datos existentes a la nueva base de datos.

En este artículo

Información general

Cuando se inicia Access por primera vez o si se cierra una base de datos sin cerrar Access, se muestra la vista Microsoft Office Backstage.

La vista Backstage es un punto de partida desde el que se puede crear otra base de datos, abrir una base de datos existente y ver contenido destacado de Office.com, todo aquello que Access puede hacer en un archivo de base de datos o fuera de una base de datos, por contraposición a dentro de una base de datos.

Crear una base de datos

Al abrir Access, la vista Backstage muestra la pestaña Nuevo. La pestaña Nuevo ofrece varias formas de crear una base de datos:

  • Una base de datos en blanco    Puede empezar desde cero si quiere. Se trata de una buena opción si se tienen requisitos de diseño muy concretos o datos existentes que hay que adaptar o incorporar.

  • Una plantilla que se instala con Access    Considere la posibilidad de usar una plantilla si va a iniciar un nuevo proyecto y quiere adelantar trabajo. Access incluye varias plantillas instaladas de manera predeterminada.

  • Una plantilla de Office.com    Además de las incluidas en Access, puede encontrar otras muchas plantillas en Office.com. Ni siquiera tiene que abrir un explorador, las plantillas están disponibles en la pestaña Nuevo.

Agregar a una base de datos

Cuando trabaja en una base de datos, puede agregar campos, tablas o elementos de aplicación.

Los elementos de aplicación son una característica que le permite usar varios objetos de base de datos relacionados juntos como si fueran uno solo. Por ejemplo, un elemento de aplicación podría consistir en una tabla y un formulario que se basa en la tabla. Puede agregar la tabla y el formulario al mismo tiempo mediante el elemento de aplicación.

También puede crear consultas, formularios, informes y macros: todos los objetos de base de datos con los que está acostumbrado a trabajar.

Crear una base de datos mediante una plantilla

Access incluye diversas plantillas que pueden usarse tal como están o como punto de partida. Una plantilla es una base de datos lista para usar que contiene todas las tablas, las consultas, los formularios, las macros y los informes necesarios para realizar una tarea concreta. Por ejemplo, hay plantillas que puede usar para realizar el seguimiento de problemas, administrar contactos o mantener un registro de gastos. Algunas plantillas contienen varios registros de ejemplo que demuestran su uso.

Si una de estas plantillas se ajusta a sus necesidades, usarla es la forma más rápida de iniciar una base de datos. Pero, si tiene datos en otro programa que quiere importar a Access, puede que prefiera crear una base de datos sin usar una plantilla. Las plantillas tienen una estructura de datos ya definida y puede que adaptar los datos existentes a la estructura suponga demasiado trabajo.

  1. Si tiene abierta una base de datos, haga clic en Cerrar en la pestaña Archivo. La vista Backstage muestra la pestaña Nuevo.

  2. Hay varios conjuntos de plantillas disponibles en la pestaña Nuevo, algunos de los cuales están integrados en Access. Puede descargar otras plantillas de Office.com. Vea la siguiente sección de este artículo para obtener más información.

  3. Seleccione la plantilla que quiere usar.

  4. Access propone un nombre de archivo para la base de datos en el cuadro Nombre de archivo; puede cambiarlo si quiere. Para guardar la base de datos en una carpeta distinta de la que aparece debajo del cuadro de nombre de archivo, haga clic en texto alternativo, vaya a la carpeta en la que quiere guardarla y luego haga clic en Aceptar. Si lo prefiere, puede crear la base de datos y vincularla a un sitio de SharePoint.

  5. Haga clic en Crear.

    Access crea una base de datos a partir de la plantilla elegida y luego abre la base de datos. En muchas de las plantillas se muestra un formulario en el que se pueden empezar a escribir datos. Si la plantilla contiene datos de ejemplo, puede eliminar cada uno de los registros haciendo clic en el selector de registros (el cuadro sombreado o la barra que se encuentra inmediatamente a la izquierda del registro) y luego realizar lo siguiente:

    En el grupo Registros de la pestaña Inicio, haga clic en Eliminar. Imagen del botón

  6. Para empezar a escribir datos, haga clic en la primera celda vacía del formulario y comience a escribir. Use el Panel de navegación para buscar otros formularios o informes que quiera usar. Algunas plantillas incluyen un formulario de navegación que permite moverse entre los distintos objetos de base de datos.

Para más información sobre cómo trabajar con plantillas, vea el artículo Usar una plantilla para crear una base de datos de escritorio de Access.

Principio de página

Crear una base de datos sin usar una plantilla

Si no está interesado en usar una plantilla, puede crear una base de datos creando sus propias tablas, formularios, informes y otros objetos de base de datos. En la mayoría de los casos, esto implica uno o ambos de los procedimientos siguientes:

  • Escribir, pegar, o importar datos en la tabla que se crea al crear una base de datos y después repetir el proceso con otras tablas que cree mediante el comando Tabla de la pestaña Crear.

  • Importar datos de otros orígenes y crear otras tablas en el proceso.

Crear una base de datos en blanco

  1. Haga clic en la pestaña Archivo, en Nuevo y luego, en Base de datos en blanco.

  2. Escriba un nombre de archivo en el cuadro Nombre de archivo. Para cambiar la ubicación predeterminada del archivo, haga clic en Buscar una ubicación donde colocar la base de datos texto alternativo(junto al cuadro Nombre de archivo), vaya a la nueva ubicación y haga clic en Aceptar.

  3. Haga clic en Crear.

    Access crea la base de datos con una tabla vacía denominada Tabla1 y, luego, abre esa tabla en la vista Hoja de datos. El cursor se coloca en la primera celda vacía de la columna Haga clic para agregar.

  4. Comience a escribir para agregar datos o puede pegar datos de otro origen, tal y como se describe en la sección Copiar los datos de otro origen en una tabla de Access.

Escribir datos en la vista Hoja de datos es muy similar a trabajar en una hoja de cálculo de Excel. La estructura de tabla se crea al escribir los datos. Cuando agrega una nueva columna a la hoja de datos, se define un nuevo campo en la tabla. En función de los datos que se escriben, Access establece automáticamente el tipo de datos de cada campo.

Si en este momento no quiere escribir datos en Tabla1, haga clic en Cerrar Imagen del botón. Si ha efectuado algún cambio en la tabla, Access le pide que guarde los cambios. Haga clic en para guardar los cambios, en No para descartarlos o en Cancelar para dejar abierta la tabla.

Sugerencia:  Access busca un archivo denominado En_blanco.accdb en la carpeta situada en [unidad de instalación]:\Archivos de programa\Microsoft Office\Plantillas\1033\Access\. Si existe, Blank.accdb es la plantilla para todas las nuevas bases de datos en blanco. Cualquier contenido que incluya es heredado por todas las nuevas bases de datos en blanco. Es una buena forma de distribuir contenido predeterminado, como, por ejemplo, números de pieza o directivas y avisos de exención de responsabilidad de la compañía.

Importante: Si cierra Tabla1 sin guardarla como mínimo una vez, Access elimina toda la tabla, aunque se hayan escrito datos.

Agregar una tabla

Puede agregar nuevas tablas a una base de datos existente mediante los comandos del grupo Tablas de la pestaña Crear.

Imagen de la cinta de opciones de Access

Crear una tabla, empezando en la vista Hoja de datos    En la vista Hoja de datos, puede escribir datos inmediatamente y dejar que Access cree la estructura de la tabla en segundo plano. Los nombres de campo se asignan numéricamente (Campo1, Campo2, etc.) y Access establece automáticamente el tipo de datos de cada campo, según los datos que se escriban.

  1. En el grupo Tablas de la pestaña Crear, haga clic en Tabla. Imagen del botón

    Access crea la tabla y selecciona la primera celda vacía de la columna Haga clic para agregar.

  2. En el grupo Agregar y eliminar de la pestaña Campos, haga clic en el tipo de campo que quiere agregar. Si no ve el tipo de campo que busca, haga clic en Más campos Imagen del botón.

  3. Access muestra una lista de tipos de campo de uso habitual. Haga clic en el campo que quiera y Access agregará el nuevo campo a la hoja de datos en el punto de inserción.

    Puede arrastrar el campo para moverlo. Cuando arrastra un campo en una hoja de datos, aparece una barra de inserción vertical en donde se colocará el campo.

  4. Para agregar datos, comience a escribir en la primera celda vacía o pegue datos de otro origen, tal y como se describe en la sección Copiar los datos de otro origen en una tabla de Access.

  5. Para cambiar el nombre de una columna (campo), haga doble clic en el encabezado de la columna y escriba el nuevo nombre.

    Debe asignar un nombre significativo a cada campo para que pueda saber lo que contiene al verlo en el panel Lista de campos.

  6. Para mover una columna, haga clic en su encabezado para seleccionarla y arrástrela a la ubicación que prefiera. También puede seleccionar varias columnas contiguas y arrastrarlas a la vez a una nueva ubicación. Para seleccionar varias columnas contiguas, haga clic en el encabezado de columna de la primera columna y, mientras mantiene presionada la tecla MAYÚS, haga clic en el encabezado de columna de la última columna.

Crear una tabla, empezando en la vista Diseño    En la vista Diseño, se crea primero la estructura de tabla. Cambie después a la vista Hoja de datos para escribir datos o especificar datos con otro método, como pegar o importar.

  1. En el grupo Tablas de la pestaña Crear, haga clic en Diseño de la tabla. Imagen del botón

  2. Para cada campo de la tabla, escriba un nombre en la columna Nombre de campo y seleccione un tipo de datos en la lista Tipo de datos.

  3. Si quiere, puede escribir una descripción de cada campo en la columna Descripción. La descripción se muestra después en la barra de estado de la vista Hoja de datos al situar el cursor en ese campo. La descripción también sirve como texto de la barra de estado para los controles de un formulario o informe que se cree arrastrando un campo del panel Lista de campos, así como para los controles que se creen para ese campo al usar el Asistente para formularios o el Asistente para informes.

  4. Tras haber agregado todos los campos, guarde la tabla:

    • En la pestaña Archivo, haga clic en Guardar.

  5. Cuando quiera comenzar a escribir datos en la tabla, cambie a la vista Hoja de datos y haga clic en la primera celda vacía. También puede pegar datos de otro origen, tal y como se describe en la sección Copiar los datos de otro origen en una tabla de Access.

Establecer propiedades de campo en la vista Diseño    Independientemente de cómo haya creado la tabla, es una buena idea examinar y establecer las propiedades de campo. Aunque algunas propiedades están disponibles en la vista Hoja de datos, algunas propiedades solo se pueden establecer en la vista Diseño. Para cambiar a la vista Diseño, haga clic con el botón derecho en la tabla en el panel de navegación y, a continuación, haga clic en Vista Diseño. Para ver las propiedades de un campo, haga clic en el campo de la cuadrícula de diseño. Las propiedades se muestran debajo de la cuadrícula de diseño, en Propiedades de campo.

Para ver una descripción de cada propiedad de campo, haga clic en la propiedad y lea la descripción en el cuadro situado junto a la lista de propiedades en Propiedades de campo. Si desea más información, haga clic en el botón Ayuda.

En la siguiente tabla, se describen algunas de las propiedades de campo que se ajustan habitualmente.

Propiedad

Descripción

Tamaño de campo

En los campos de texto, esta propiedad establece el número máximo de caracteres que se pueden almacenar en el campo. El máximo es 255. En los campos numéricos, esta propiedad establece el tipo de número que se almacenará (entero largo, doble, etc.). Para obtener el almacenamiento de datos más eficiente, se recomienda asignar la cantidad mínima de espacio que crea que va a necesitar para los datos. Si cambian las necesidades, puede ajustar el valor al alza posteriormente.

Formato

Esta propiedad establece cómo se muestran los datos. No afecta a los datos reales tal y como se almacenan en el campo. Puede seleccionar un formato predefinido o especificar un formato personalizado.

Máscara de entrada

Use esta propiedad para especificar una trama para todos los datos que se especifiquen en este campo. Esto ayuda a garantizar que todos los datos se escriben correctamente y que contienen el número de caracteres necesarios. Para obtener ayuda sobre cómo crear una máscara de entrada, haga clic en Botón Generadora la derecha del cuadro de propiedad.

Valor predeterminado

Use esta propiedad para especificar el valor predeterminado que aparecerá en este campo cada vez que se agregue un nuevo registro. Por ejemplo, si tiene un campo de fecha y hora en el que quiere registrar siempre la fecha en que se ha agregado el registro, puede escribir "Fecha()" (sin las comillas) como valor predeterminado.

Obligatorio

Esta propiedad establece si se requiere un valor en este campo. Si establece esta propiedad en , Access no le permite agregar un nuevo registro a menos que se escriba un valor en este campo.

Principio de página

Copiar los datos de otro origen en una tabla de Access

Si los datos están almacenados actualmente en otro programa, como, por ejemplo, Excel, puede copiarlos y pegarlos en una tabla de Access. En general, esto funciona mejor si los datos ya están separados en columnas, tal y como están en una hoja de cálculo de Excel. Si los datos se encuentran en un programa de procesamiento de texto, es mejor separar las columnas de datos con pestañas o convertir los datos en tabla en el programa de procesamiento de texto antes de copiarlos. Si los datos se tienen que editar o manipular (por ejemplo, separar los nombres completos en nombres y apellidos), puede que le convenga hacerlo antes de copiarlos, sobre todo si no está familiarizado con Access.

Cuando pega datos en una tabla vacía, Access establece el tipo de datos de cada campo según el tipo de datos que encuentra allí. Por ejemplo, si un campo copiado no contiene nada más que valores de fecha, Access aplica el tipo de datos de fecha y hora a ese campo. Si el campo copiado solo contiene las palabras "sí" y "no", Access aplica el tipo de datos Sí/No al campo.

Access asigna nombre a los campos en función de lo que encuentra en la primera fila de datos pegados. Si la primera fila de datos pegados es de tipo similar a las filas siguientes, Access determina que la primera fila forma parte de los datos y asigna nombres genéricos (F1, F2, etc.) a los campos. Si la primera fila de datos pegados no es similar a las filas siguientes, Access determina que la primera fila consta de nombres de campo. Access asigna nombre a los campos en consecuencia y no incluye la primera fila en los datos.

Si Access asigna nombres de campo genéricos, se debe cambiar el nombre al campo cuanto antes para evitar confusiones. Use el procedimiento siguiente:

  1. Presione CTRL+G para guardar la tabla.

  2. En la vista Hoja de datos, haga doble clic en cada encabezado de columna y escriba un nombre de campo descriptivo para cada columna.

  3. Guarde de nuevo la tabla.

Nota: También puede cambiar el nombre de los campos yendo a la vista Diseño y editando allí los nombres de los campos. Para cambiar a la vista Diseño, haga clic con el botón derecho en la tabla en el panel de navegación y luego haga clic en Vista Diseño. Para cambiar de nuevo a la vista Hoja de datos, haga doble clic en la tabla en el panel de navegación.

Principio de página

Importar, anexar o vincular a datos de otro origen

Puede que tenga datos almacenados en otro programa y quiera importarlos a una nueva tabla o anexarlos a una tabla existente en Access. También podría trabajar con personas que mantengan sus datos en otros programas y quiera trabajar con esos datos vinculándolos a Access. En ambos casos, Access facilita trabajar con datos de otros orígenes. Puede importar datos de una hoja de cálculo de Excel, de una tabla en otra base de datos de Access, de una lista de SharePoint y de otros muchos orígenes. El proceso que se usa difiere ligeramente según el origen, pero el procedimiento siguiente le servirá de punto de partida.

  1. En Access, en el grupo Importar y vincular de la pestaña Datos externos, haga clic en el comando correspondiente al tipo de archivo que quiere importar.

    Grupo Importar y vincular de la pestaña Datos externos

    Por ejemplo, si va a importar datos de una hoja de cálculo de Excel, haga clic en Excel. Si no ve el tipo de programa que busca, haga clic en Más.

    Nota: Si no encuentra el tipo de formato correcto en el grupo Importar y vincular, es posible que tenga que iniciar el programa en el que originalmente ha creado los datos y usarlo para guardar los datos en un formato de archivo común (como, por ejemplo, archivo de texto delimitado) para poder importar esos datos a Access.

  2. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar para buscar el archivo de datos de origen en el cuadro Nombre de archivo.

  3. En Especifique cómo y dónde desea almacenar los datos en la base de datos actual, haga clic en la opción que quiera (todos los programas le permiten importar y algunos le permiten anexar o vincular). Puede crear otra tabla que use los datos importados o (con algunos programas) puede anexar los datos a una tabla existente o crear una tabla vinculada que mantenga un vínculo a los datos del programa de origen.

  4. Si se inicia un asistente, siga las instrucciones de las páginas siguientes del asistente. En la última página del asistente, haga clic en Finalizar.

    Si importa objetos o vincula tablas desde una base de datos de Access, aparecerá el cuadro de diálogo Importar objetos o Vincular tablas. Elija los elementos que quiera y haga clic en Aceptar.

    El proceso exacto depende de si elige importar, anexar o vincular datos.

  5. Access le preguntará si quiere guardar los detalles de la operación de importación que acaba de completar. Si cree que volverá a realizar la misma operación de importación en el futuro, haga clic en Guardar pasos de importación y escriba los detalles. Puede repetir fácilmente la operación en el futuro haciendo clic en Importaciones guardadas Imagen del botónen el grupo Importar y vincular de la pestaña Datos externos. Si no quiere guardar los detalles de la operación, haga clic en Cerrar.

Si opta por importar una tabla, Access importará los datos a una nueva tabla y luego mostrará la tabla en el grupo Tablas del panel de navegación. Si opta por anexar datos a una tabla existente, los datos se agregan a esa tabla. Si opta por vincular a datos, Access crea una tabla vinculada en el grupo Tablas del panel de navegación.

Principio de página

Agregar un elemento de aplicación

Puede usar un elemento de aplicación para agregar funcionalidad a una base de datos existente. Un elemento de aplicación puede ser tan sencillo como una sola tabla o puede incluir varios objetos relacionados tales como una tabla y un formulario enlazado.

Por ejemplo, el elemento de aplicación Comentarios se compone de una tabla con un campo Id. de Autonumeración, un campo de fecha y un campo de memo. Puede agregarlo a cualquier base de datos y usarlo tal como está o con una personalización mínima.

  1. Abra la base de datos a la que quiere agregar un elemento de aplicación.

  2. Haga clic en la pestaña Crear.

  3. En el grupo Plantillas, haga clic en Elementos de aplicación. Se abrirá una lista de elementos disponibles.

  4. Haga clic en el elemento de aplicación que quiere agregar.

Principio de página

Abrir una base de datos existente de Access

  1. En la pestaña Archivo, haga clic en Abrir.

  2. En el cuadro de diálogo Abrir, vaya a la base de datos que quiere abrir.

  3. Siga uno de estos procedimientos:

    • Haga doble clic en la base de datos para abrirla en el modo predeterminado que se especifique en el cuadro de diálogo Opciones de Access o el modo que haya establecido una directiva administrativa.

    • Haga clic en Abrir para abrir la base de datos con acceso compartido en un entorno multiusuario para que usted y otros usuarios puedan leer y escribir en la base de datos.

    • Haga clic en la flecha situada junto al botón Abrir y luego en Abrir en modo solo lectura para abrir la base de datos con acceso de solo lectura de modo que pueda verla pero no editarla. Otros usuarios aún pueden leer y escribir en la base de datos.

    • Haga clic en la flecha situada junto al botón Abrir y luego en Abrir en modo solo lectura para abrir la base de datos con acceso exclusivo. Cuando tiene una base de datos abierta con acceso exclusivo, cualquier persona que intente abrir la base de datos recibirá un mensaje que indica que "el archivo ya está en uso".

    • Haga clic en la flecha situada junto al botón Abrir y luego en Abrir en modo exclusivo de solo lectura para abrir la base de datos con acceso de solo lectura. Otros usuarios aún pueden abrir la base de datos, pero están limitados al modo de solo lectura.

Nota: Puede abrir un archivo de datos directamente en un formato de archivo externo, como, por ejemplo, dBASE, Microsoft Exchange o Excel. También puede abrir directamente cualquier origen de datos ODBC, como, por ejemplo, Microsoft SQL Server. Access crea automáticamente una base de datos de Access en la misma carpeta que el archivo de datos y agrega vínculos a cada tabla de la base de datos externa.

Sugerencias

  • Para abrir una de las bases de datos abiertas recientemente, en la pestaña Archivo, haga clic en Recientes y en el nombre de archivo correspondiente a esa base de datos. Access abre la base de datos con las mismas opciones de configuración que tenía la última vez que se abrió. Si la lista de archivos usados recientemente no aparece, en la pestaña Archivo, haga clic en Opciones. En el cuadro de diálogo Opciones de Access, haga clic en Configuración de cliente. En Mostrar, escriba el número de documentos que se mostrarán en la lista de documentos recientes, hasta un máximo de 50.

    También puede mostrar las bases de datos recientes en la barra de navegación de la vista Backstage, con acceso de dos clics: 1) la pestaña Archivo y 2) la base de datos reciente que quiere abrir. Cerca de la parte inferior de la pestaña Recientes, marque la casilla Obtener acceso rápidamente a este número de bases de datos recientes y ajuste el número de bases de datos que quiere mostrar.

  • Si abre una base de datos haciendo clic en el comando Abrir de la pestaña Archivo, puede ver una lista de accesos directos a las bases de datos que ha abierto recientemente haciendo clic en Mis documentos recientes en el cuadro de diálogo Abrir.

Principio de página

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×