En este artículo se describen la sintaxis de la fórmula y el uso de la función ELEGIR en Microsoft Excel.

Descripción

Usa el argumento núm_índice para devolver un valor de una lista de argumentos de valores. Use ELEGIR para seleccionar uno de los 254 valores posibles a partir del rango del argumento índice. Por ejemplo, si valor1 a valor7 son los días de la semana, ELEGIR devuelve uno de los días cuando se usa un número entre 1 y 7 como argumento núm_índice.

Sintaxis

ELEGIR(núm_índice; valor1; [valor2]; ...)

La sintaxis de la función ELEGIR tiene los siguientes argumentos:

  • Núm_índice    Obligatorio. Especifica el argumento de valor que se selecciona. El argumento núm_índice debe ser un número entre 1 y 254, o bien, una fórmula o referencia a una celda que contenga un número entre 1 y 254.

    • Si núm_índice es 1, ELEGIR devuelve valor1; si es 2, ELEGIR devuelve valor2 y así sucesivamente.

    • Si index_num es menor que 1 o mayor que el número del último valor de la lista, ELIJA devuelve la #VALUE! Valor de error

    • Si núm_índice es una fracción, se trunca al entero inferior antes de ser usada.

  • Valor1, valor2, ...     Valor1 es obligatorio, los valores siguientes son opcionales. De 1 a 254 argumentos de valores entre los cuales la función ELEGIR selecciona un valor o acción que se ejecuta basándose en el argumento núm_índice. Los argumentos pueden ser números, referencias a celdas, nombres definidos, fórmulas, funciones o texto.

Observaciones

  • Si núm_índice es una matriz, cada valor se evaluará cuando se evalúe ELEGIR.

  • Los argumentos de valor para ELEGIR pueden ser referencias de rango, así como valores individuales.

    Por ejemplo, la fórmula:

=SUMA(ELEGIR(2;A1:A10;B1:B10;C1:C10))

evalúa:

=SUMA(B1:B10)

que después devuelve un valor basado en los valores del rango B1:B10.

La función ELEGIR se evalúa primero, devolviendo la referencia B1:B10. La función SUMA se evalúa a continuación usando B1:B10, que es el resultado de la función ELEGIR, como su argumento.

Ejemplos

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Datos

 

Clavos

Tornillos

Tuercas

Terminado

Pernos

Fórmula

Descripción

Resultado

=ELEGIR(2;A2;A3;A4;A5)

Valor del segundo argumento de lista (valor de la celda A3)

=ELEGIR(4;B2;B3;B4;B5)

Valor del cuarto argumento de lista (valor de la celda B5)

Pernos

=ELEGIR(3,"Ancho",115,"mundo",8)

Valor del tercer argumento de lista

mundo

Ejemplo 2

Datos

23

45

1,2

10

Fórmula

Descripción (resultado)

Resultado

=SUMA(A2:ELEGIR(2;A3;A4;A5))

Suma el intervalo A2:A4. La función ELEGIR devuelve A4 como la segunda parte del intervalo de la función SUMA.

80

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?

¿Qué ha afectado a tu experiencia?

¿Algún comentario adicional? (Opcional)

¡Gracias por sus comentarios!

×