Importar datos XML

Si creó previamente una asignación XML,puede usarla para importar datos XML en celdas asignadas, pero también hay varios métodos y comandos para importar datos XML sin una asignación XML.

Si tiene una asignación XML, haga lo siguiente para importar datos XML en celdas asignadas:

  1. En el mapa XML, seleccione una de las celdas asignadas.

  2. Haga clic en > importar.

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  3. En el cuadro de diálogo Importar XML, busque y seleccione el archivo de datos XML (.xml) que desea importar y haga clic en Importar.

Otras formas de importar datos XML

Para obtener más información sobre los problemas, vea Problemas comunes con la importación de datos XML al final de este artículo.

Importar un archivo de datos XML como una tabla XML

  1. Haga clic en > importar.

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  2. En el cuadro de diálogo Importar XML, busque y seleccione el archivo de datos XML (.xml) que desea importar y haga clic en Importar.

    Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema del archivo de datos XML.

  3. En el cuadro de diálogo Importar datos, realice una de las siguientes acciones:

    1. Seleccione Tabla XML en una hoja de cálculo existente para importar el contenido del archivo de datos XML a una tabla XML de la hoja de cálculo en la ubicación de celda especificada.

    2. Seleccione Tabla XML en nueva hoja de cálculo para importar el contenido del archivo a una tabla XML en una nueva hoja de cálculo a partir de la celda A1. El esquema del archivo de datos XML se muestra en el panel de tareas Origen XML.

  4. Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema del archivo de datos XML.

  5. Para controlar el comportamiento de los datos XML (como el enlace de datos, el formato y el diseño), haga clic en Propiedades,que muestra el cuadro de diálogo Propiedades de mapa XML. Por ejemplo, los datos existentes en un rango asignado se sobrescribirán al importar datos de forma predeterminada, pero puede cambiarlo.

Importar varios archivos de datos XML

  1. Seleccione una celda asignada para importar varios archivos XML en un único conjunto de celdas asignadas.

    Si desea importar varios archivos XML en varios conjuntos de celdas asignadas, haga clic en una celda en cualquier lugar de la hoja de cálculo que no esté asignada.

  2. Haga clic en > importar.

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  3. En el cuadro de diálogo Importar XML, busque y seleccione el archivo de datos XML (.xml) que desea importar.

    • Si los archivos son contiguos, presione Mayús y haga clic en el primer y el último archivo de la lista. Todos los datos de los archivos XML se importarán y se anexarán a las celdas asignadas.

    • Si los archivos no son contiguos, mantenga presionada la tecla Ctrl y haga clic en cada archivo que quiera importar en la lista.

  4. Haga clic en Importar.

    Si seleccionó archivos que no son contiguos, aparecerá el cuadro de diálogo Importar <nombre de archivo >.xml archivo. Seleccione la asignación XML que corresponde al archivo de datos XML que va a importar para cada archivo.

    Para usar una sola asignación para todos los archivos seleccionados que aún no se han importado, seleccione Usar esta asignación XML para todos los archivos seleccionados de este esquema.

Importar varios archivos de datos XML como datos externos

Para importar varios archivos XML que usan el mismo espacio de nombres pero esquemas XML diferentes, puede usar el comando Importar datos desde XML. Excel crea una asignación XML única para cada archivo de datos XML que importe.

Nota: Si va a importar varios archivos XML que no definen un espacio de nombres, estos archivos XML se tratan como si usaron el mismo espacio de nombres.

  1. Si usa Excel una suscripciónMicrosoft 365, haga clic en Datos > Obtener datos >Desde > desde XML.

    Si está usando Excel 2016 o anterior, haga clic en Datos >De otros orígenes > de importación de datos XML.

  2. Vaya a la unidad, carpeta o ubicación de Internet que tiene el archivo de datos XML (.xml) que desea importar.

  3. Seleccione el archivo y haga clic en Abrir.

  4. En el cuadro de diálogo Importar datos, realice una de las siguientes acciones:

    • Tabla XML en una hoja de cálculo existente    El contenido del archivo se importa a una nueva tabla XML en una nueva hoja de cálculo. Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema del archivo de datos XML.

    • Hoja de cálculo existente    Los datos XML se importan en una tabla bidimensional con filas y columnas que muestran etiquetas XML como encabezados de columna y datos en filas debajo de los encabezados de columna. El primer elemento (el nodo raíz) se usa como un título y se muestra en la ubicación de celda especificada. El resto de las etiquetas se ordenan alfabéticamente en la segunda fila. En este caso, Excel no deduce un esquema y no puede usar una asignación XML.

    • Nueva hoja de cálculo    Excel agrega una nueva hoja de cálculo al libro y coloca automáticamente los datos XML en la esquina superior izquierda de la nueva hoja de cálculo. Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema del archivo de datos XML.

  5. Para controlar el comportamiento de los datos XML, como el enlace de datos, el formato y el diseño, haga clic en Propiedades,que muestra el cuadro de diálogo Propiedades de mapa XML. Por ejemplo, los datos existentes en un rango asignado se sobrescriben al importar datos de forma predeterminada, pero puede cambiarlo.

Abrir un archivo de datos XML para importar sus datos

  1. Haga clic en Archivo > Abrir.

    Si usa Excel 2007, haga clic en Microsoft Office botón Imagen del botón de Office >Abrir.

  2. En el cuadro de diálogo Abrir, haga clic en la unidad, carpeta o ubicación de Internet que tiene el archivo que desea abrir.  

  3. Seleccione el archivo y haga clic en Abrir.

  4. Si aparece el cuadro de diálogo Importar XML, el archivo que ha abierto hace referencia a una o varias hojas de estilos transformación de idioma de hoja de estilos extensible (XSLT), de modo que puede hacer clic en una de las siguientes opciones:

    • Abrir el archivo sin aplicar una hoja de estilos    Los datos XML se importan en una tabla bidimensional con filas y columnas que muestran etiquetas XML como encabezados de columna y datos en filas debajo de los encabezados de columna. El primer elemento (el nodo raíz) se usa como un título y se muestra en la ubicación de celda especificada. El resto de las etiquetas se ordenan alfabéticamente en la segunda fila. En este caso, Excel no deduce un esquema y no puede usar una asignación XML.

    • Abrir el archivo con la siguiente hoja de estilos aplicada (seleccione una)    Seleccione la hoja de estilos que desea aplicar y, a continuación, haga clic en Aceptar. Los datos XML se formatearán según la hoja de estilos seleccionada.

      Nota: Los datos XML se abren como de solo lectura en Excel para que no guarde accidentalmente el archivo de origen original en el formato de archivo libro de Excel Macro-Enabled (.xlsm). En este caso, Excel no deduce un esquema y no puede usar una asignación XML.

  5. Si aparece el cuadro de diálogo Abrir XML, el archivo XML no tiene ninguna referencia de hoja de estilos XSLT. Para abrir el archivo, haga clic en una de las siguientes opciones:

    • Haga clic en Como una tabla XML para crear una tabla XML en un libro nuevo.

      El contenido del archivo se importa a la tabla XML. Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema del archivo de datos XML.

    • Haga clic en Como un libro de solo lectura.

      Los datos XML se importan en una tabla bidimensional con filas y columnas que muestran etiquetas XML como encabezados de columna y datos en filas debajo de los encabezados de columna. El primer elemento (el nodo raíz) se usa como un título y se muestra en la ubicación de celda especificada. El resto de las etiquetas se ordenan alfabéticamente en la segunda fila. En este caso, Excel no deduce un esquema y no puede usar una asignación XML.

      Los datos XML se abren como de solo lectura en Excel para que no guarde accidentalmente el archivo de origen original en el formato de archivo libro de Excel Macro-Enabled (.xlsm). En este caso, Excel no deduce un esquema y no puede usar una asignación XML.

    • Haga clic en Usar el panel de tareas Origen XML.

      El esquema del archivo de datos XML se muestra en el panel de tareas Origen XML. A continuación, puede arrastrar elementos del esquema a la hoja de cálculo para asignarlos a la hoja de cálculo.

      Si el archivo de datos XML no hace referencia a un esquema, Excel deduce el esquema del archivo de datos XML.

Problemas comunes con la importación de datos XML

Excel muestra el cuadro de diálogo Error de importación XML cuando no puede validar datos según la asignación XML. En este cuadro de diálogo, haga clic en Detalles para obtener información adicional sobre cada error. En la tabla siguiente se enumeran algunos errores comunes de importación:

Error

Qué ha pasado

Validación de esquema con errores

Al hacer clic en Validar datos en el esquema para importar y exportar en el cuadro de diálogo Propiedades de mapa XML, los datos se importaron, pero los datos no se validaron con la asignación XML especificada.

Algunos datos se importaron como texto

Algunos o todos los datos que importó se convirtieron de su tipo de datos declarado en texto. Para usar estos datos en un cálculo, deberá convertir los datos de texto en números o fechas. Por ejemplo, un valor de fecha convertido en texto no funcionará según lo previsto en la función AÑO hasta que lo convierta en el tipo de datos Fecha. Excel convierte datos en texto cuando:

  • Los datos están en un formato Excel no es compatible.

  • Los datos no son compatibles con la Excel representación interna del tipo de datos XSD. Para solucionar este problema, compruebe cada declaración de tipo de datos para asegurarse de que los datos XML son válidos según el esquema XML.

Error de análisis XML

El analizador XML no puede abrir el archivo XML especificado. Asegúrese de que el archivo XML no tiene errores de sintaxis y de que el XML está bien formado.

No se puede encontrar un mapa XML que se corresponda con los datos

Este problema puede producirse al seleccionar más de un archivo de datos XML para importar y Excel encontrar una asignación XML que coincida con uno de los archivos. Para el archivo denominado en la barra de título del cuadro de diálogo, importe primero un esquema adecuado y, después, intente importar el archivo de nuevo.

No se puede cambiar el tamaño de una tabla XML para dar cabida a los datos

Intenta agregar filas importando o anexando datos a la tabla XML, pero no hay espacio para que la tabla se expanda. Una tabla XML solo puede expandirse desde la parte inferior hacia abajo. Por ejemplo, puede haber un objeto, como una imagen u otra tabla, inmediatamente debajo de la tabla XML que impide que la tabla XML se expanda. O bien, para que la tabla XML se expanda, superará el límite de Excel fila de 1.048.576. Para solucionar este problema, reorganice las tablas y los objetos de la hoja de cálculo para permitir que la tabla XML se expanda desde abajo.

El archivo XML especificado no hace referencia a un esquema

El archivo XML que intenta abrir no hace referencia a un esquema XML. Para trabajar con los datos XML que hay en el archivo, Excel un esquema basado en el contenido del archivo XML. Si ese esquema es incorrecto o insuficiente, quítelo del libro. A continuación, cree un archivo de esquema XML y edite el archivo de datos XML para que el archivo de datos XML haga referencia al esquema. Para obtener más información, vea Asignar elementos XML a celdas de un mapa XML.

Nota: No puede exportar el esquema Excel deducido como un archivo de datos de esquema XML independiente (.xsd). Aunque existen editores de esquemas XML y otros métodos para crear un archivo de esquema XML, es posible que no disponga de acceso a estos editores o no sepa cómo utilizarlos.

Siga estos pasos para quitar el esquema que Excel creado desde el libro:

  1. Click Developer > Source.

    Comandos XML en la pestaña Desarrollador

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  2. En el panel de tareas Origen XML, haga clic en MAPAS.

  3. En el cuadro de Mapas xml, haga clic en el mapa XML Excel y haga clic en Eliminar.

Importar varios archivos XML que usan el mismo espacio de nombres, pero los distintos esquemas no funcionan según lo esperado

Cuando trabaja con varios archivos de datos XML y esquemas XML, normalmente se crea una asignación XML para cada esquema, se asignan los elementos que desea y, a continuación, se importa cada archivo de datos XML a la asignación XML correspondiente. Con el comando Importar para abrir varios archivos XML con el mismo espacio de nombres, solo puede usar un esquema XML. Al usar este comando para abrir varios archivos XML que usan el mismo espacio de nombres pero esquemas diferentes, puede obtener resultados inesperados. Por ejemplo, es posible que los datos se sobrescriban o que los archivos no se abran.

Para importar varios archivos XML que usan el mismo espacio de nombres pero esquemas XML diferentes, pruebe a usar el comando Importar datos de XML (haga clic en Datos > Desde otros orígenes). Este comando permite que varios archivos XML con el mismo espacio de nombres usen varios esquemas XML. Excel crea una asignación XML única para cada archivo de datos XML que quiera importar.

Nota: Si va a importar varios archivos XML que no definen un espacio de nombres, estos archivos XML se tratan como si usaron el mismo espacio de nombres.

Mostrar la pestaña Programador

Si no aparece la pestaña Programador, realice las siguientes acciones para mostrarla:

  • En Excel 2013 y Excel 2010:

    1. Haga clic en Archivo > Opciones.

    2. Haga clic en la categoría Personalizar cinta de opciones.

    3. Under Main Tabs, check the Developer box, and click OK.

  • En Excel 2007:

    1. Haga clic en Microsoft Office botón Imagen del botón de Office > Excel opciones.

    2. Click the Popular category.

    3. Under Top options for working with Excel, check the Show Developer tab in the Ribbon box, and click OK.

Vea también

Vista general de XML en Excel

Map XML elements to cells in an XML Map

Exportar datos XML

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×