La función INDICE devuelve un valor o la referencia a un valor desde una tabla o rango.

Su explorador no admite vídeo.

Hay dos formas de utilizar la función INDICE:

  • Si desea devolver el valor de una celda especificada o de una matriz de celdas, consulte Forma de matriz.

  • Si desea devolver una referencia a las celdas especificadas, consulte Forma de referencia.

Forma de matriz

Descripción

Devuelve el valor de un elemento de una tabla o matriz, seleccionado por los índices de número de fila y columna.

Use la forma matricial si el primer argumento de INDICE es una constante matricial.

Sintaxis

INDICE(matriz; núm_fila; [núm_columna])

La forma de matriz de la función INDICE tiene los siguientes argumentos:

  • matriz    Obligatorio. Es un rango de celdas o una constante de matriz.

    • Si matriz contiene solo una fila o columna, el argumento row_num o column_num es opcional.

    • Si matriz tiene más de una fila y más de una columna y solo se usa row_num o column_num, INDICE devuelve una matriz de toda la fila o columna de la matriz.

  • fila    Obligatorio, a menos que column_num esté presente. Selecciona la fila de la matriz desde la cual devolverá un valor. Si row_num se omite, column_num necesario.

  • column_num    Opcional. Selecciona la columna de la matriz desde la cual devolverá un valor. Si column_num se omite, row_num es necesario.

Observaciones

  • Si se usan los argumentos row_num y column_num, INDICE devuelve el valor de la celda en la intersección de row_num y column_num.

  • row_num y column_num deben apuntar a una celda dentro de la matriz; de lo contrario, INDICE devuelve un #REF! .

  • Si establece row_num o column_num en 0 (cero), INDICE devuelve la matriz de valores para toda la columna o fila, respectivamente. Para usar valores devueltos como matriz, escriba la función INDICE como fórmula de matriz.

    Nota: Si tiene una versión actual de Microsoft 365 , puedeintroducir la fórmula en la celda superior izquierda del rango de salida y, a continuación, presione ENTRAR para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe escribirse como una fórmula de matriz heredada seleccionando primero el rango de salida, introduzca la fórmula en la celda superior izquierda del rango de salida y, después, presione CTRL+MAYÚS+ENTRAR para confirmarla. Excel inserta llaves al principio y al final de la fórmula por usted. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

Ejemplos

Ejemplo 1

Estos ejemplos usan la función INDICE para buscar el valor de la celda de intersección de una fila y una columna.

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego Entrar.

Datos

Datos

Manzanas

Limones

Plátanos

Peras

Fórmula

Descripción

Resultado

=INDICE(A2:B3,2,2)

Valor en la intersección de la segunda fila y la segunda columna del rango A2:B3.

Peras

=INDICE(A2:B3,2,1)

Valor en la intersección de la segunda fila y la primera columna del rango A2:B3.

Plátanos

Ejemplo 2

Este ejemplo usa la función INDICE en una fórmula de matriz para buscar los valores de dos celdas especificadas en una matriz de 2x2.  

Nota: Si tiene una versión actual de Microsoft 365 , puedeintroducir la fórmula en la celda superior izquierda del rango de salida y, a continuación, presione ENTRAR para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe escribirse como una fórmula de matriz heredada seleccionando primero dos celdas en blanco, introduzca la fórmula en la celda superior izquierda del rango de salida y presione CTRL+MAYÚS+ENTRAR para confirmarla. Excel inserta llaves al principio y al final de la fórmula por usted. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

Fórmula

Descripción

Resultado

=INDICE({1,2;3,4},0,2)

Valor encontrado en la primera fila, segunda columna de la matriz. La matriz contiene 1 y 2 en la primera fila y 3 y 4 en la segunda fila.

2

Valor encontrado en la segunda fila, segunda columna de la matriz (misma matriz que arriba).

4

Volver al principio


Formulario de referencia

Descripción

Devuelve la referencia de la celda ubicada en la intersección de una fila y de una columna determinadas. Si la referencia está hecha de selecciones no adyacentes, puede seleccionar la selección en la que buscar.

Sintaxis

INDEX(ref, núm_fila, [núm_columna], [núm_área])

El formulario de referencia de la función INDICE tiene los siguientes argumentos:

  • referencia    Obligatorio. Es una referencia a uno o varios rangos de celdas.

    • Si va a escribir un rango no adyacente para la referencia, escriba la referencia entre paréntesis.

    • Si cada área de referencia contiene solo una fila o columna, el argumento row_num o column_num, respectivamente, es opcional. Por ejemplo, use INDICE(ref,,núm_columna) para un argumento ref con una sola fila.

  • row_num    Obligatorio. Es el número de la fila en el argumento ref desde la que se devolverá una referencia.

  • column_num    Opcional. Es el número de la columna en el argumento ref desde la que se devolverá una referencia.

  • area_num    Opcional. Selecciona un rango de referencia del que se devolverá la intersección de row_num y column_num. La primera área seleccionada o especificada se numera con 1, la segunda con 2 y así sucesivamente. Si area_num se omite, INDICE usa el área 1.  Las áreas que se muestran aquí deben estar en una hoja.  Si especifica áreas que no están en la misma hoja, provocará un #VALUE! error.  Si necesita usar intervalos que se encuentran en hojas diferentes entre sí, se recomienda usar la forma de matriz de la función INDICE y usar otra función para calcular el rango que compone la matriz.  Por ejemplo, podría usar la función ELEGIR para calcular el intervalo que se va a usar.

Por ejemplo, si Referencia describe las celdas (A1:B4,D1:E4,G1:H4), area_num 1 es el rango A1:B4, area_num 2 es el rango D1:E4 y area_num 3 es el rango G1:H4.

Observaciones

  • Después de que la referencia y area_num han seleccionado un rango determinado, row_num y column_num seleccionan una celda determinada: row_num 1 es la primera fila del rango, column_num 1 es la primera columna, y así sucesivamente. La referencia devuelta por INDICE es la intersección de row_num y column_num.

  • Si establece row_num o column_num en 0 (cero), INDICE devuelve la referencia de toda la columna o fila, respectivamente.

  • row_num, column_num y area_num deben apuntar a una celda dentro de la referencia; de lo contrario, INDICE devuelve un #REF! . Si row_num y column_num, INDICE devuelve el área en referencia especificada por area_num.

  • El resultado de la función INDICE es una referencia y será interpretado como tal por otras fórmulas. El valor devuelto por la función INDICE se puede usar como una referencia o como un valor, dependiendo de la fórmula. Por ejemplo, la fórmula CELDA("ancho";INDICE(A1:B2,1,2)) es igual a CELDA("ancho",B1). La función CELDA usa el valor devuelto por INDICE como referencia a una celda. Por otra parte, una fórmula como 2*INDICE(A1:B2,1,2) traduce el valor devuelto por INDICE al número de la celda B1.

Ejemplos

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR.

Fruta

Precio

Recuento

Manzanas

0,69 $

40

Plátanos

0,34 $

38

Limones

0,55 $

15

Naranjas

0,25 $

25

Peras

0,59 $

40

Almendras

2,80 $

10

Anacardos

3,55 $

16

Cacahuetes

1,25 $

20

Nueces

1,75 $

1,2

Fórmula

Descripción

Resultado

=INDICE(A2:C6; 2; 3)

Intersección de la segunda fila y la tercera columna en el intervalo A2:C6, que es el contenido de la celda C3.

38

=INDICE((A1:C6; A8:C11); 2; 2; 2)

Intersección de la segunda fila y la segunda columna en la segunda área de A8:C11, que es el contenido de la celda B9.

1,25

=SUMA(INDICE(A1:C11; 0; 3; 1))

La suma de la tercera columna en la primera área del rango A1:C11, que es la suma de C1:C11.

216

=SUMA(B2:INDICE(A2:C6; 5; 2))

Suma del rango que comienza en B2 y termina en la intersección de la quinta fila y la segunda columna del rango A2:A6, que es la suma de B2:B6.

2,42

Principio de página

Vea también

Función BUSCARV

Función COINCIDIR

Función INDIRECTO

Directrices y ejemplos de fórmulas de matriz

Funciones de búsqueda y referencia (referencia)

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?

¿Qué ha afectado a tu experiencia?

¿Algún comentario adicional? (Opcional)

¡Gracias por sus comentarios!

×