Puede usar La vinculación de objetos e incrustación (OLE) para incluir contenido de otros programas, como Word o Excel.

OLE es compatible con muchos programas diferentes y OLE se usa para hacer que el contenido creado en un programa esté disponible en otro programa. Por ejemplo, puede insertar un documento de Office Word en un libro de Office Excel. Para ver qué tipos de contenido puede insertar, haga clic en Objeto en el grupo Texto de la pestaña Insertar. Solo los programas que están instalados en el equipo y que admiten objetos OLE aparecen en el cuadro Tipo de objeto.

Si copia información entre Excel o cualquier programa compatible con OLE, como Word, puede copiar la información como una objeto vinculado o una objeto incrustado. Las principales diferencias entre objetos vinculados y objetos incrustados son dónde se almacenan los datos y cómo se actualiza el objeto después de colocarlo en el archivo de destino. Los objetos incrustados se almacenan en el libro en el que se insertan y no se actualizan. Los objetos vinculados permanecen como archivos independientes y se pueden actualizar.

Objetos vinculados e incrustados en un documento

Objetos vinculados e incrustados en un documento de Office para Windows

1. Un objeto incrustado no tiene ninguna conexión con el archivo de origen.

2. Un objeto vinculado está vinculado al archivo de origen.

3. El archivo de origen actualiza el objeto vinculado.

Cuándo usar objetos vinculados

Si desea que la información de su archivo de destino se actualice cuando cambien los datos de la archivo de origen, use objetos vinculados.

Con un objeto vinculado, la información original permanece almacenada en el archivo de origen. El archivo de destino muestra una representación de la información vinculada, pero almacena solo la ubicación de los datos originales (y el tamaño si el objeto es un objeto de gráfico de Excel). El archivo de origen debe permanecer disponible en su equipo o red para mantener el vínculo a los datos originales.

La información vinculada se puede actualizar automáticamente si cambia los datos originales en el archivo de origen. Por ejemplo, si selecciona un párrafo en un documento de Word y, a continuación, pega el párrafo como un objeto vinculado en un libro de Excel, la información se puede actualizar en Excel si cambia la información del documento de Word.

Cuándo usar objetos incrustados

Si no desea actualizar los datos copiados cuando cambien en el archivo de origen, use un objeto incrustado. La versión del origen está incrustada por completo en el libro. Si copia la información como un objeto incrustado, el archivo de destino requiere más espacio en disco que si vincula la información.

Cuando un usuario abre el archivo en otro equipo, puede ver el objeto incrustado sin tener acceso a los datos originales. Como un objeto incrustado no tiene vínculos al archivo de origen, el objeto no se actualiza si cambia los datos originales. Para cambiar un objeto incrustado, haga doble clic en el objeto para abrirlo y editarlo en el programa de origen. El programa de origen (u otro programa capaz de editar el objeto) debe estar instalado en el equipo.

Cambiar la forma en que se muestra un objeto OLE

Puede mostrar una objeto vinculado o objeto incrustado en un libro exactamente como aparece en la programa origen o como un icono. Si el libro se verá en línea y no tiene intención de imprimir el libro, puede mostrar el objeto como un icono. Esto minimiza la cantidad de espacio de visualización que ocupa el objeto. Los visores que quieran mostrar la información pueden hacer doble clic en el icono.

Insertar un objeto en una hoja de cálculo

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto Icono de objeto en la cinta de opciones.
    Insertar objeto

  3. En el cuadro de diálogo Objeto, haga clic en la pestaña Crear desde archivo.

  4. Haga clic en Examinar y seleccione el archivo que quiere insertar.

  5. Si quiere insertar un icono en la hoja de cálculo en lugar de mostrar el contenido del archivo, active la casilla Mostrar como icono. Si no activa ninguna casilla, Excel muestra la primera página del archivo. En ambos casos, al hacer doble clic se abre el archivo completado. Haga clic en Aceptar.

    Nota: Después de agregar el icono o el archivo, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo. También puede cambiar el tamaño del icono o el archivo mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el archivo o el icono.

Insertar un vínculo a un archivo

Es posible que quiera agregar un vínculo al objeto en lugar de incrustarlo completamente. Puede hacerlo si el libro y el objeto que quiere agregar están almacenados en un sitio de SharePoint, una unidad de red compartida o una ubicación similar, y la ubicación de los archivos no va a cambiar. Esto resulta útil si se modifica el objeto vinculado, porque el vínculo siempre abre el documento más reciente.

Nota: Si mueve el archivo vinculado a otra ubicación, el vínculo deja de funcionar.

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto Icono de objeto en la cinta de opciones.
    Insertar objeto

  3. Haga clic en la pestaña Crear desde archivo.

  4. Haga clic en Examinar y seleccione el archivo que quiere vincular.

  5. Active la casilla Vincular a archivo y haga clic en Aceptar.

Crear un nuevo objeto desde dentro de Excel

Puede crear un objeto completamente nuevo basado en otro programa sin salir de su libro. Por ejemplo, si quiere agregar una explicación más detallada a un gráfico o tabla, puede crear un documento incrustado, como un archivo de Word o PowerPoint, en Excel. Puede establecer el objeto para que se muestre directamente en una hoja de cálculo o agregar un icono que abre el archivo.

Este objeto incrustado es un documento de Word.
  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto Icono de objeto en la cinta de opciones.
    Insertar objeto

  3. En la pestaña Crear nuevo, seleccione el tipo de objeto que quiere insertar de la lista. Si quiere insertar un icono en la hoja de cálculo en lugar del objeto en sí, active la casilla Mostrar como icono.

  4. Haga clic en Aceptar. Según el tipo de archivo que se va a insertar, se abre una nueva ventana de programa o bien aparece una ventana de edición dentro de Excel.

  5. Cree el nuevo objeto que quiere insertar.

    Cuando haya terminado, si Excel abrió una nueva ventana del programa en el que se creó el objeto, puede trabajar directamente en ella.

    Puede editar el documento de Word incrustado directamente en Excel.

    Cuando haya terminado de trabajar en la ventana, puede realizar otras tareas sin guardar el objeto incrustado. Cuando se cierra el libro, los objetos nuevos se guardarán automáticamente.

    Nota: Después de agregar el objeto, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo de Excel. También puede cambiar el tamaño del objeto mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el objeto.

Insertar un objeto en una hoja de cálculo

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. Haga clic en la pestaña Crear desde archivo.

    La pestaña "Crear de un archivo" en el cuadro de diálogo Objeto.
  4. Haga clic en Examinar y seleccione el archivo que quiere insertar.

  5. Si quiere insertar un icono en la hoja de cálculo en lugar de mostrar el contenido del archivo, active la casilla Mostrar como icono. Si no activa ninguna casilla, Excel muestra la primera página del archivo. En ambos casos, al hacer doble clic se abre el archivo completado. Haga clic en Aceptar.

    Nota: Después de agregar el icono o el archivo, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo. También puede cambiar el tamaño del icono o el archivo mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el archivo o el icono.

Insertar un vínculo a un archivo

Es posible que quiera agregar un vínculo al objeto en lugar de incrustarlo completamente. Puede hacerlo si el libro y el objeto que quiere agregar están almacenados en un sitio de SharePoint, una unidad de red compartida o una ubicación similar, y la ubicación de los archivos no va a cambiar. Esto resulta útil si se modifica el objeto vinculado, porque el vínculo siempre abre el documento más reciente.

Nota: Si mueve el archivo vinculado a otra ubicación, el vínculo deja de funcionar.

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. Haga clic en la pestaña Crear desde archivo.

  4. Haga clic en Examinar y seleccione el archivo que quiere vincular.

  5. Active la casilla Vincular a archivo y haga clic en Aceptar.

    En la pestaña "Crear de un archivo", seleccione "Vincular al archivo".

Crear un nuevo objeto desde dentro de Excel

Puede crear un objeto completamente nuevo basado en otro programa sin salir de su libro. Por ejemplo, si quiere agregar una explicación más detallada a un gráfico o tabla, puede crear un documento incrustado, como un archivo de Word o PowerPoint, en Excel. Puede establecer el objeto para que se muestre directamente en una hoja de cálculo o agregar un icono que abre el archivo.

Este objeto incrustado es un documento de Word.
  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. En la pestaña Crear nuevo, seleccione el tipo de objeto que quiere insertar de la lista. Si quiere insertar un icono en la hoja de cálculo en lugar del objeto en sí, active la casilla Mostrar como icono.

    La pestaña Crear nuevo en el cuadro de diálogo Objeto.
  4. Haga clic en Aceptar. Según el tipo de archivo que se va a insertar, se abre una nueva ventana de programa o bien aparece una ventana de edición dentro de Excel.

  5. Cree el nuevo objeto que quiere insertar.

    Cuando haya terminado, si Excel abrió una nueva ventana del programa en el que se creó el objeto, puede trabajar directamente en ella.

    Puede editar el documento de Word incrustado directamente en Excel.

    Cuando haya terminado de trabajar en la ventana, puede realizar otras tareas sin guardar el objeto incrustado. Cuando se cierra el libro, los objetos nuevos se guardarán automáticamente.

    Nota: Después de agregar el objeto, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo de Excel. También puede cambiar el tamaño del objeto mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el objeto.

Cambiar la forma en que se muestra un objeto OLE

  1. Haga clic con el botón derecho en el icono o objeto, seleccione tipo de objetoObjeto (por ejemplo,Objeto de documento) y, a continuación, haga clic en Convertir.

  2. Siga uno de los siguientes procedimientos:

    • Para mostrar el contenido, desactive la casilla Mostrar como icono.

    • Para mostrar un icono, active la casilla Mostrar como icono. Opcionalmente, puede cambiar la imagen o etiqueta del icono predeterminado. Para ello, haga clicen Cambiar icono y, a continuación, haga clic en el icono que desee de la lista Icono o escriba una etiqueta en el cuadro Título.

Editar contenido de un programa OLE

Mientras se encuentra en Excel, puede cambiar el contenido vinculado o incrustado desde otro programa.

Editar un objeto vinculado en el programa de origen

  1. En el grupo Conexiones de la pestaña Datos, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando Modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista Archivo de origen, haga clic en el origen de la objeto vinculado y, a continuación, haga clic en Abrir origen.

  3. Realice los cambios que desee en el objeto vinculado.

  4. Salga del programa origen para volver al archivo de destino.

Editar un objeto incrustado en el programa de origen

  1. Haga doble clic en objeto incrustado para abrirlo.

  2. Realice los cambios que desee en el objeto.

  3. Si está editando el objeto en su lugar dentro del programa abierto, haga clic en cualquier lugar fuera del objeto para volver a la archivo de destino.

    Si edita el objeto incrustado en el programa de origen en una ventana independiente, salga del programa de origen para volver al archivo de destino.

Nota: Al hacer doble clic en determinados objetos incrustados, como clips de sonido y vídeo, se reproduce el objeto en lugar de abrir un programa. Para editar uno de estos objetos incrustados, haga clic con el botón derecho en el icono o objeto, seleccione tipo de objetoObjeto (por ejemplo, Objetoclip multimedia) y, a continuación, haga clic en Editar.

Editar un objeto incrustado en un programa distinto del programa de origen

  1. Seleccione la objeto incrustado que desea editar.

  2. Haga clic con el botón derecho en el icono o objeto, seleccione tipo de objetoObjeto (por ejemplo,Objeto de documento) y, a continuación, haga clic en Convertir.

  3. Siga uno de los siguientes procedimientos:

    • Para convertir el objeto incrustado en el tipo que especifique en la lista, haga clic en Convertir en.

    • Para abrir el objeto incrustado como el tipo que especifique en la lista sin cambiar el tipo de objeto incrustado, haga clic en Activar.

Seleccionar un objeto OLE con el teclado

  1. Presione CTRL+G para mostrar el cuadro de diálogo Ir a.

  2. Haga clic enEspecial , seleccione Objetosy, a continuación, haga clic en Aceptar.

  3. Presione TAB hasta que el objeto que desee esté seleccionado.

  4. Presione MAYÚS+F10.

  5. Seleccione Objeto oObjeto de gráficoy, a continuación, haga clic en Editar.

Problema: Al hacer doble clic en un objeto vinculado o incrustado, aparece un mensaje "no se puede editar".

Este mensaje aparece cuando archivo de origen o programa origen no se puede abrir.

Asegúrese de que el programa de origen está disponible     Si el programa de origen no está instalado en el equipo, convierta el objeto al formato de archivo de un programa que tiene instalado.

Asegurarse de que la memoria es adecuada     Asegúrese de que tiene suficiente memoria para ejecutar el programa de origen. Cierre otros programas para liberar memoria, si es necesario.

Cerrar todos los cuadros de diálogo     Si el programa de origen se está ejecutando, asegúrese de que no tiene ningún cuadro de diálogo abierto. Cambie al programa de origen y cierre los cuadros de diálogo abiertos.

Cerrar el archivo de origen     Si el archivo de origen es un objeto vinculado, asegúrese de que otro usuario no lo tiene abierto.

Asegúrese de que el nombre del archivo de origen no ha cambiado     Si el archivo de origen que desea editar es un objeto vinculado, asegúrese de que tiene el mismo nombre que cuando creó el vínculo y que no se ha movido. Seleccione el objeto vinculado y, a continuación, haga clic en el comando Editar vínculos del grupo Conexiones de la pestaña Datos para ver el nombre del archivo de origen. Si el archivo de origen se ha cambiado de nombre o se ha movido, use el botón Cambiar origen del cuadro de diálogo Editar vínculos para localizar el archivo de origen y volver a conectar el vínculo.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×