Modificar, editar o cambiar un informe

En este tema se describen las técnicas que puede usar para modificar un informe de Access existente. Access proporciona dos vistas que puede usar para realizar cambios en el informe: vista Diseño y Vista Diseño. La elección de qué vista usar depende de la tarea específica que intenta realizar. Es posible que termine usando ambas vistas para realizar los cambios.

¿Qué desea hacer?

Comprender la vista Diseño

La vista Diseño es la vista más intuitiva para la modificación del informe y se puede usar para casi todos los cambios que desea realizar en un informe en Access. En la vista Diseño, el informe se está ejecutando realmente, por lo que puede ver los datos tanto como aparecerán cuando se impriman. Sin embargo, también puede realizar cambios en el diseño del informe en esta vista. Como puede ver los datos mientras modifica el informe, es una vista muy útil para establecer anchos de columna, agregar niveles de agrupación o realizar casi cualquier otra tarea que afecte a la apariencia y legibilidad del informe. En la ilustración siguiente se muestra un informe de la Libreta de teléfonos del cliente en la vista Diseño.

Informe en la vista Presentación

El informe que ve en la vista Diseño no tiene el mismo aspecto que el informe impreso. Por ejemplo, no hay saltos de página en la vista Diseño. Además, si ha usado configurar página para dar formato al informe con columnas, las columnas no se muestran en la vista Diseño. Sin embargo, la vista Diseño le ofrece una aproximación muy cercana del informe impreso. Si desea ver el aspecto del informe cuando se imprima, use Vista previa de impresión.

Algunas tareas no se pueden realizar en la vista Diseño y requieren que cambie a la vista Diseño. En determinadas situaciones, Access mostrará un mensaje en el que se le indica que debe cambiar a la vista Diseño para realizar un cambio en particular.

Comprender la vista Diseño

La vista Diseño le ofrece una vista más detallada de la estructura del informe. Puede ver las bandas de encabezado y pie de página para el informe, la página y los grupos. El informe no se está ejecutando realmente en la vista Diseño, por lo que no puede ver los datos subyacentes mientras trabaja; sin embargo, hay ciertas tareas que puede realizar más fácilmente en la vista Diseño que en la vista Diseño. Puede:

  • Agregue una amplia variedad de controles al informe, como etiquetas, imágenes, líneas y rectángulos.

  • Editar orígenes de control de cuadro de texto en los propios cuadros de texto, sin usar la hoja de propiedades.

  • Cambie algunas propiedades que no están disponibles en la vista Diseño.

En la ilustración siguiente se muestra un informe de la Libreta de teléfonos del cliente en la vista Diseño.

Informe en la vista Diseño

Alternar vistas

Access proporciona una variedad de métodos para cambiar entre vistas. Si el informe ya está abierto, puede cambiar a otra vista siguiendo uno de estos procedimientos:

  • Haga clic con el botón derecho en el informe en el panel de navegación y, a continuación, haga clic en la vista que desee en el menú contextual.

  • Haga clic con el botón derecho en la pestaña del documento o la barra de título del informe y, a continuación, haga clic en la vista que desee en el menú contextual.

  • En la pestaña Inicio, en el grupo Vista, haga clic en el botón Vista para alternar entre las vistas disponibles. Como alternativa, puede hacer clic en la flecha situada debajo de Vistay, a continuación, seleccionar una de las vistas disponibles en el menú.

  • Haga clic con el botón derecho en un área en blanco del propio informe y, a continuación, haga clic en la vista que desee. Si el informe está abierto en la vista Diseño, debe hacer clic con el botón derecho fuera de la cuadrícula de diseño.

  • Haga clic en uno de los iconos de vista pequeña de la barra de estado de Access.

Si el informe no está abierto, haga doble clic en el informe en el panel de navegación para abrirlo en la vista Informe. Para abrir el informe en otra vista, haga clic con el botón derecho en el informe en el panel de navegación y, a continuación, haga clic en la vista que desee en el menú contextual.

Nota: Si va a modificar un informe en el que ha usado configurar página para crear varias columnas (por ejemplo, un informe de etiquetas postales), solo puede ver las columnas en vista previa de impresión. Cuando ve el informe en la vista Informe o en la vista Diseño, Access muestra los datos en una sola columna.

Modificar el informe en la vista Diseño

En esta sección se describen algunas de las modificaciones comunes del informe que puede realizar en la vista Diseño.

Cambiar el ancho de columna o campo en la vista Diseño

  1. Haga clic en un elemento de la columna que desea ajustar.

    Se dibuja un borde alrededor del elemento para indicar que el campo está seleccionado.

  2. Arrastre el borde derecho o izquierdo del borde hasta que la columna sea el ancho que desee.

Cambiar el alto de fila o campo en la vista Diseño

  1. Haga clic en un elemento de la fila que desea ajustar.

    Se dibuja un borde alrededor del elemento para indicar que el campo está seleccionado.

  2. Arrastre el borde superior o inferior del borde hasta que la fila sea el alto que desee.

Agregar un campo en la vista Diseño

  • En la pestaña Diseño, en el grupo Herramientas, haga clic en Agregar campos existentes.

    Se muestra la lista de campos disponibles. Si hay campos disponibles en otras tablas, estos se mostrarán en Campos disponibles en otras tablas:.

  • Arrastre un campo de la lista de campos al informe. Al mover el campo, un área resaltada indicará dónde se colocará el campo al soltar el botón del mouse.

    Nota: Para agregar varios campos a la vez, mantenga presionada la tecla CTRL y haga clic en cada campo de la lista de campos que desee. Después, suelte la tecla CTRL y arrastre los campos al informe. Los campos se colocarán adyacentes entre sí.

Volver al principio

Comprender los diseños de control

Los diseños de control son guías que alinean los controles horizontal y verticalmente para dar al informe una apariencia uniforme. Puede pensar en un diseño de control como una tabla, donde cada celda de la tabla contiene un control. En los procedimientos siguientes se muestra cómo agregar, quitar o reorganizar controles en los diseños de control.

Los diseños de control se incluyen en dos variedades: tabulares y apilados.

  • En los diseños de control tabular, los controles se organizan en filas y columnas como una hoja de cálculo, con etiquetas en la parte superior. Los diseños de control tabular abarcan siempre dos secciones de un informe; independientemente de la sección en la que se encuentran los controles, las etiquetas se encuentran en la sección que se encuentra encima de ellos. En la ilustración siguiente se muestra un diseño de control tabular básico.

    Diseño básico de controles en tabla

  • En los diseños apilados, los controles se organizan verticalmente como puede ver en un formulario de papel, con una etiqueta a la izquierda de cada control. Los diseños apilados siempre están incluidos en una sola sección de informe. En la ilustración siguiente se muestra un diseño básico de control apilado.

    Diseño de control apilado básico

Puede tener varios diseños de control de cualquier tipo en un informe. Por ejemplo, es posible que tenga un diseño tabular para crear una fila de datos para cada registro y, después, uno o más diseños apilados debajo, que contengan más datos del mismo registro.

Crear un nuevo diseño de control

Access crea automáticamente diseños de control de columnas en las siguientes circunstancias:

  • Para crear un nuevo informe, haga clic en Imagen del botón en el grupo Informes de la pestaña Crear.

  • Para crear un nuevo informe, haga clic en Informe en blanco Imagen del botón en el grupo Informes de la pestaña Crear y, después, arrastre un campo desde el panel Lista de campos al informe.

En un informe existente, puede crear un nuevo diseño de control haciendo lo siguiente:

  1. Seleccione un control que desee agregar al diseño.

  2. Si desea agregar otros controles al mismo diseño, mantenga presionada la tecla MAYÚS y seleccione esos controles.

  3. Siga uno de estos procedimientos:

    • En la pestaña Organizar, en el grupo Tabla, haga clic en Tabular o Apiladas.

    • Haga clic con el botón derecho en el control o controles seleccionados, seleccione Diseñoy, a continuación, haga clic en Tabular o Apilado.

Access crea el diseño de control y le agrega los controles seleccionados.

Cambiar un diseño de control de tabular a apilado o de apilado a tabular

Para cambiar un diseño completo de un tipo de diseño al otro:

  • Seleccione el diseño de control haciendo clic en el selector de diseño naranja en la esquina superior izquierda del diseño.

    Se seleccionan todas las celdas del diseño.

  • Siga uno de estos procedimientos:

    • En la pestaña Organizar, en el grupo Tabla, haga clic en el tipo de diseño que desee(Tabular o Apilado).

    • Haga clic con el botón derecho en el diseño de control, seleccione Diseñoy, a continuación, haga clic en el tipo de diseño que desee.

Access reorganiza los controles en el tipo de diseño seleccionado.

Dividir un diseño de control en dos diseños

Puede dividir un diseño de control en dos diseños mediante el procedimiento siguiente:

  1. Mantenga presionada la tecla MAYÚS y haga clic en los controles que desea mover al nuevo diseño de control.

  2. Siga uno de estos procedimientos:

    • En la pestaña Organizar, en el grupo Tabla, haga clic en el tipo de diseño que desee para el nuevo diseño(Tabular o Apilado).

    • Haga clic con el botón derecho en los controles seleccionados, seleccione Diseñoy, a continuación, haga clic en el tipo de diseño que desee para el nuevo diseño.

Access crea un nuevo diseño de control y le agrega los controles seleccionados.

Reorganizar controles en un diseño de control

  • Puede mover un control dentro de un diseño de control arrastrándolo a la ubicación que desee. Al arrastrar el campo, una barra horizontal o vertical indica dónde se colocará al soltar el botón del mouse.

  • Puede mover un control de un diseño de control a otro diseño de control del mismo tipo. Por ejemplo, puede arrastrar un control de un diseño apilado a otro diseño apilado, pero no a un diseño tabular.

Agregar controles a un diseño de control

Para agregar un nuevo campo desde el panel Lista de campos a un diseño de control existente    

  • Solo tiene que arrastrar el campo desde el panel Lista de campos al diseño. Una barra horizontal o vertical indica dónde se colocará el campo al soltar el botón del mouse.

Para agregar controles existentes a un diseño de control existente    

  1. Seleccione el primer control que desea agregar al diseño de control.

  2. Si desea agregar otros controles al mismo diseño, mantenga presionada la tecla MAYÚS y seleccione esos controles. Puede seleccionar controles en otros diseños de control.

  3. Siga uno de estos procedimientos:

    • Si el informe está abierto en la vista Diseño, arrastre los campos seleccionados al diseño. Una barra horizontal o vertical indica dónde se colocarán los campos al soltar el botón del mouse.

    • Si el informe está abierto en la vista Diseño:

      1. En la pestaña Organizar, en el grupo Tabla, haga clic en el tipo del diseño que va a agregar. Si va a agregar a un diseño tabular, haga clic enTabular. Si va a agregar a un diseño apilado, haga clic enApilado.

        Access crea un nuevo diseño y agrega los controles seleccionados.

      2. Arrastre el nuevo diseño al diseño existente. Una barra horizontal o vertical indica dónde se colocarán los campos al soltar el botón del mouse.

Quitar controles de un diseño de control

Quitar un control de un diseño de control le permite colocarlo en cualquier lugar del informe sin afectar al posicionamiento de ningún otro control.

  1. Seleccione el control que desea quitar del diseño. Para seleccionar varios controles, mantenga presionada la tecla MAYÚS y, a continuación, haga clic en los controles que desea quitar. Para seleccionar todos los controles del diseño, haga clic en el cuadro selector de diseño en la esquina superior izquierda del diseño.

  2. Haga clic con el botón derecho en uno de los controles seleccionados, seleccione Diseñoy, a continuación, haga clic en Quitar diseño.

    Access quita los controles seleccionados del diseño.

Sugerencia: Para evitar que un control se inserte en un diseño de control mientras lo mueve, mantenga presionada la tecla CTRL y, después, arrastre el control hasta donde desee.

Volver al principio

Eliminar un campo o columna

  1. Haga clic en el campo o columna que se va a eliminar o haga clic en su etiqueta o encabezado de columna.

    Access dibuja un borde alrededor del elemento para indicar que está seleccionado.

  2. Pulse SUPRIMIR.

Cambiar la configuración de página

Use los grupos Tamaño de página y Diseño de página de la pestaña Configurar página para cambiar el tamaño, la orientación, los márgenes, entre otros.

  1. Haga clic en la pestaña Configurar página.

  2. En el grupo Tamaño de página, haga clic en Tamaño para seleccionar otro tamaño de papel.

  3. En el grupo Tamaño de página, haga clic en Márgenes para realizar ajustes en los márgenes del informe.

  4. En el grupo Diseño de página, haga clic en Vertical u Horizontal para cambiar la orientación del papel.

Cambiar el formato de un campo

  1. Seleccione el campo al que desea aplicar formato.

  2. En la pestaña Formato, use las herramientas del grupo Fuente para aplicar el formato que desee.

Enlazar un cuadro de texto a un campo diferente (cambiar el origen de control de un control)

  1. Haga clic dentro de la columna o el campo para el que desea cambiar el origen del control.

    Se dibuja un borde alrededor del elemento para indicar que el campo está seleccionado.

  2. Si la hoja de propiedades no se muestra actualmente, presione F4 para mostrarla.

  3. En la pestaña Datos de la hoja de propiedades, establezca la propiedad ControlSource en el nuevo campo. Puede seleccionar un campo de la lista desplegable o escribir una expresión en el cuadro.

Cambiar el origen de registros del informe

  1. Si la hoja de propiedades no se muestra, presione F4 para mostrarla.

  2. En la lista desplegable de la parte superior de la hoja de propiedades, haga clic en Informe.

  3. En la hoja de propiedades, haga clic en la pestaña Datos.

  4. En la lista desplegable Origen de registros, seleccione la tabla o consulta que desea usar para un origen de registros o haga clic en Botón Generador para mostrar el Generador de consultas.

    Nota: Si el informe se basa actualmente en una tabla, Access le preguntará si desea crear una consulta basada en la tabla. Haga clic en Sí para mostrar el Generador de consultas y crear la consulta, o haga clic en No para cancelar la operación. Si elige crear una consulta, la nueva consulta se convertirá en el origen de registros del informe. Se creará como una consulta "incrustada", es decir, una consulta almacenada en la propiedad RecordSource del informe, en lugar de como un objeto de consulta independiente.

Ajustar texto en un campo

  1. Si la hoja de propiedades no se muestra, haga clic con el botón derecho en el campo en el que desea ajustar el texto y haga clic en Propiedades. En caso contrario, haga clic en el campo para seleccionarlo.

  2. En la pestaña Formato de la hoja de propiedades, establezca la propiedad CanGrow enSí.

Agregar líneas de división

Si los controles están contenidos en un diseño de control, puede agregar líneas de cuadrícula para proporcionar más separación visual entre los controles.

  1. Haga clic en cualquier campo de un diseño de control.

    Se dibuja un borde alrededor del campo para indicar que está seleccionado.

  2. En la pestaña Organizar, en el grupo Tabla, haga clic en Líneas de cuadrícula.

  3. Seleccione el estilo de líneas de cuadrícula que desee en la lista desplegable.

Nota: También puede agregar líneas de cuadrícula haciendo clic con el botón derecho en cualquier campo de un diseño de control, apuntando a Diseño,apuntando a Líneas de cuadrícula y, a continuación, seleccionando el tipo de líneas de cuadrícula que desee.

Volver al principio

Agregar o modificar un logotipo u otra imagen

Los procedimientos siguientes muestran cómo agregar un logotipo a un informe con la herramienta Logotipo y cómo cambiar el tamaño de un control de imagen o una imagen dentro de un control de imagen.

Agregar un logotipo

  • En la pestaña Diseño, en el grupo Encabezado y pie de página, haga clic en Logotipo.

    Se muestra el cuadro de diálogo Insertar imagen.

  • Busque la carpeta donde está almacenado el archivo del logotipo y haga doble clic en el archivo.

    Access agrega el logotipo a la esquina superior izquierda del informe.

Cambiar el tamaño de un control que contiene un logotipo u otra imagen

  1. Haga clic en el control que contiene la imagen.

    Se dibuja un borde alrededor del control para indicar que está seleccionado.

  2. Coloque el puntero en el borde. Cuando el puntero se convierte en una flecha de dos puntas, puede arrastrarlo en las direcciones indicadas por las flechas para que el control de imagen sea más grande o más pequeño.

Tenga en cuenta que el valor predeterminado de la propiedad Modo de tamaño de una imagen es Clip,lo que significa que la imagen permanecerá del mismo tamaño independientemente de lo grande o pequeño que sea el control de imagen. Si desea que la imagen sea más grande o más pequeña a medida que cambia el tamaño del control, haga lo siguiente:

Cambiar el tamaño del logotipo o la imagen dentro del control

  1. Seleccione la imagen.

  2. Si no se muestra la Hoja de propiedades, presione F4 para mostrarla.

  3. En la pestaña Formato de la hoja de propiedades, establezca la propiedad Modo de tamaño en la opción que desee:

Configuración

Descripción

Clip

La imagen mantiene el mismo tamaño, independientemente de lo grande o pequeño que sea el control de la imagen. Si hace que el control de imagen sea más pequeño que la imagen, la imagen se recortará.

Estirar

La imagen se estira vertical y horizontalmente para que coincida con el tamaño del control de imagen. La relación de aspecto original de la imagen no se conserva, por lo que esta configuración puede dar como resultado una imagen distorsionada a menos que establezca con precisión el alto y el ancho del control de imagen.

Zoom

A medida que se cambia el tamaño del control de imagen, la imagen se ajusta para ser lo más grande posible sin afectar a la relación de aspecto original de la imagen.

Volver al principio

Agregar o editar un título de informe

En los procedimientos siguientes se muestra cómo agregar o editar una etiqueta que contiene el título del informe.

Agregar un título a un informe

  • En la pestaña Diseño, en el grupo Encabezado y pie de página, haga clic en Título.

    Se agrega una nueva etiqueta al encabezado del informe y se introduce el nombre del informe como título del informe.

  • Cuando se crea la etiqueta, el texto de la etiqueta se selecciona automáticamente para que, si desea cambiar el texto, simplemente pueda empezar a escribir el título que desee.

  • Presione ENTRAR cuando haya terminado.

Editar el título del informe

  1. Haga doble clic en la etiqueta que contiene el título del informe para colocar el cursor en la etiqueta.

  2. Escriba el texto que desea usar como título del informe y presione ENTRAR cuando haya terminado.

Agregar números de página, la fecha actual o la hora actual

Los procedimientos siguientes muestran cómo agregar números de página a un informe y cómo agregar la fecha actual o la hora actual.

Agregar números de página

  • En la pestaña Diseño, en el grupo Encabezado y pie de página, haga clic en Números de página.

    Se muestra el cuadro de diálogo Números de página.

  • Elija el formato, la posición y la alineación que desee para los números de página.

  • Desactive la casilla Mostrar número de primera página si no desea un número en la primera página.

  • Haga clic en Aceptar.

    Los números de página se agregan al informe. Cambie a Vista previa de impresión para ver el aspecto de los números al imprimir el informe.

Agregar la fecha u hora

  • En la pestaña Diseño, en el grupo Encabezado y pie de página, haga clic en Fecha y hora.

    Se muestra el cuadro de diálogo Fecha y hora.

  • Desactive la casilla Incluir fecha si no desea incluir la fecha.

  • Si desea incluir la fecha, haga clic en el formato de fecha que desee.

  • Desactive la casilla Incluir hora si no desea incluir la hora.

  • Si desea incluir la hora, haga clic en el formato de hora que desee.

    Una muestra de la fecha y hora, en los formatos que ha elegido, aparece en el área Muestra del cuadro de diálogo.

  • Haga clic en Aceptar.

Modificar el informe en la vista Diseño

En algunos casos, no puede realizar determinadas modificaciones en el informe en la vista Diseño y, en su lugar, debe usar la vista Diseño.

Agregar números de línea

  1. En el grupo Controles de la pestaña Diseño, haga clic en Cuadro de texto.

  2. Haga clic en un área abierta de la sección donde quiera que aparezcan los números de línea. En la mayoría de los casos, esta será la sección Detalles. Moverá el cuadro de texto a su ubicación final más adelante.

    Al hacer clic en el informe, Access crea un nuevo cuadro de texto independiente.

  3. Haga clic en la etiqueta (justo a la izquierda del nuevo cuadro de texto) y presione SUPRIMIR.

  4. Haga clic una vez en el nuevo cuadro de texto para seleccionarlo y, después, vuelva a hacer clic para colocar el cursor en el cuadro de texto.

  5. Escriba =1 y presione ENTRAR.

  6. Si no se muestra la Hoja de propiedades, presione F4 para mostrarla.

  7. En la pestaña Datos de la hoja de propiedades, establezca la propiedad Suma ejecutándose en Más de todo.

    Nota: Si se trata de un informe agrupado y desea que la numeración comience en 1 para cada grupo, establezca la propiedad en Over Group.

  8. Cambie el tamaño del cuadro de texto a un ancho menor colocando el puntero sobre el controlador de tamaño en el borde derecho del cuadro de texto y arrastrándolo a la izquierda. Deje suficiente espacio para el número de línea más grande que espera ver en este informe.

  9. Si es necesario, haga espacio para el cuadro de texto en el extremo izquierdo de la sección Detalle arrastrando los controles existentes en esa sección hacia la derecha o redimensionando el control situado más a la izquierda en esa sección.

  10. Arrastre el nuevo cuadro de texto a la ubicación que desee en el informe.

  11. Cambie a la vista Informe, Vista previa de impresión o Diseño para ver los números de línea.

Hacer que un encabezado de grupo aparezca en la parte superior de cada página

Para los grupos que abarcan varias páginas, es útil que el encabezado del grupo aparezca en la parte superior de cada página para que pueda ver fácilmente en qué grupo se encuentran los datos. Puede seleccionar un encabezado de grupo en la vista Diseño, pero es más fácil hacerlo en la vista Diseño.

  1. Haga doble clic en el selector de sección de encabezado de grupo (la barra horizontal encima de la sección de encabezado del grupo).

  2. En la pestaña Formato de la hoja de propiedades, establezca la propiedad Repetir sección en Sí.

Abrir un subinforme en su propia ventana de la vista Diseño

Al abrir un informe en la vista Diseño, los subinformes contenidos en el informe también se abren en la vista Diseño. Sin embargo, cada subinforme se muestra dentro de su control de subinforme, no como una ventana independiente. Dado que el control del subinforme suele ser demasiado pequeño para trabajar fácilmente, normalmente es más conveniente abrir el subinforme en su propia ventana y editarlo. Para abrir un subinforme en una ventana nueva, realice una de las siguientes acciones:

  • Seleccione el subinforme y, a continuación, en la pestaña Diseño, en el grupo Herramientas, haga clic en Subinforme en Nueva ventana.

  • Haga clic una vez fuera del control del subinforme para asegurarse de que no está seleccionado y, a continuación, haga clic con el botón derecho en el control de subinforme y, a continuación, haga clic en Subinformeen Nueva ventana.

Volver al principio

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×