Cuando se trata de funciones de matriz desbordadas, como SECUENCIA,es posible hacer referencia a todo el rango de desbordamiento colocando el operador de rango desbordado (#) después del rango. En el ejemplo siguiente, tenemos =SECUENCIA(10) en la celda A2, que se desborda a A2:A11. En la celda C2 tenemos la fórmula =SUMA(A2#), que es el equivalente de =SUMA(A2:A11), ya que A2:A11 es el rango de desbordamiento de la fórmula en A2. Esto devuelve 55, la suma de todos los valores del rango de matriz desbordado.

Si el rango de desbordamiento crece o se contrae, por ejemplo cambiando la fórmula de A2 a =SECUENCIA(20), la fórmula SUMA lo reflejará automáticamente. Si se trataba de un rango normal, tendríamos que escribir =SUMA(A2:A11) y actualizarlo manualmente si cambia el rango de desbordamiento. A menudo, es posible que no se de cuenta si un rango ha cambiado, por lo que esto puede quitar una gran cantidad de trabajo de suposición.

Operador de rango desbordado para hacer referencia a rangos de matriz desbordados completos con =SUMA(A2#).

Este es otro ejemplo de usar el operador de rango desbordado en varias fórmulas, donde creamos una lista única a partir de una lista de nombres, ordenamos la lista y luego filtramos por nombres de más de 3 caracteres de longitud. Tenemos =ORDENAR(C2#) en la celda E2 y =FILTRO(C2#,LEN(C2#)>3) en la celda G2.

Operador de rango desbordado (#) para hacer referencia a todo un rango de matriz desbordado con =FILTER(C2#,LARGO(C2#)>3)

Limitaciones conocidas

El operador de rango desbordado no admite referencias a libros cerrados. En su lugar, devolverá un #REF! o #VALOR!. Al abrir el libro al que se hace referencia, se resolverá el problema.

¿Necesita más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

Vea también

Función FILTRAR

Función MATRIZALEAT

Función SECUENCIA

Función ORDENAR

Función ORDENARPOR

Función UNICOS

Errores #SPILL! en Excel

Matrices dinámicas y comportamiento de matriz desbordada

Operador de intersección implícita: @

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×