Al diseñar un formulario en Access, puede crear un cuadro de lista o un cuadro combinado que se puede usar para buscar un registro cuando se selecciona un valor de la lista. Esto facilita a los usuarios encontrar rápidamente registros existentes sin tener que escribir un valor en el cuadro de diálogo Buscar.

Notas: 

  • Para que este procedimiento funcione, el formulario debe estar enlazado a una tabla o a una consulta guardada. El paso 5 del procedimiento contiene más información sobre qué hacer si este no es el caso.

  • Este procedimiento puede crear código que solo se ejecutará cuando se conceda el estado de confianza a la base de datos. Para más información, vea el artículo Decidir si se debe confiar en una base de datos.

Crear el cuadro de lista o el cuadro combinado

  1. Haga clic con el botón secundario en el formulario en el panel de navegación y luego haga clic en Vista Diseño.

  2. En la pestaña Diseño, en el grupo Controles, asegúrese de que usar asistentes de control Imagen del botón esté seleccionado.

  3. En el grupo Controles, haga clic en Cuadro de lista o Cuadro combinado.

  4. En el formulario, haga clic donde quiera colocar el cuadro de lista o el cuadro combinado.

  5. En la primera página del asistente, haga clic en Buscar un registro en mi formulario en función del valor que seleccioné en mi cuadro combinado/cuadrode lista y, a continuación, haga clic en Siguiente.

    La opción Buscar un registro... no está disponible.

    Si la opción Buscar un registro en mi formulario en función del valor que seleccioné en mi cuadro combinado o cuadro de lista no se muestra, es probable que se deba a que el formulario no está enlazado a una tabla o a una consulta guardada. El formulario debe estar enlazado a un objeto que esté disponible en el panel de navegación en Tablaso consultas.

    Use el procedimiento siguiente para comprobar si un formulario está enlazado a una tabla o consulta guardada:

    1. Haga clic en Cancelar para cerrar el asistente.

    2. Haga clic con el botón derecho en el cuadro de lista o cuadro combinado que creó anteriormente y, a continuación, haga clic en Eliminar.

    3. Si no se muestra el panel de tareas Hoja de propiedades, presione F4 para mostrarlo.

    4. Seleccione Formulario en la lista en la parte superior de la hoja de propiedades.

    5. En la pestaña Datos de la hoja de propiedades, vea el cuadro de propiedades Origen del registro. Este cuadro debe contener el nombre de una tabla o consulta guardada para poder usar el procedimiento descrito en este artículo. Si el cuadro está en blanco, puede seleccionar una tabla o consulta existente como origen de registros o puede crear una consulta nueva para que sirva como origen de registros. Si el cuadro contiene una instrucción SELECT, tiene la opción adicional de convertir esa instrucción en una consulta guardada. Una vez que haya completado una de estas tareas, la próxima vez que ejecute el asistente cuadro combinado/cuadro de lista, se mostrará la opción Buscar un registro....

      Siga uno de estos procedimientos en función de lo que desea hacer:

      • Seleccionar una tabla o consulta existente como origen de registros

        1. Si sabe que hay una tabla o consulta existente en la base de datos que contiene los registros que desea buscar, use este procedimiento para enlazar el formulario a ese objeto.

          Nota: Si el cuadro de la propiedad Origen del registro contiene una instrucción SELECT, siguiendo este procedimiento se eliminará esa instrucción de forma permanente. Es posible que desee copiar la instrucción en un archivo de texto u otro programa de procesamiento de texto en caso de que desee restaurarla.

        2. Haga clic en el cuadro de propiedades Origen del registro y, a continuación, haga clic en la flecha desplegable que aparece.

        3. Seleccione una de las tablas o consultas disponibles. Si una tabla o consulta adecuada no está disponible, debe crear una para poder continuar. Para obtener más información, vea los artículos Crear una tabla y agregar campos o Crear una consulta de selección sencilla.

        4. Guarde el formulario y repita el procedimiento al principio de este artículo. El asistente ahora debería mostrar la opción Buscar un registro en mi formulario en función del valor que seleccioné en mi cuadro combinado/cuadro de lista.

      • Crear una consulta guardada o convertir una instrucción SELECT en una consulta guardada

        Si los datos que desea buscar están contenidos en más de una tabla, tendrá que enlazar el formulario a una consulta que seleccione los datos de esas tablas.

        1. En el cuadro de propiedades Origen del registro, haga clic en el botón Generar Botón Generador.

          Access abre el Generador de consultas.

          • Puede empezar a crear una consulta nueva. Para obtener más información, vea el artículo Crear una consulta de selección sencilla. Cuando haya terminado de crear la consulta, continúe con el paso 2.

          • Si el cuadro de propiedad Origen de registros contenía originalmente una instrucción SELECT, esa consulta se muestra en el Generador de consultas. Continúe con el paso 2 para convertirla en una consulta guardada.

        2. En el grupo Cerrar de la pestaña Diseño, haga clic en Guardar como.

        3. En el cuadro de diálogo Guardar como, escriba un nombre para la consulta en el cuadro Guardar consulta en: .

        4. Asegúrese de que Consulta está seleccionada en el cuadro Como y, a continuación, haga clic en Aceptar.

        5. En la pestaña Diseño, en el grupo Cerrar, haga clic en Cerrar.

        6. Haga clic en Sí para guardar los cambios realizados en la consulta y actualizar la propiedad.

          Access muestra el formulario en la vista Diseño y cambia la propiedad Origen del registro para que se muestre el nuevo nombre de consulta guardado.

        7. Haga clic en Guardar en la barra de herramientas de acceso rápido.

        8. Repita el procedimiento al principio de este artículo. El asistente ahora debería mostrar la opción Buscar un registro en mi formulario en función del valor que seleccioné en mi cuadro combinado/cuadro de lista.

  6. Siga las instrucciones del asistente. En la última página del asistente, haga clic en Finalizar para mostrar el cuadro de lista o el cuadro combinado en la vista Diseño.

Volver al principio

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×