Tareas básicas en Access 2010

Estas son algunas tareas básicas de la base de datos que puede hacer para ayudarle a aprender a usar Microsoft Access 2010.

 

En este artículo

¿Qué es Access?

Access 2010 es una herramienta de implementación y diseño de aplicaciones de base de datos que puede usar para realizar un seguimiento de información importante. Puede conservar los datos en el equipo o publicar en la Web para que otros usuarios puedan usar la base de datos con un explorador web.

Muchas personas empiezan a usar Access cuando el programa que usan para realizar un seguimiento de algo gradualmente se vuelve menos apto para la tarea. Por ejemplo, supongamos que es un organizador de eventos y desea realizar un seguimiento de todos los detalles que necesita administrar para que los eventos se realicen correctamente. Si usa un procesador de textos o un programa de hoja de cálculo para ello, puede encontrar fácilmente problemas con datos duplicados e incoherentes. Puede usar software de calendario, pero el seguimiento de la información financiera de un calendario no es adecuado.

Bases de datos relacionales en Access

A veces, necesita una base de datos relacional para realizar un seguimiento de dicha información: un almacén de datos que se ha separado en colecciones de datos más pequeñas (denominadas tablas) para eliminar la redundancia y, a continuación, se relacionan conjuntamente en función de bits comunes de información (denominados campos). Por ejemplo, una base de datos relacional de planificación de eventos puede contener una tabla con información de cliente, una tabla con información de proveedor y una tabla con información de eventos. La tabla con información de evento puede tener un campo para relacionarlo con la tabla de cliente y un campo para relacionarlo con la tabla de proveedor. De esa forma, por ejemplo, si el número de teléfono de un proveedor cambiaba, la información podría cambiarse una vez en la tabla de proveedores, en lugar de en todos los casos que implicasen al proveedor.

Access es una herramienta que puede usar para desarrollar de forma rápida y sencilla aplicaciones de base de datos relacionales que le ayudan a administrar la información. Puede crear una base de datos para ayudarle a realizar un seguimiento de casi cualquier tipo de información, como inventario, contactos profesionales o procesos empresariales. De hecho, Access incluye plantillas que puede usar inmediatamente para realizar un seguimiento de una variedad de información, lo que facilita las cosas incluso para un principiante.

Al abrir Access

Al iniciar Access 2010, verá la vista Backstage de Microsoft Office, donde puede obtener información sobre la base de datos actual, crear una base de datos nueva, abrir una base de datos existente y ver contenido destacado desde Office.com.

Vista Backstage de Access 2010

La vista Backstage también contiene muchos otros comandos que puede usar para ajustar, mantener o compartir las bases de datos. Los comandos de la vista Backstage se aplican generalmente a bases de datos enteras, no a objetos dentro de una base de datos.

Nota: Puede acceder a la vista Backstage en cualquier momento haciendo clic en la pestaña Archivo.

Volver al principio

Buscar y aplicar una plantilla

Access le proporciona una amplia variedad de plantillas que puede usar para acelerar el proceso de creación de bases de datos. Una plantilla es una base de datos lista para usar que contiene todas las tablas, consultas, formularios e informes necesarios para realizar una tarea específica. Por ejemplo, hay plantillas que se pueden usar para realizar un seguimiento de problemas, administrar contactos o mantener un registro de gastos. Algunas plantillas contienen varios registros de ejemplo que demuestran su uso. Las bases de datos de plantillas se pueden usar tal y como están o puede personalizarlas para adaptarlas mejor a sus necesidades.

Para buscar y aplicar una plantilla a la base de datos, haga lo siguiente:

  1. En la pestaña Archivo, haga clic en Nuevo.

  2. En Plantillas disponibles, realice una de las siguientes acciones:

    • Para volver a usar una plantilla que ha usado recientemente, haga clic en Plantillas recientesy, a continuación, seleccione la plantilla que desee.

    • Para usar una plantilla que ya tiene instalada, haga clic en Mis plantillasy, a continuación, seleccione la plantilla que desee.

    • Para buscar una plantilla en Office.com, en plantillas de Office.com,haga clic en una categoría de plantilla, seleccione la plantilla que desee y, a continuación, haga clic en Descargar para descargar la plantilla de Office .com en su equipo.

      También puede buscar plantillas en Office.com desde Access. En el cuadro Buscar Office.com plantillas, escriba uno o varios términos de búsqueda y, a continuación, haga clic en el botón de flecha para buscar.

  3. Opcionalmente, haga clic en el icono de carpeta situado junto al cuadro Nombre de archivo para ir a una ubicación donde quiera crear la base de datos. Si no indica una ubicación específica, Access crea la base de datos en la ubicación predeterminada que se muestra debajo del cuadro Nombre de archivo.

  4. Haga clic en Crear.

Access crea la base de datos y la abre para su uso.

Volver al principio

Creación de una base de datos desde cero

Si desea una introducción más exhaustiva a los conceptos que hay detrás de usar Access para crear una base de datos, vea el artículo Conceptos básicos del diseño de la base de datos.

Si ninguna de las plantillas se ajusta a sus necesidades o si tiene datos en otro programa que desea usar en Access, puede decidir que es mejor crear una base de datos desde cero. En Access 2010, tiene una opción: una base de datos de escritorio estándar o una base de datos web.

Para obtener más información sobre las bases de datos web, vea el artículo Crear una base de datos para compartir en la Web.

Para crear una nueva base de datos, haga lo siguiente:

  1. Inicie Access.

  2. En la pestaña Nuevo de la vista Backstage, haga clic en Base de datos en blanco o Base de datos web en blanco.

    Importante: La elección que haga aquí determinará qué características están disponibles en la base de datos. Las bases de datos de escritorio no se pueden publicar en la Web y las bases de datos web no admiten algunas características de escritorio, como consultas de totales.

  3. A la derecha, escriba un nombre para la base de datos en el cuadro Nombre de archivo.

    Para cambiar la ubicación en la que crea el archivo, haga clic en Examinar texto alternativo junto al cuadro Nombre de archivo, busque y seleccione la nueva ubicación y, a continuación, haga clic en Aceptar.

  4. Haga clic en Crear.

    Access crea la base de datos y, a continuación, abre una tabla vacía (denominada Tabla1) en Vista de hoja de datos.

  5. Access coloca el cursor en la primera celda vacía de la columna Hacer clic para agregar de la nueva tabla.

    Para agregar datos, empiece a escribir o puede pegar datos de otro origen, como se describe en la sección Pegar datos de otro origen en una tabla de Access,más adelante en este artículo.

    Notas: 

    • Escribir datos en la vista Hoja de datos está diseñado para ser muy similar a escribir datos en una hoja de cálculo de Excel. La restricción principal es que los datos deben especificarse en filas y columnas contiguas, empezando en la esquina superior izquierda de la hoja de datos. No debe intentar dar formato a los datos al incluir filas o columnas en blanco como puede hacer en una hoja de cálculo de Excel, ya que si lo hace, se desperdiciará espacio en la tabla. La tabla solo contiene los datos. Todas las presentaciones visuales de los datos se realizarán en los formularios e informes que diseñe más adelante.

    • La estructura de tabla se crea al escribir los datos. Cada vez que agregue una nueva columna a la hoja de datos, se definirá un nuevo campo en la tabla. Access establece la tipo de datos del campo en función del tipo de datos que escriba. Por ejemplo, si tiene una columna en la que solo ha especificado valores de fecha, Access establecerá el tipo de datos de ese campo en Fecha y hora. Si más adelante intenta introducir un valor que no sea de fecha (como un nombre o un número de teléfono) en ese campo, Access muestra un mensaje en el que se le informa de que el valor no coincide con el tipo de datos de la columna. Cuando sea posible, debe planear la tabla para que cada columna contenga el mismo tipo de datos, ya sea texto, fechas, números o algún otro tipo. Esto hace que sea mucho más fácil crear consultas, formularios e informes que seleccionen solo los datos que desee.

Si aún no desea escribir datos, haga clic en Cerrar Imagen del botón .

Nota: Access eliminará Tabla1 si la cierra sin guardar.

Principio de página

Abrir una base de datos existente de Access

Sugerencia: Para abrir rápidamente una de las últimas bases de datos que tenía abiertas, en la pestaña Archivo, haga clic en Recientes y, a continuación, haga clic en el nombre de archivo.

  1. En la pestaña Archivo, haga clic en Abrir.

  2. Haga clic en un acceso directo en el cuadro de diálogo Abrir o, en el cuadro Buscar en, haga clic en la unidad o carpeta que contiene la base de datos que desee.

  3. En la lista de carpetas, haga doble clic en carpetas hasta que abra la carpeta que contiene la base de datos.

  4. Cuando encuentre la base de datos, realice una de las siguientes acciones:

    • Para abrir la base de datos en modo de apertura predeterminado, haga doble clic en ella.

    • Para abrir la base de datos para el acceso compartido en un entorno multiusuario, para que tanto usted como otros usuarios puedan leer y escribir en la base de datos al mismo tiempo, haga clic en Abrir.

    • Para abrir la base de datos para obtener acceso de solo lectura, de modo que pueda verlo pero no editarlo, haga clic en la flecha situada junto al botón Abrir y, a continuación, haga clic en Abrir de solo lectura.

    • Para abrir la base de datos para un acceso exclusivo, para que nadie más pueda abrirla mientras la tiene abierta, haga clic en la flecha situada junto al botón Abrir y, a continuación, haga clic en Abrir exclusivo.

    • Para abrir la base de datos para obtener acceso de solo lectura, haga clic en la flecha situada junto al botón Abrir y, a continuación, haga clic en Abrir solo lectura Exclusiva Otros usuarios pueden abrir la base de datos, pero solo tienen acceso de solo lectura.

Si no encuentra la base de datos que quiere abrir    

  1. En el cuadro de diálogo Abrir, haga clic en el acceso directo Mi PC o, en el cuadro Buscar en, haga clic en Mi PC.

  2. En la lista de unidades, haga clic con el botón derecho en la unidad donde cree que puede estar la base de datos y haga clic en Buscar.

  3. Escriba los criterios de búsqueda y presione ENTRAR para buscar la base de datos.

  4. Si se encuentra la base de datos, ábrala haciendo doble clic en ella en el cuadro de diálogo Resultados de la búsqueda.

    Como la búsqueda se inició desde el cuadro de diálogo Abrir, debe hacer clic en Cancelar en ese cuadro de diálogo antes de que se abra la base de datos.

Puede abrir directamente un archivo de datos en un formato de archivo externo (como dBASE, Paradox, Microsoft Exchange o Excel). También puede abrir directamente cualquier origen de datos ODBC, como, por ejemplo, Microsoft SQL Server o Microsoft FoxPro. Access crea automáticamente una base de datos de Access en la misma carpeta que el archivo de datos y agrega vínculos a cada tabla de la base de datos externa.

Volver al principio

Introducción al uso de la nueva base de datos

Según la plantilla que haya usado, es posible que deba realizar una o varias de las siguientes acciones para empezar a usar la nueva base de datos:

  • Si Access muestra un cuadro de diálogo Inicio de sesión con una lista vacía de usuarios, use el siguiente procedimiento para empezar:

    1. Haga clic en Nuevo usuario.

    2. Rellene el formulario Detalles del usuario.

    3. Haga clic en Guardar y cerrar.

    4. Seleccione el nombre de usuario que acaba de introducir y, a continuación, haga clic en Iniciar sesión.

  • Si Access muestra una hoja de datos vacía, puede empezar a escribir datos directamente en esa hoja de datos o hacer clic en otros botones y pestañas para explorar la base de datos.

  • Si Access muestra una página introducción, puede hacer clic en vínculos de esa página para obtener más información sobre la base de datos o hacer clic en otros botones y pestañas para explorar la base de datos.

  • Si Access muestra un mensaje de advertencia de seguridad en la barra de mensajes y confía en el origen de la plantilla, haga clic en Habilitar contenido. Si la base de datos requiere un inicio de sesión, tendrá que iniciar sesión de nuevo.

Para bases de datos de escritorio y web, también desea empezar con uno de estos pasos:

Volver al principio

Agregar una tabla

Puede agregar una tabla nueva a una base de datos existente mediante las herramientas del grupo Tablas de la pestaña Crear.

Grupo Tablas de la ficha Crear

Nota: En una base de datos web, solo el comando Tabla está disponible en el grupo Tablas.

Independientemente de la vista en la que empiece, siempre puede cambiar a la otra vista con los botones de vista de la barra de estado de la ventana de Access.

Crear una tabla en blanco en la vista Hoja de datos    En la vista Hoja de datos, puede escribir datos inmediatamente y permitir que Access cree la estructura de tabla en segundo plano. Los nombres de campo se asignan numéricamente (Campo1, Campo2, entre otros) y Access establece el tipo de datos de campo, en función del tipo de datos que escriba.

  1. En la pestaña Crear, en el grupo Tablas, haga clic en Tabla Imagen del botón .

  2. Access crea la tabla y, a continuación, coloca el cursor en la primera celda vacía de la columna Hacer clic para agregar.

  3. Para agregar datos, empiece a escribir en la primera celda vacía o puede pegar datos de otro origen, como se describe más adelante en este artículo.

    • Para cambiar el nombre de una columna (campo), haga doble clic en el encabezado de la columna y escriba el nuevo nombre.

      Sugerencia: Asigne un nombre significativo a cada campo para que pueda saber qué contiene sin tener que ver los datos.

    • Para mover una columna, selecciónelo haciendo clic en el encabezado de columna y arrástrela hasta donde quiera. También puede seleccionar varias columnas contiguas y arrastrarlas todas a una nueva ubicación juntos.

      Para agregar más campos a la tabla, puede empezar a escribir en la columna Hacer clic y agregar en la vista Hoja de datos, o bien puede agregar nuevos campos mediante los comandos del grupo Agregar & Eliminar de la pestaña Campos.

Crear una tabla a partir de la vista Diseño    En la vista Diseño, se crea primero la estructura de tabla. A continuación, puede cambiar a la vista Hoja de datos para escribir datos o escribir los datos mediante otro método, como con un formulario.

La vista Diseño no está disponible para tablas en una base de datos web.

  1. En el grupo Tablas de la pestaña Crear, haga clic en Diseño de la tabla. Imagen del botón

  2. Para cada campo de la tabla, escriba un nombre en la columna Nombre de campo y seleccione un tipo de datos en la lista Tipo de datos.

  3. Puede especificar información adicional para cada campo en la columna Descripción. La descripción que escriba se muestra en la barra de estado cuando el punto de inserción se encuentra en ese campo y se usa como texto de la barra de estado para los controles que cree arrastrando el campo desde el panel Lista de campos a un formulario o informe, y para los controles creados para ese campo por el Asistente para formularios o el Asistente para informes.

  4. Tras haber agregado todos los campos, guarde la tabla:

    • En la pestaña Archivo, haga clic en Guardar.

  5. Puede empezar a escribir datos en la tabla en cualquier momento cambiando a la vista Hoja de datos, haciendo clic en la primera celda vacía y escribiendo. También puede pegar datos de otro origen, como se describe en la sección siguiente.

Crear una tabla basada en una lista de SharePoint    Con una lista de SharePoint, las personas que no tienen Access pueden usar sus datos. Además, los datos de lista se almacenan en un servidor, lo que generalmente ofrece una mejor protección frente a la pérdida de datos que los archivos almacenados en un equipo de escritorio. Puede empezar con una lista nueva o puede vincular a una lista existente. Debe tener permisos suficientes en el sitio de SharePoint donde desea crear la lista; esto puede variar según el sitio, por lo que póngase en contacto con el administrador de SharePoint para obtener más información sobre las opciones.

Esta característica no está disponible en una base de datos web.

  1. En la pestaña Crear, en el grupo Tablas, haga clic en Listas de SharePoint.

  2. Puede usar una de las plantillas de lista para crear una lista estándar de SharePoint, como Contactos o Eventos.

    También puede elegir crear una lista personalizada o vincular o importar una lista existente. Haga clic en la opción que quiera.

  3. Si elige cualquiera de las plantillas de lista o para crear una lista personalizada, se abrirá el cuadro de diálogo Crear nueva lista para guiarlo por el proceso. Si elige usar una lista existente, se abrirá el cuadro de diálogo Obtener datos externos para ayudarle.

Para obtener más información sobre las tablas, vea el artículo Introducción a la tabla.

Volver al principio

Pegar datos de otro origen en una tabla de Access

Si los datos se almacenan actualmente en otro programa, como Excel, puede copiar y pegar los datos en una tabla de Access. En general, esto funciona mejor si los datos ya están separados en columnas, tal y como están en una hoja de cálculo de Excel. Si los datos están en un programa de procesamiento de texto, primero debe separar las columnas de datos mediante tabulaciones o convertir los datos en una tabla en el programa de procesamiento de texto y, después, copiar los datos. Si los datos necesitan alguna edición o manipulación (por ejemplo, separar nombres completos en nombres y apellidos), es posible que desee hacerlo antes de copiar los datos, especialmente si no está familiarizado con Access.

Cuando pega datos en una tabla vacía, Access establece el tipo de datos de cada campo según el tipo de datos que encuentra allí. Por ejemplo, si un campo copiado no contiene nada más que valores de fecha, Access aplica el tipo de datos de fecha y hora a ese campo. Si el campo copiado solo contiene las palabras "sí" y "no", Access aplica el tipo de datos Sí/No al campo.

Access asigna nombre a los campos en función de lo que encuentra en la primera fila de datos pegados. Si la primera fila de datos pegaron es similar en tipo a las filas siguientes, Access determina que la primera fila forma parte de los datos y asigna los nombres genéricos de los campos (Campo1, Campo2, y así sucesivamente). Si la primera fila de datos pegaron no es similar a las filas siguientes, Access usa la primera fila como nombres de campo y excluye la primera fila de los datos reales.

Si Access asigna nombres de campo genéricos, se debe cambiar el nombre al campo cuanto antes para evitar confusiones. Use el procedimiento siguiente:

  1. En la pestaña Archivo, haga clic en Guardar para guardar la tabla.

  2. En la vista Hoja de datos, haga doble clic en cada encabezado de columna y, a continuación, escriba un nombre para la columna.

  3. Guarde de nuevo la tabla.

Volver al principio

Importar o vincular datos de otro origen

Es posible que tenga datos que haya estado recopilando en otro programa que le gustaría usar en Access. Quizás trabaje con personas que almacenen sus datos en otros programas y quiera trabajar con sus datos en Access. O bien, puede que tenga varios orígenes de datos distintos y necesite un "teclado de aterrizaje" donde pueda reunirlos todos para un análisis más profundo.

Access facilita la importación o vinculación de datos de otros programas. Puede traer datos de una hoja de cálculo de Excel, de una tabla de otra base de datos de Access, de una lista de SharePoint o de cualquier otra variedad de orígenes. El proceso difiere ligeramente según el origen de datos, pero estas instrucciones le ayudarán a empezar:

  1. En la pestaña Datos externos, en el grupo Importar & vínculo, haga clic en el comando del tipo de archivo desde el que va a importar.

    Por ejemplo, si va a importar datos de una hoja de cálculo de Excel, haga clic en Excel. Si no ve el tipo de programa correcto, haga clic en Más.

    Nota: Si no encuentra el tipo de formato correcto en el grupo Importar vínculo de &, es posible que deba iniciar el programa en el que creó originalmente los datos y, a continuación, usar ese programa para guardar los datos en un formato de archivo compatible con Access (como un archivo de texto delimitado ) y, después, importar o vincular a los datos.

  2. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar para buscar el archivo de datos de origen o escriba la ruta completa del archivo de datos de origen en el cuadro Nombre de archivo.

  3. Haga clic en la opción que desee en Especificar cómo y dónde desea almacenar los datos en la base de datos actual. Puede crear una tabla con los datos importados o crear una tabla vinculada que mantenga un vínculo al origen de datos.

  4. Haga clic en Aceptar.

    Según su elección, se abrirá el cuadro de diálogo Vincular objetos o importar objetos.

  5. Use el cuadro de diálogo para finalizar el proceso. El procedimiento exacto que siga depende de la opción de importación o vínculo que haya elegido.

  6. En la última página del asistente, haga clic en Finalizar.

    Si decide importar, Access le preguntará si desea guardar los detalles de la operación de importación que acaba de completar.

  7. Si cree que volverá a realizar esta misma operación de importación, haga clic en Guardarpasos de importación y, a continuación, escriba los detalles.

    A continuación, puede reproducir fácilmente la operación de importación haciendo clic en Importaciones guardadas en el grupo Importar de la pestaña Datos externos, haciendo clic en la especificación de importación y, a continuación, haciendo clic en Ejecutar.

  8. Si no quiere guardar los detalles de la operación, haga clic en Cerrar.

Access importa los datos a una nueva tabla y, a continuación, muestra la tabla en Tablas en el panel de navegación.

Para obtener más información sobre cómo importar datos a Access, siga los vínculos de la sección Vea también de este artículo.

Volver al principio

Pasos siguientes

El resto del proceso de diseño varía en función de sus objetivos, pero probablemente quiera considerar la posibilidad de crear consultas, formularios, informes y macros. En este artículo no se proporciona información sobre la creación de objetos de base de datos adicionales.

Para obtener más información, vea estos artículos:

Volver al principio

Importar datos de una hoja de cálculo u otro programa

Si está familiarizado con otros programas de base de datos u hojas de cálculo, es probable que conozca los conceptos básicos de cómo funcionan estas aplicaciones y para qué bases de datos se usan. Access difiere de muchas otras aplicaciones de base de datos, ya que le permite crear bases de datos relacionales y difiere aún más de la mayoría de los programas de hoja de cálculo al ofrecer herramientas para desarrollar consultas, formularios e informes sofisticados. Access también ofrece muchas opciones para trabajar con otros programas de base de datos, como SQL Server.

Importar una hoja de cálculo de Excel en Access

Muchas personas comienzan a explorar Access después de crear por primera vez una lista en Excel. Excel es un buen lugar para iniciar una lista, pero a medida que la lista crece, se hace más difícil organizarla y mantenerla actualizada. Mover la lista a Access suele ser el siguiente paso lógico.

Una tabla de base de datos es similar en estructura a una hoja de cálculo, ya que los datos se almacenan en filas y columnas. Como resultado, normalmente es fácil importar una hoja de cálculo a una tabla de base de datos. La principal diferencia entre almacenar los datos en una hoja de cálculo y almacenarlos en una base de datos está en cómo se organizan los datos. Simplemente importar toda la hoja de cálculo como una tabla nueva en una base de datos no resolverá los problemas asociados con la organización y actualización de los datos, especialmente si la hoja de cálculo contiene datos redundantes. Para solucionar estos problemas, debe dividir los datos de la hoja de cálculo en tablas independientes, cada una que contenga datos relacionados. Para obtener más información sobre cómo organizar los datos en las tablas, vea el artículo Conceptos básicos del diseño de la base de datos.

Access incluye el Asistente para analizador de tablas, que puede ayudarle a completar este proceso. Después de importar los datos a una tabla, el asistente le ayuda a dividir la tabla en tablas independientes, cada una de las cuales contiene datos que no están duplicados en ninguna de las otras tablas. El asistente también crea las relaciones necesarias entre las tablas.

Volver al principio

Importar una hoja de cálculo de Excel como una tabla en una nueva base de datos

  1. Haga clic en la pestaña Archivo, en Nuevo y luego, en Base de datos en blanco.

  2. Escriba un nombre para la nueva base de datos en el cuadro Nombre de archivo y, a continuación, haga clic en Crear.

    Se abrirá la nueva base de datos y Access creará una nueva tabla vacía, Tabla1.

  3. Cierre tabla1.

    Cuando se le pregunte si desea guardar los cambios en el diseño de tabla1, haga clic en No.

  4. En la pestaña Datos externos, en el grupo Importar & vínculo, haga clic en Excel. Imagen del botón

  5. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar.

  6. Use el cuadro de diálogo Abrir archivo para localizar el archivo.

  7. Seleccione el archivo y haga clic en Abrir.

  8. En el cuadro de diálogo Obtener datos externos, asegúrese de que la opción Importar los datos de origen en una tabla nueva de la base de datos actual está seleccionada.

  9. Haga clic en Aceptar.

    Se inicia el Asistente para importar hoja de cálculo y le pregunta algunas preguntas sobre los datos.

  10. Siga las instrucciones y haga clic en Siguiente o Atrás para desplazarse por las páginas. En la última página del asistente, haga clic en Finalizar.

    Nota: Access le pregunta si desea guardar los detalles de la operación de importación que acaba de completar. Si cree que volverá a realizar esta misma operación de importación, haga clic en y, a continuación, escriba los detalles. A continuación, puede reproducir fácilmente la operación en el futuro haciendo clic en Importaciones guardadas en el grupo Importar de la pestaña Datos externos. Si no quiere guardar los detalles de la operación, haga clic en Cerrar.

Access importa los datos a una nueva tabla y, a continuación, los muestra en Todas las tablas en el panel de navegación.

Volver al principio

Usar el Asistente para analizador de tablas para organizar los datos

Después de importar los datos a una tabla de Access, puede usar el Asistente para analizador de tablas para identificar rápidamente datos redundantes. A continuación, el asistente proporciona una forma sencilla de organizar los datos en tablas independientes, de modo que se almacenen de la manera más eficaz. Access conserva la tabla original como copia de seguridad y, a continuación, crea nuevas tablas que puede usar como base para la aplicación de base de datos.

  1. Abra la base de datos de Access que contiene la tabla que desea analizar.

  2. En la pestaña Herramientas de base de datos, en el grupo Analizar, haga clic en Analizar tabla.

    Se inicia el Asistente para analizador de tablas.

    Las dos primeras páginas del asistente contienen un breve tutorial, con botones en los que puede hacer clic para ver ejemplos. Si no ve las páginas de introducción, pero en su lugar ve una casilla con la etiqueta ¿Mostrar páginas introductorias?, active la casilla y, después, haga clic dos veces en Atrás para ver la introducción. Si no desea volver a ver las páginas introductorias después de leer la introducción, puede despejar la casilla ¿Mostrar páginas introductorias?.

  3. En la página ¿Qué tabla contiene campos con valores que se repiten en muchos registros?, seleccione la tabla que desea analizar y, a continuación, haga clic en Siguiente.

  4. Puede dejar que el asistente decida qué campos van en qué tablas o puede tomar esa decisión usted mismo. Si sigue las sugerencias del asistente, puede realizar cambios en el diseño de tabla en la página siguiente del asistente.

    Nota: Si deja que el asistente decida qué campos colocar en qué tablas, es posible que sus opciones no sean siempre adecuadas para los datos, especialmente si no hay muchos datos con los que trabajar. Debe comprobar cuidadosamente los resultados del asistente. Por otro lado, es posible que el asistente sugiera una organización más eficiente que la que está pensando, por lo que es una buena idea al menos probar las decisiones del asistente una vez. Si no le gustan las sugerencias, puede reorganizar los campos manualmente y siempre puede hacer clic en Atrás y organizar todos los campos usted mismo.

  5. Haga clic en Siguiente. En esta página, especifique qué tablas contienen los campos. Si decide dejar que el asistente decida, debería ver varias tablas conectadas por líneas de relación. En caso contrario, Access crea solo una tabla que contiene todos los campos. En cualquier caso, puede realizar cambios en esta página.

    • Puede arrastrar campos de una tabla a un área en blanco de la página para crear una nueva tabla que contenga esos campos. Access le pide un nombre de tabla.

    • Puede arrastrar campos de una tabla a otra si cree que se almacenarán de forma más eficiente allí.

    • La mayoría de las tablas recibirán un id. oun campo id. único generado. Para obtener más información sobre los campos id., haga clic en Sugerencias en la esquina superior derecha del asistente.

    • Para deshacer un cambio, haga clic en el botón Deshacer.

    • Para cambiar el nombre de una tabla, haga doble clic en la barra de título, escriba el nuevo nombre y, a continuación, haga clic en Aceptar.

  6. Una vez que haya organizado los campos de la forma que desee, haga clic en Siguiente.

  7. Si el asistente encuentra registros que tienen valores muy similares, identificará esos valores como posibles errores tipográficos y presentará una pantalla donde puede confirmar qué hacer al respecto. Desplácese por la lista para buscar cualquiera que tenga valores en la columna Corrección y, a continuación, haga clic en el elemento correspondiente en la lista desplegable. Seleccione (Dejar tal como está) para evitar que el asistente realice cambios en el valor. Cuando haya terminado, haga clic en Siguiente.

  8. El asistente le pregunta si desea crear una consulta similar a la tabla original. Si ya ha creado formularios e informes basados en la tabla original, crear una consulta de este tipo es una buena idea. Si elige Sí, cree la consulta,el asistente cambiará el nombre de la tabla original anexando "_OLD" al nombre de la tabla y, a continuación, asigne un nombre a la nueva consulta con el nombre de la tabla original. Los formularios e informes basados en la tabla ahora usan la consulta para sus datos y siguen funcionando como antes.

  9. Haga clic en Finalizar.

    El asistente crea las nuevas tablas según lo especificado y, a continuación, las abre. Cerrarlas cuando haya terminado de inspeccionar los resultados.

Volver al principio

Trabajar con datos de otros programas

Access 2010 proporciona características para trabajar con datos almacenados en otros programas.

Crear una nueva base de datos de Access que se vincula a datos en otro formato de archivo    Puede usar Access para abrir un archivo en otro formato de archivo como texto, dBASE o una hoja de cálculo. Access crea automáticamente una base de datos de Access y vincula el archivo por usted.

  1. Inicie Access.

  2. En la pestaña Archivo, haga clic en Abrir.

  3. En el cuadro de diálogo Abrir, haga clic en el tipo de archivo que desea abrir en la lista. Si no está seguro del tipo de archivo, haga clic en Todos los archivos (*.*).

  4. Si es necesario, busque la carpeta que contiene el archivo que desea abrir. Cuando encuentre el archivo, haga doble clic en él para abrirlo.

  5. Siga las instrucciones del asistente. En la última página del asistente, haga clic en Finalizar.

Importar o vincular datos a una base de datos de Access existente    Puede importar datos de otros orígenes y programas a tablas de Access para que los datos se contengan en el archivo de Access, o bien puede vincularlos desde Access para que los datos permanezcan en el archivo original (fuera del archivo de Access).

  1. En la pestaña Datos externos, en el grupo Importar & vínculo, haga clic en el formato en el que se almacenan los datos.

    Puede importar o vincular a datos de los siguientes orígenes:

    • Excel    Puede traer datos de una hoja de cálculo o un rango con nombre en un libro de Excel. Cada hoja de cálculo o rango con nombre debe importarse o vincularse por separado.

    • Access    Esto es muy útil para separar el proceso de los datos y crear una base de datos dividida. Es decir, puede usar una base de datos para contener todos los formularios, informes y macros, y mantener los datos en otra base de datos. A continuación, puede desarrollar mejoras sin interrumpir el trabajo de nadie. También puede combinar datos de muchas bases de datos de Access diferentes en una, lo que facilita resumir datos entre departamentos o entre socios empresariales.

    • base de datos ODBC    Muchos programas admiten este formato, incluidos muchos productos de servidor de bases de datos. Esto le ayuda a crear bases de datos de "plataforma de aterrizaje", donde combina datos de diferentes sistemas.

    • Archivo de texto    Puede conectarse a un archivo de texto sencillo e incluso puede usar Access para cambiar el contenido de ese archivo. Esto puede ayudar a que los datos de Access se puedan consumir fácilmente en una amplia variedad de programas.

    • Archivo XML    Este formato también ofrece compatibilidad con una variedad de otros programas, incluidos algunos servidores web.

    • Lista de SharePoint    Esto hace que los datos se pueden usar con un explorador web, la forma estándar de usar una lista de SharePoint.

    • Servicios de datos    Puede conectarse a servicios de datos web dentro de su empresa.

    • Documento HTML    

    • Carpeta de Outlook    Puede conectarse a carpetas de Outlook para integrar más fácilmente la información de contacto con el resto de los datos.

    • archivo dBase    dBase es un sistema de base de datos alternativo popular que es compatible con Access

      Aparecerá el cuadro de diálogo Obtener datos externos.

  2. Siga las instrucciones del cuadro de diálogo.

    Access importará o vinculará los datos a la base de datos. Para la mayoría de los formatos, debe especificar la ubicación de los datos y, a continuación, elegir cómo desea que los datos se almacenen en la base de datos.

Volver al principio

Usar una base de datos de versión anterior en varias versiones de Access

Si su base de datos de Access o proyecto de Access se creó en Access 2000 o posterior, puede usar la base de datos o el proyecto en la versión de Access en la que se creó o en cualquier versión posterior, incluso si el archivo está habilitado para la seguridad. Por ejemplo, los archivos de Access 2000 se pueden usar en Access 2000, Access 2002, Access 2003, Access 2007 y Access 2010.

Es posible que tenga una situación en la que desee conservar los datos en una versión anterior de Access, pero tiene usuarios con una versión posterior de Access que quieren vincular a estos datos pero que siguen aprovechando algunas de las características de la versión posterior. La solución es crear una nueva base de datos "front-end" en la versión posterior (que contenga formularios, informes, consultas, macros, pero sin tablas) y vincularla a las tablas del archivo de versión anterior. Use uno de los procedimientos siguientes, dependiendo de si la base de datos está contenida en un archivo o ya está dividida en un aplicación front-end/back-end.

Usar un archivo de base de datos de Access en varias versiones de Access

Si todas las tablas, formularios y otros objetos de la base de datos de Access de versión anterior están contenidos en un archivo y desea usar la base de datos en varias versiones de Access, puede crear una nueva base de datos front-end en una versión posterior y vincularla al archivo original. Los usuarios que tengan la versión anterior de Access todavía pueden usar la base de datos original. Los usuarios que tengan la versión posterior pueden usar la nueva base de datos front-end para vincular a los mismos datos. Puede crear varias versiones front-end si necesita adaptarse a varias versiones de Access.

Volver al principio

Paso 1: Crear una copia de la base de datos existente y guardarla en un nuevo formato

Use el procedimiento siguiente para convertir la base de datos a cualquiera de los tres formatos más recientes: Access 2000, Access 2002-2003 o Access 2007. Este comando conserva la base de datos original en su formato original y crea una copia en el formato que especifique.

  1. Cierre el archivo de Access. Si el archivo es una base de datos de Access multiusuario ubicada en un servidor o en una carpeta compartida, asegúrese de que nadie más lo tiene abierto.

  2. Inicie Access 2010.

  3. En la pestaña Archivo, haga clic en Abrir.

  4. Busque la ubicación del archivo que desea convertir y, después, haga doble clic en él para abrirlo.

    Si aparece el cuadro de diálogo Mejora de la base de datos, para preguntar si desea mejorar la base de datos, haga clic en No.

  5. Si se abre un formulario al iniciar la base de datos, cierre el formulario.

  6. En la pestaña Archivo, haga clic en Guardar base de datos como.

  7. En el cuadro de diálogo Guardar como, escriba un nombre para la nueva base de datos.

    Nota: A menos que guarde la nueva base de datos en una ubicación diferente, su nombre debe ser diferente del de la base de datos original. En ambos casos, normalmente es mejor usar un nombre diferente, de modo que pueda distinguir fácilmente entre la base de datos front-end y la base de datos back-end. Sin embargo, si va a convertir al formato de Access 2007, la extensión de nombre de archivo cambia de .mdb a .accdb, para que pueda usar el mismo nombre de archivo.

  8. Haga clic en Guardar.

Volver al principio

Paso 2: Dividir la base de datos de copia y usar el archivo original como base de datos back-end

Divida la base de datos convertida mediante el procedimiento siguiente:

  • En la pestaña Herramientas de base de datos, en el grupo Mover datos, haga clic en Base de datos de Access. Imagen del botón

  • En el cuadro de diálogo Divisor de base de datos, haga clic en Dividir base de datos.

    Puede realizar una copia de seguridad si lo desea, pero también puede volver a crear la copia con la base de datos original.

  • Escriba un nombre para la base de datos back-end y, a continuación, haga clic en Dividir.

Volver al principio

Paso 3: Conectar el nuevo front-end a la base de datos original

  1. Elimine la base de datos back-end que creó la herramienta Divisor de base de datos, con cuidado de no eliminar la base de datos original.

  2. Vincule la nueva base de datos front-end a las tablas de la base de datos original: En la pestaña Datos externos, en el grupo Importar & vínculo, haga clic en Administrador de tablas vinculadas. Imagen del botón

  3. Haga clic en Seleccionar todoy, a continuación, active la casilla Solicitar siempre nueva ubicación.

  4. Haga clic en Aceptar,busque la base de datos de versión anterior y, después, haga doble clic en ella.

    Si todo va bien, Access muestra un mensaje que indica que todas las tablas vinculadas seleccionadas se actualizaron correctamente.

Ahora puede mejorar la nueva base de datos front-end para admitir nuevas características para los usuarios que tengan versiones más recientes de Access. Los usuarios que tengan versiones anteriores pueden seguir usando la base de datos de versiones anteriores.

Volver al principio

Usar una aplicación front-end/back-end en varias versiones de Access

Si la base de datos de Access ya es aplicación front-end/back-end, puede convertir el front-end al nuevo formato de archivo. No es necesario realizar cambios en la base de datos back-end.

El procedimiento siguiente muestra cómo usar el comando Guardar base de datos como para convertir la base de datos front-end a cualquiera de los tres formatos más recientes: Access 2000, Access 2002-2003 o Access 2007. Este comando conserva la base de datos original en su formato original y crea una copia en el formato que especifique.

  1. Cierre la base de datos front-end. Si el archivo es una base de datos de Access multiusuario ubicada en un servidor o en una carpeta compartida, asegúrese de que nadie más lo tiene abierto.

  2. Inicie Access 2010.

  3. En la pestaña Archivo, haga clic en Abrir.

  4. Busque la ubicación de la base de datos front-end y, después, haga doble clic en ella para abrirla.

    Si aparece el cuadro de diálogo Mejora de la base de datos, para preguntar si desea mejorar la base de datos, haga clic en No.

  5. Si aparece un formulario al abrir la base de datos, cierre el formulario.

  6. En la pestaña Archivo, haga clic en Guardar base de datos como.

  7. En el cuadro de diálogo Guardar como, escriba un nombre para la nueva base de datos.

  8. Haga clic en Guardar.

Ahora puede mejorar la nueva base de datos front-end para admitir nuevas características.

Volver al principio

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

×