Cuando necesite buscar datos que cumplan más de una condición, como unidades vendidas entre abril y enero, o unidades vendidas por Nancy, puede usar las funciones Y y O juntas. Aquí le mostramos un ejemplo:

Usar Y y O en la misma fórmula

Esta fórmula anida la función Y dentro de la función O para buscar unidades vendidas entre el 1 de abril de 2011 y el 1 de enero de 2012, o cualquier unidad vendida por Nancy. Puede ver que devuelve Verdadero para las unidades vendidas por Nancy y también para las unidades vendidas por Tim y Ed durante las fechas especificadas en la fórmula.

Esta es la fórmula de un formulario que puede copiar y pegar. Si desea jugar con él en un libro de ejemplo, vea el final de este artículo.

=O(Y(C2>FECHA(2011,4,30),C2<DATE(2012,1,1)),B2="Nancy")

Vamos a profundizar un poco más en la fórmula. La función O requiere un conjunto de argumentos (fragmentos de datos) que puede probar para ver si son verdaderos o falsos. En esta fórmula, el primer argumento es la función Y y la función FECHA anidada dentro de ella, el segundo es "Nancy". Puede leer la fórmula de esta manera: Pruebe si una venta se realizó después del 30 de abril de 2011 y antes del 1 de enero de 2012, o si la realizó Nancy.

La función Y también devuelve Verdadero o Falso. La mayoría de las veces, usa Y para ampliar las capacidades de otra función, como O y SI. En este ejemplo, la función O no encontraría las fechas correctas sin la función Y.

Usar Y y O con SI

También puede usar Y y O con la función SI.

Las funciones Y y O anidadas en una función SI

En este ejemplo, las personas no ganan bonificaciones hasta que venden al menos bienes por valor de 125.000 dólares, a menos que trabajen en la región sur, donde el mercado es más pequeño. En ese caso, pueden optar a una bonificación después de 100 000 $ en ventas.

=SI(O(C4>=125000,AND(B4="South",C4>=100000))=VERDADERO,C4*0,12,"Sin bonificación")

Veamos un poco más profundo. La función SI requiere tres partes de datos (argumentos) para ejecutarse correctamente. La primera es una prueba lógica, la segunda es el valor que desea ver si la prueba devuelve Verdadero y la tercera es el valor que desea ver si la prueba devuelve False. En este ejemplo, la función O y todo lo anidado en ella proporcionan la prueba lógica. Puede leerlo como: Busque valores mayores o iguales a 125.000, a menos que el valor de la columna C sea "Sur", busque un valor mayor que 100 000 y, cada vez que ambas condiciones sean verdaderas, multiplique el valor por 0,12, el importe de la comisión. En caso contrario, muestre las palabras "Sin bonificación".

Volver al principio

Datos de ejemplo

Si desea trabajar con los ejemplos de este artículo, copie la tabla siguiente en la celda A1 de su propia hoja de cálculo. Asegúrese de seleccionar toda la tabla, incluida la fila de título.


Vendedor

Región

Ventas

Fórmula/resultado

Miller

Este

87925

=SI(O(C2>=125000,AND(B2="South",C2>=100000))=VERDADERO,C2*0,12,"Sin bonificación")

Stahl

Norte

100000

=SI(O(C3>=125000,AND(B3="South",C3>=100000))=VERDADERO,C3*0,12,"Sin bonificación")

Foster

Oeste

145000

=SI(O(C4>=125000,AND(B4="South",C4>=100000))=VERDADERO,C4*0,12,"Sin bonificación")

Wilcox

Sur

200750

=SI(O(C5>=125000,AND(B5="South",C5>=100000))=VERDADERO,C5*0,12,"Sin bonificación")

Bernabé

Sur

178650

=SI(O(C6>=125000,AND(B6="South",C6>=100000))=VERDADERO,C6*0,12,"Sin bonificación")

Tomás

Norte

99555

=SI(O(C7>=125000,AND(B7="South",C7>=100000))=VERDADERO,C7*0,12,"Sin bonificación")

Keever

Este

147000

=SI(O(C8>=125000,AND(B8="South",C8>=100000))=VERDADERO,C8*0,12,"Sin bonificación")

Cassazza

Norte

213450

=SI(O(C9>=125000,AND(B9="South",C9>=100000))=VERDADERO,C9*0,12,"Sin bonificación")

Brownlee

Sur

122680

=SI(O(C10>=125000,AND(B10="South",C10>=100000))=VERDADERO,C10*0,12,"Sin bonificación")

Smithberg

Oeste

92500

=SI(O(C11>=125000,AND(B11="South",C11>=100000))=VERDADERO,C11*0,12,"Sin bonificación")

Benson

Este

88350

=SI(O(C12>=125000,AND(B12="South",C12>=100000))=VERDADERO,C12*0,12,"Sin bonificación")

Lectura

Oeste

102500

=SI(O(C13>=125000,AND(B13="South",C13>=100000))=VERDADERO,C13*0,12,"Sin bonificación")

Volver al principio

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×