Síntoma
La etiqueta de registro seleccionada está vacía o muestra "Sin nombre" aunque el valor seleccionado aparezca correctamente en la lista de resultados del control de búsqueda.
Por ejemplo,
Causa
El texto que se muestra en las etiquetas no está relacionado con cómo aparece el elemento en la lista de resultados. El texto de etiqueta es el campo principal de una entidad. De forma predeterminada, el campo principal es "Nombre". Para la entidad Usuario, es "Nombre completo". El campo principal es un campo obligatorio en la interfaz de usuario, pero puede estar vacío.
-
El registro tiene un valor para su campo principal y, después, es probable que esta columna falte en la vista. Compruebe la vista que se representa para asegurarse de que el campo principal está presente y en la posición más a la izquierda.
Por ejemplo, compruebe la columna principal de la vista de búsqueda de la cuenta
-
El registro no tiene un valor para su campo principal. Podría estar relacionado con una migración no correcta de la base de datos.
Mitigación
Solución para cada causa
-
Si la columna no se encuentra en la vista. Agregue la columna en la vista.
Haga clic en "Agregar columnas" para agregar la columna principal
La columna principal suele ser Nombre o Nombre completo para la entidad de usuario.