Síntomas
Cuando intenta utilizar HTTP para tener acceso a un recurso prohibido desde un servidor Web que devuelve un código de estado HTTP 403, el cliente de Microsoft.NET Framework 2.0 cierra la conexión persistente con el servidor Web. Dado que para la solicitud siguiente se debe negociar una nueva conexión, este comportamiento puede disminuir el rendimiento del servidor Web y el cliente.
Notas:
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Este comportamiento también se produce al intentar obtener acceso al recurso prohibido mediante HTTPS. Sin embargo, este comportamiento es por diseño cuando se utiliza HTTPS. Para ver el recurso, el cliente que tenga que volver a establecer una nueva conexión HTTPS y volver a autenticarse en el servidor Web.
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Este comportamiento sólo se produce cuando el servidor Web devuelve un código de estado HTTP 403. El cliente de.NET Framework 2.0 no cierra la conexión persistente cuando el servidor Web devuelve otros códigos de estado.
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Este comportamiento no se produce al utilizar las versiones de Microsoft.NET Framework 1.1 o una versión anteriores de la de.NET Framework.
Causa
Este problema se produce porque la versión 2.0 de.NET Framework responde incorrectamente al código de estado HTTP 403 cuando el.NET Framework no utiliza la comunicación de Secure Sockets Layer (SSL) HTTP.
Solución
Ahora hay una revisión compatible de Microsoft, pero sólo se diseñó para corregir el problema que se describe en este artículo. Sólo se aplica a sistemas que experimenten este problema específico. Esta revisión puede ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere al próximo service pack de.NET Framework 2.0 que contenga este hotfix.
Para resolver este problema inmediatamente, póngase en contacto con los servicios de soporte técnico de Microsoft para obtener la revisión. Para obtener una lista completa de números de teléfono de servicios de soporte técnico de Microsoft e información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: En casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.
Requisitos previos
La lista siguiente contiene los requisitos previos de la revisión:
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La de Microsoft.NET Framework 2.0
Requisito de reinicio
No es necesario que reinicie el equipo después de aplicar este hotfix.
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento de fecha y hora del Panel de Control.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
System.dll |
2.0.50727.163 |
3,018,752 |
04-Jun-2006 |
09:24 |
x86 |
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Más información
Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft