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Síntomas

Al intentar agregar nuevos usuarios al Portal de negocios, es posible que el dominio no aparezca en la lista.

Causa

Business Portal no puede obtener acceso al controlador de dominio.

Resolución

Asegúrese de que puede hacer ping al controlador de dominio para el dominio que no aparece en El portal de negocios. Use el comando ping en el servidor que ejecuta Business Portal. Asegúrese de que puede hacer ping por su nombre de NetBios.

Para usar el comando ping, siga estos pasos en el servidor que ejecuta Business Portal:

  1. Haga clic enInicio, haga clic en Ejecutar,escriba cmd y, a continuación, haga clic en Aceptar.

  2. Para hacer ping por nombre, siga estos pasos:

    1. Escriba el comando siguiente:

      ping SERVERNAMENote Reemplazar SERVERNAME por el nombre del controlador de dominio.

    2. Presione ENTRAR.

Solución alternativa 

Si ejecuta Microsoft Business Portal 2.0, Microsoft Business Portal 2.5 o Microsoft Business Portal 2.5 Feature Pack (Portal de negocios 2.7), use el método 1. Si ejecuta Business Portal 3.0, use el método 2.

Método 1: Usar la utilidad Configuración de seguridad para agregar los usuarios del dominio que no aparece en El portal de negocios

Para ejecutar la utilidad Configuración de seguridad, siga estos pasos:

  1. Busque la carpeta bin del sitio web que tiene instalado El portal de negocios. De forma predeterminada, se encuentra en C:\Inetpub\wwwroot\bin.

  2. Haga doble clic en el SecuritySetupUtility.exe.
    Nota Para ejecutar esta utilidad, debe iniciar sesión en el servidor como la persona que instaló Business Portal.

Método 2: Agregar manualmente una entrada al archivo BusinessFramework.config archivo

  1. En Windows Explorador, busque el BusinessFramework.config archivo. De forma predeterminada, este archivo se encuentra en C:\Inetpub\wwwroot\bin.

  2. Abra el archivo con un editor de texto como Bloc de notas.

  3. Agregue la siguiente entrada al archivo:

    <Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>
    <useAlternativeDomainLookup type="Boolean" value="True”/>
    </Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>


    Esta es una sección del aspecto que debe tener el archivo después de agregar la entrada:

    <Microsoft.BusinessFramework.Security.SecureApplicationDirectoryList>
    <directoryList type="String" value="/sites/BusinessPortal/|/BusinessPortal/"/>
    </Microsoft.BusinessFramework.Security.SecureApplicationDirectoryList>

    <Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>
    <useAlternativeDomainLookup type="Boolean" value="True"/>
    </Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>

Más información

Pasos para reproducir el problema

  1. Iniciar portal empresarial.

  2. Haga clic en Configuraciónsitio, haga clic en Usuarios y permisos,haga clic en Administrar usuarios del portalempresarial y, a continuación, haga clic en Agregar nuevos usuarios.

  3. En la ventana Agregar usuarios, haga clic en Siguiente.

No se muestra ningún dominio en la lista Dominio o algunos dominios no aparecen en la lista.

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