Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Recibe periódicamente los siguientes errores al ejecutar los flujos de escritorio:

  • AgentNotReachable : el agente solicitado no es accesible

  • UnresponsiveAgent - El agente rpa no responde

Causa

Estos errores se producen cuando el servicio power automate que se ejecuta en el equipo ya no puede comunicarse con el agente en la sesión de usuario que ejecuta el flujo. Normalmente, se producen por un rendimiento de máquina poco óptimo, como un uso elevado de la CPU, y pueden bloquear temporalmente la comunicación entre el servicio y el agente.

Solución

Si suele tener estos errores, asegúrese de que su equipo cumple los requisitos mínimos.

Si sigue teniendo este problema, puede intentar aumentar el tiempo de espera que usa el servicio power automate para hablar con el agente. De forma predeterminada, este valor se establece en 10 segundos. Para hacerlo:

  1. Abra el Registro para: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Power Automate Desktop\Service

  2. Agregar un nuevo DWORD (32 bits) y asignarle el siguiente nombre: AgentPingTimeoutSeconds

  3. Haga doble clic en el valor para cambiar su configuración. Antes de establecer el valor, haga clic en el botón de radio "Decimal" . Si usa la conectividad directa del equipo (es decir, está usando la aplicación de tiempo de ejecución de la máquina para conectar el equipo a la nube), intente aumentar el valor a 30. Si usa la puerta de enlace de datos local (no se recomienda), cambie el valor a 15.

  4. Reinicia el servicio power automate yendo al administrador de tareas (CTRL-MAYÚS-ESC), seleccionando la pestaña "Servicios", seleccionando "UIFlowService" en la lista, haciendo clic con el botón derecho y seleccionando Reiniciar.

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×