Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Nota Ver el nuevo contenido actualizado el 24/08/21

Síntomas

Después de instalar las actualizaciones del 25 de mayo de 2021(KB5003214)y del 21 de junio de 2021(KB5003690),algunos dispositivos no pueden instalar actualizaciones nuevas, como las actualizaciones del 6 de julio de 2021(KB5004945)o posteriores. Recibirá el mensaje de error "PSFX_E_MATCHING_BINARY_MISSING".  

Causa

Este problema se produce en dispositivos que se han scavenged automáticamente para quitar registros de recursos obsoletos. Cuando se scavenged un sistema, la última actualización acumulativa (LCU) instalada recientemente se marca como permanente y los componentes antiguos se quitan del sistema. Después de completar la búsqueda y de que un dispositivo se encuentra en este estado, no puede desinstalar KB5003214 o KB5003690 y no puede instalar las futurasLCUs.

Solución o solución alternativa

Se recomienda una actualización local. Una actualización local instala un sistema operativo en el dispositivo sin quitar primero la versión anterior. Sus archivos, aplicaciones y configuración no se verán afectados. Hay varias formas de realizar una actualización local, pero solo nos centraremos en lo siguiente:

  • Espere a que Windows Update Medic Service (WaaSMedicSVC) realice automáticamente una actualización local. El Windows Update Medic se ejecuta en segundo plano y diagnostica y repara Windows actualizaciones basadas en el nivel de impacto de evaluación de WaaS. Este proceso de actualización local solo se ejecutará automáticamente en dispositivos que están significativamente desa actualizar.

  • Para obtener una resolución más rápida, realice una actualización manual en la posición como se describe a continuación. Al hacerlo, se instalará la actualización de calidad de seguridad más reciente disponible.  Esta es nuestra solución alternativa preferida.

    Actualizado el 24/24/21 

    NotaLa opción de actualización local solo está disponible para dispositivos que hayan estado en línea durante al menos 30 días. 

    Nota Para dispositivos ARM64, una actualización local solo se realizará correctamente si KB5005932 ya se ha instalado. Puede comprobar que KB5005932 se ha instalado yendo Configuración> Windows actualizar > historial de actualizaciones> otras actualizaciones. Si los dispositivos ARM64 no tienen KB5005932 instalado, seleccione Buscar actualizaciones en la página de configuración de actualización de Windows para iniciar un examen.

Actualización manual local 

  1. Para abrir una ventana del símbolo del sistema, escriba "cmd" o "símbolo del sistema" en el cuadro de búsqueda.

  2. Seleccione Ejecutar como administrador.

    texto alternativo

  3. A continuación, generará el valor de clave del Registro necesario para que un dispositivo esté dirigido a una actualización local.  En el símbolo del sistema, escriba lo siguiente:

    Reg.exe Agregar HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion /v AllowInplaceUpgrade /t REG_DWORD /f /d 1

    texto alternativo

  4. Presione Entrar.

    Nota Este valor del Registro se quitará una vez completada la actualización local. La actualización local puede tardar hasta 48 horas en ofrecerse al dispositivo. Una vez ofrecido, el dispositivo se actualizará a una versión limpia del sistema operativo que se encuentra actualmente en el equipo. También tendrá la última actualización mensual de calidad de seguridad. Después de la actualización local, el dispositivo podrá realizar las actualizaciones con normalidad.

Obtener más información

Microsoft ha confirmado que se trata de un problema en los productos de Microsoft que aparecen en la lista

en la sección "Se aplica a".

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×