Síntomas
Al abrir la página Administrar usuarios del portal empresarial en Portal de negocios en Microsoft Dynamics GP o en Microsoft Dynamics SL, recibirá el siguiente mensaje de error:
displayError: --- soap:Server System.Web.Services.Protocols.SoapException:Server no pudo procesar la solicitud. ---> Microsoft.BusinessFramework.Data.EntityDataNotFoundException: Microsoft.Applications.BusinessDesk.Dynamics.User
Causa
Este problema se produce cuando se cumplen las condiciones siguientes:
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El registro de un cliente, un proveedor, un vendedor, un empleado, un usuario o un administrador se eliminó de las bases de datos de back office.
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Un usuario del Portal profesional se asigna a este registro a través de un rol avanzado.
Como el registro se eliminó de las bases de datos de back office, el elemento web Roles avanzados no aparece al abrir la página Administrar usuarios del portal profesional. Por lo tanto, el rol avanzado asignado no se puede desasignado. Como el rol avanzado no se puede desasignado, recibirá el mensaje de error que se menciona en la sección "Síntomas".
Resolución
Para resolver este problema, busque roles avanzados asignados que ya no sean válidos. Para ello, ejecute uno de los scripts siguientes:
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Para Microsoft Dynamics GP o para Microsoft Business Solutions: Great Plains, descargue el script AdvdRoleOrphaned_GP.sql. Después, ejecute el script en la base de datos de Dynamics. El siguiente archivo está disponible para su descarga desde el archivo de soluciones empresariales de Microsoft Exchange Server:
AdvdRoleOrphaned_GP.sql Fecha de publicación: El 24 de enero de 2006 Microsoft ha analizado
este archivo en busca de virus. Microsoft usó el software de detección de virus más reciente que había disponible en la fecha en la que se publicó el archivo. El archivo está guardado en servidores de seguridad mejorada que ayudan a prevenir cambios no autorizados del archivo. -
Para Microsoft Dynamics SL o para Microsoft Business Solutions: Solomon, descargue el script AdvRoleOrphaned_SL.sql. A continuación, ejecute el script en la base de datos del sistema. El siguiente archivo está disponible para su descarga desde el archivo de soluciones empresariales de Microsoft Exchange Server:
AdvRoleOrphaned_SL.sql Fecha de publicación: El 24 de enero de 2006 Microsoft ha analizado
este archivo en busca de virus. Microsoft usó el software de detección de virus más reciente que había disponible en la fecha en la que se publicó el archivo. El archivo está guardado en servidores de seguridad mejorada que ayudan a prevenir cambios no autorizados del archivo.
Nota: Se genera un informe al ejecutar el script. Si el script encuentra roles avanzados asignados que ya no son válidos, se proporciona un script de limpieza en el informe. Por ejemplo, el informe de la sección "Más información" proporciona un script de limpieza que describe cómo eliminar un registro.
Más información
El script genera un informe similar al siguiente:Buscar id. de usuario: LESSONUSER1 de tipo: Microsoft.Applications.BusinessDesk.Dynamics.User No se encontró la función BACK Office/Enterprise LESSONUSER1 en la tabla patrón de usuario
(SY01400).
Id. de usuario: 110A1DC6-F1E8-4892-B517-4DE353D63DDE
RoleID: 97EFA56C-75A9-489D-9ACA-2BF0DCFCA1B0
Container ID: D98C1DD4-008F-04B2-E980-0998ECF8427E
Constituent Role: <entityKey><Microsoft.Applications.BusinessDesk.Dynamics.User ID="LESSONUSER1" /></entityKey>Para eliminar este registro, ejecute lo siguiente: eliminar de
MbfRoleUser donde (UserID = '110A1DC6-F1E8-4892-B517-4DE353D63DDE' y
RoleID = '97EFA56C-75A9-489D-9ACA-2BF0DCFCA1B0' y ContainerID = 'D98C1DD4-008F-04B2-E980-0998ECF8427E')