Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Imagine el siguiente escenario:

  • Tiene un documento XML Paper Specification (XPS) que está alojado en un sitio Web.

  • El sitio Web está configurado para utilizar autenticación básica o autenticación de formularios con una cookie de sesión.

  • Ejecute XPSViewer.exe para tener acceso al documento XPS en un equipo que ejecuta.NET Framework 3.5 Service Pack 1 (SP1).

En este escenario, se bloquea XPSViewer.exe. Además, recibirá el siguiente mensaje de error:

XPSViewer.exe ha detectado un problema y debe cerrarse. Sentimos las molestias.

Causa

Este problema se produce debido a un error en XPSViewer.exe. Este error produce el error que se produzca cuando el Visor de XPS le pide que escriba una credencial de usuario.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Debe tener la versión.NET Framework 3.5 SP1 instalado para aplicar esta revisión.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar esta revisión si no se utiliza ninguna instancia del de.NET Framework.

Información de reemplazo de revisión

Esta revisión no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.

Para todas las versiones de x86 de Windows Server 2000, Windows Server 2003 y Windows XP

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Xpsviewer.exe

3.0.6920.4008

298,304

25-Sep-2009

01:54

x86


Solución alternativa

Para evitar este problema, utilice uno de los métodos siguientes:

  • No utilice la autenticación para el sitio Web.

  • Utilizar autenticación de Windows integrada como la autenticación NTLM o la autenticación Kerberos. Asegúrese de que el documento puede tener acceso sin credenciales de usuario. Por ejemplo, los sitios Web en una zona de la intranet o en sitios de confianza puede tener acceso sin credenciales de usuario.

  • Utilice la autenticación de formularios junto con una cookie persistente.

  • Utilice Microsoft XPS Visor Essentials Pack (EP) en lugar de XPSViewer.exe para abrir el documento.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener Microsoft XPS Essentials Pack, visite el siguiente sitio Web del centro de descarga de Microsoft:

http://www.microsoft.com/downloads/details.aspx?FamilyId=B8DCFFDD-E3A5-44CC-8021-7649FD37FFEE

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×