Síntomas
Imagine la siguiente situación:
-
Generar un proyecto de instalación de Microsoft Visual Studio 2008 y, a continuación, instalar el archivo MSI generado para una ruta de instalación.
-
Migrar el proyecto de instalación para Visual Studio 2010 y, a continuación, realizar las siguientes acciones para una actualización importante:
-
Cambiar el campo de la propiedad ProductVersion principales.
-
Cambiar la propiedad ProductCode .
-
Establezca la propiedad RemovePreviousVersions en True.
-
-
Volver a generar el proyecto de instalación e instale el archivo MSI generado en la misma ruta de instalación.
En este escenario, los archivos y claves del registro para la ruta de instalación desaparecen inesperadamente.
Causa
Este problema se produce porque se utiliza un algoritmo hash diferente para crear el GUID en Visual Studio 2010. Al instalar el archivo MSI que se crea desde el proyecto de instalación de Visual Studio 2010, el archivo MSI determina que el GUID ha cambiado y elimina los archivos y claves del registro para la ruta de instalación basada en la secuencia del proyecto.
Solución
Para resolver este problema, aplique esta revisión. Este hotfix presenta la propiedad BackwardCompatibleIDGeneration . De forma predeterminada, esta propiedad se establece en False. Antes de generar el proyecto de instalación en Visual Studio 2010, deberá establecer explícitamente la propiedad BackwardCompatibleIDGeneration en True para habilitar la revisión.
Información de la revisión
Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix. Para resolver este problema inmediatamente, póngase en contacto con los servicios de soporte técnico de Microsoft para obtener la revisión. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota En casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión. Para descargar este hotfix desde MSDN Code Gallery, visite el siguiente sitio Web de Microsoft:
http://code.msdn.microsoft.com/KB2418919Nota MSDN Code Gallery muestra los idiomas para los que la revisión está disponible. Si no ve su idioma en la lista, es porque la página de recursos de galería de código no está disponible para ese idioma. O bien, puede descargar este hotfix desde el siguiente sitio Web de Microsoft Connect:
https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=32676
Requisitos previos
Para aplicar este hotfix, debe tener Visual Studio 2010 instalado.
Información de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix. Se recomienda que salga de todas las instancias de Visual Studio o de las aplicaciones de Microsoft.NET Framework antes de aplicar este hotfix.
Información de la sustitución de revisión
Esta revisión no sustituye a ninguna revisión publicada previamente.
Información sobre los archivos
La versión global de esta revisión instala archivos que tienen los atributos que se enumeran en las siguientes tablas. Las fechas y horas de estos archivos se muestran según la Hora universal coordinada (UTC). Las fechas y horas de estos archivos se muestran en el equipo local en horario local con la configuración actual del horario de verano (DST). Además, las fechas y horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Nombre de archivo |
Versión de archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Dpca.dll |
10.0.30319.464 |
236,872 |
11-May-2011 |
13:08 |
x86 |
Dpdpl.dll |
10.0.30319.464 |
145,232 |
11-May-2011 |
13:08 |
x86 |
Dpdpl.dll |
10.0.30319.464 |
145,744 |
11-May-2011 |
13:08 |
x86 |
Dpdpl.dll |
10.0.30319.464 |
146,256 |
11-May-2011 |
13:08 |
x86 |
Dpdpl.dll |
10.0.30319.464 |
147,280 |
11-May-2011 |
13:08 |
x86 |
Dpdpl.dll |
10.0.30319.464 |
147,792 |
11-May-2011 |
13:08 |
x86 |
Dpdpl.dll |
10.0.30319.464 |
148,304 |
11-May-2011 |
13:08 |
x86 |
Dpdpl.dll |
10.0.30319.464 |
904,520 |
11-May-2011 |
13:08 |
x86 |
Dpedt.dll |
10.0.30319.464 |
696,136 |
11-May-2011 |
13:08 |
x86 |
Dpplg.dll |
10.0.30319.464 |
2,606,408 |
11-May-2011 |
13:08 |
x86 |
Dpprj.dll |
10.0.30319.464 |
1,229,640 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
163,152 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
163,664 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
167,248 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
168,272 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
178,000 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
178,512 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
180,560 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
181,072 |
11-May-2011 |
13:08 |
x86 |
Dpprjui.dll |
10.0.30319.464 |
181,584 |
11-May-2011 |
13:08 |
x86 |
Projectsidl3.tlb |
Not applicable |
2,816 |
10-May-2011 |
03:47 |
Not applicable |
Solución alternativa
Como solución alternativa para este problema, utilice uno de los métodos siguientes:
-
Método 1: Cambiar manualmente todos los GUID del componente para que sea igual a la de Visual Studio 2008.
-
Método 2: Volver a ordenar la acción RemoveExistingProducts después de la acción InstallInitialize . Esto asegura que los archivos antiguos se eliminan y se vuelve a instalar la versión más reciente.Nota Este método no funciona cuando se dispone de componentes compartidos.
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".
Más información
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft