Síntomas
Cuando intenta establecer una sesión de impresión TN3270 mediante el servicio de Microsoft Host Integration Server 2013 TN3270, recibirá el siguiente mensaje de error:
Dispositivo en uso
Una traza de TN3270 que se captura a través de la utilidad de traza SNA contiene el mensaje de error siguiente, más detallado:
RECHAZO DE TIPO DE DISPOSITIVO DE SUBNEG BEGIN TN3270E
Este problema puede producirse incluso si la sesión se muestra como disponible en la consola de administración de Host Integration Server.
Causa
Bajo ciertas condiciones de anticipación, se inicia un temporizador repetitivo de 1 segundo antes de que se limpia la sesión. Esto evita que una nueva sesión para la unidad lógica se establece inmediatamente.
La revisión de la sección "Resolución" cambia el temporizador para que la sesión finaliza inmediatamente. Esto permite la creación inmediata de una nueva sesión para la unidad lógica.
Solución
Microsoft Host Integration Server 2013
La revisión que resuelve este problema se incluye en la actualización acumulativa siguiente:
Actualización acumulativa 3 para Host Integration Server 2013
Revisión de actualización acumulativa 2 para Host Integration Server 2013
Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.
Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.
Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/default.aspx
Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Requisitos previos
Debe tener el paquete de actualización acumulativa 2 para 2013 de Microsoft Host Integration Server instalado para poder aplicar este hotfix. Para obtener más información acerca de cómo obtener el paquete de actualización acumulativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
Paquete 2 de actualización de 2929767 acumulado para Host Integration Server 2013
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".