Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Cuando se ejecuta un sitio Web que se ejecuta la canalización de publicidad en un servidor que está ejecutando Microsoft Commerce Server 2007 o Microsoft Commerce Server 2009, recibirá un mensaje de error similar al siguiente:

HttpContext.Current es nulo de Commerce.CSFLoadHistory.1

Además, se graba un evento similar al siguiente en el registro de aplicación:

Causa

Este problema se produce porque los componentes LoadHistory, SaveHistory y IISAppendToLog comprobación el contexto ASP.NET. Sin embargo, no es necesario que estos componentes comprobar el contexto ASP.NET y en algunas situaciones, esta comprobación puede causar problemas. La canalización de publicidad incluye estos tres componentes. Por lo tanto, se produce este problema.

Solución

Para resolver este problema, aplique esta revisión en el servidor que ejecuta Commerce Server 2007 o Commerce Server 2009.

Para obtener más información acerca de este hotfix

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix. Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión. Nota Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Debe tener instalado uno de los siguientes para aplicar esta revisión:

  • Microsoft Commerce Server 2007 Service Pack 2 (SP2)

  • Microsoft Commerce Server 2009

Información de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix. Sin embargo, debe reiniciar servicios de Internet Information Server (IIS) después de aplicar este hotfix. Para reiniciar IIS, en un símbolo del sistema, escriba el comando siguiente y, a continuación, presione ENTRAR:

iisreset /restartNota Este comando detiene y reinicia todos los servicios IIS que se ejecutan.

Información sobre los archivos

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se expresan de acuerdo con la hora universal coordinada (UTC). Cuando vea la información del archivo, esta se convertirá a la hora local. Para conocer la diferencia entre la hora UTC y la hora local, use la pestaña Zona horaria del elemento Fecha y hora del Panel de control.

Para todas las versiones compatibles basadas en x86 de Commerce Server 2007

Nombre de archivo

Versión de archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Aspintrinsics.dll

6.0.4109.47

16,656

24-Aug-2010

13:46

x86

Csfcomp.dll

6.0.4109.47

281,352

24-Aug-2010

13:48

x86

Para todas las versiones compatibles basadas en x64 de Commerce Server 2007

Nombre de archivo

Versión de archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Aspintrinsics.dll

6.0.4109.47

16,656

24-Aug-2010

13:46

x86

Csfcomp.dll

6.0.4109.47

281,352

24-Aug-2010

13:48

x86

Csfcomp.dll

6.0.4109.47

485,128

24-Aug-2010

13:48

x64

Para todas las versiones compatibles basadas en x86 de Commerce Server 2009

Nombre de archivo

Versión de archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Aspintrinsics.dll

6.0.4171.28

16,656

31-Aug-2010

13:14

x86

Cs2009hotfixhelper.exe

6.0.4171.28

13,080

31-Aug-2010

13:14

x86

Csfcomp.dll

6.0.4171.28

281,352

31-Aug-2010

13:16

x86

Para todas las versiones compatibles basadas en x64 de Commerce Server 2009

Nombre de archivo

Versión de archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Aspintrinsics.dll

6.0.4171.28

16,656

31-Aug-2010

13:14

x86

Cs2009hotfixhelper.exe

6.0.4171.28

13,080

31-Aug-2010

13:14

x86

Csfcomp.dll

6.0.4171.28

281,352

31-Aug-2010

13:16

x86

Csfcomp.dll

6.0.4171.28

485,128

31-Aug-2010

13:16

x64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×