Microsoft Business Solutions-Navision 4.0 y Microsoft Navision 4.0 ahora forman parte de Microsoft Dynamics NAV 4.0. Todas las referencias a Microsoft Business Solutions-Navision o a Microsoft Navision 4.0 corresponden a Microsoft Dynamics NAV.
En este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales.
Síntomas
Totales de Index Field Technology (SIFT) que aparecen en FlowFields se calculan incorrectamente cuando se eliminan registros SIFT en Microsoft SQL Server Option para Microsoft Dynamics NAV 4.0.
Nota: Algunos ejemplos de los FlowFields son el campo inventario en el cuadro de diálogo de la Ficha de producto y el campo Saldo periodo en el cuadro de diálogo Plan de cuentas .Cuando se produce este problema, los FlowFields muestran cantidades incorrectas. Sin embargo, si hace clic en el botón de desplegar en los campos, los importes correctos aparecen en las entradas subyacentes.
Causa
Este problema puede producirse si se elimina un registro SIFT vacío o eliminar varios registros SIFT vacíos. Un registro SIFT vacío es un registro en el que todos los importes son iguales a cero. Cuando más adelante, Microsoft Dynamics NAV intenta actualizar un registro SIFT que se ha eliminado, la actualización se ha anulado. Por lo tanto, el total SIFT se convierte en incorrecto.
Solución
Información de la revisión
Ahora hay una revisión compatible de Microsoft. El hotfix corrige el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.
Para resolver este problema inmediatamente, póngase en contacto con soporte técnico de Microsoft Dynamics y productos relacionados obtener la revisión. Puede iniciar sesión en el sitio de Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio web de Microsoft:
https://mbs.microsoft.com/support/newstart.aspxTambién puede comunicarse con soporte técnico de Microsoft Dynamics y productos relacionados llamando por teléfono al (888) 477-7877.
Nota: En casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.
Cómo obtener la revisión de Microsoft Dynamics NAV o actualizar archivos
Después de solicitar una revisión de Microsoft Dynamics NAV o un archivo de actualización del soporte técnico de Microsoft Dynamics, se le enviará un hipervínculo en un mensaje de correo.
El mensaje incluirá un hipervínculo y una contraseña. Puede usar el hipervínculo para descargar la revisión de Microsoft Dynamics NAV o los archivos de actualización. Al hacer clic en el hipervínculo, se abre el cuadro de diálogo Descargar archivo-Advertencia de seguridad . A continuación, deberá ejecutar, guardar o cancelar la descarga.
Si hace clic en Ejecutar, los archivos comienzan la descarga y el proceso de extracción. Debe especificar una carpeta para los archivos nuevos y, a continuación, proporcione la contraseña.
Si hace clic en Guardar, especifique una ruta de acceso para guardar el archivo comprimido. Cuando se abre el archivo que guardó, deberá especificar una ruta para los archivos. A continuación, debe proporcionar la contraseña incluida en el correo electrónico.
Si hace clic en Cancelar, se detiene el proceso de descarga.
Cómo instalar una revisión de Microsoft Dynamics NAV o un archivo de actualización
Las actualizaciones y revisiones de Microsoft Dynamics NAV están disponibles como archivos únicos. Para instalar una actualización o una revisión de Microsoft Dynamics NAV, utilice la revisión o la actualización de los archivos para reemplazar los archivos de instalación de Microsoft Dynamics NAV existentes. Para ello, siga estos pasos:
-
Utilice la revisión o la actualización de los archivos para reemplazar los archivos siguientes de la instalación del cliente de Microsoft Dynamics NAV.
Nombre del archivo
Versión del archivo
Tamaño de archivo
Fecha
Hora
Plataforma
Dbm.dll
4.0.3.24843
345,552
01-Jul-2007
21:32
x86
Fin.exe
4.0.3.24843
8,119,760
01-Jul-2007
21:32
x86
Fin.exe.manifest
No aplicable
711
01-Jul-2007
10:24
No aplicable
Finhlink.exe
4.0.3.24843
120,272
01-Jul-2007
21:32
x86
Finsql.exe
4.0.3.24843
8,168,912
01-Jul-2007
21:32
x86
Finsql.exe.manifest
No aplicable
714
14-Dec-2006
16:41
No aplicable
Nc_netb.dll
4.0.3.24843
79,312
01-Jul-2007
21:31
x86
Nc_tcp.dll
4.0.3.24843
83,408
01-Jul-2007
21:31
x86
Nc_tcps.dll
4.0.3.24843
91,600
01-Jul-2007
21:32
x86
Ndbcs.dll
4.0.3.24843
1,086,928
01-Jul-2007
21:32
x86
Slave.exe
4.0.3.24843
95,696
01-Jul-2007
21:32
x86
Nota: El cliente de Microsoft Dynamics NAV se instala normalmente en la carpeta siguiente:
C:\Program Files\Microsoft Business Solutions-Navision\Client\Para reemplazar los archivos existentes, siga estos pasos:
-
Cierre Microsoft Dynamics NAV.
-
Busque la carpeta de instalación del cliente de Microsoft Dynamics NAV.
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en la carpeta de instalación del cliente de Microsoft Dynamics NAV.
-
En el cuadro de diálogo Confirmar el reemplazo de archivos , haga clic en Sí para sobrescribir los archivos en la carpeta de instalación.
-
Si la revisión o la actualización incluye las versiones traducidas del archivo fin.stx o del archivo fin.etx, debe reemplazar el archivo fin.stx o fin.etx que se instala en las carpetas de idioma específico de la carpeta de instalación.
Para reemplazar el archivo fin.stx o fin.etx, siga estos pasos.Nota: En el siguiente ejemplo hace referencia a una instalación en alemán.
-
Copie cualquier archivo de W1 fin.stx o fin.etx a la siguiente carpeta:
C:\Program Files\Microsoft Business Solutions-Navision\Client\
-
Copie cualquier archivo fin.stx o fin.etx desde la carpeta ESP en la carpeta siguiente:
C:\Program Files\Microsoft Business Solutions-Navision\Client\ENU\
-
Copie cualquier archivo fin.stx o fin.etx desde la carpeta DEU a la siguiente carpeta:
C:\Program Files\Microsoft Business Solutions-Navision\Client\DEU\En algunos casos, los archivos ejecutables de cliente nuevo convierten el formato de base de datos. Por lo tanto, debe actualizar a todos los clientes. Para la opción nativa, también debe actualizar la instalación del servidor.
-
-
-
Si tiene instalado Microsoft Dynamics NAV Application Server, sustituya los archivos siguientes en la instalación de Microsoft Dynamics NAV Application Server.
Nombre del archivo
Versión del archivo
Tamaño de archivo
Fecha
Hora
Plataforma
Dbm.dll
4.0.3.24843
345,552
01-Jul-2007
21:32
x86
Nas.exe
4.0.3.24843
1,422,800
01-Jul-2007
21:32
x86
Nassql.exe
4.0.3.24843
1,463,760
01-Jul-2007
21:32
x86
Ndbcs.dll
4.0.3.24843
1,086,928
01-Jul-2007
21:32
x86
Slave.exe
4.0.3.24843
95,696
01-Jul-2007
21:32
x86
Para reemplazar los archivos existentes, siga estos pasos:
-
Detener el servidor de aplicaciones Microsoft Dynamics NAV.
-
Busque el directorio de instalación de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server normalmente se instala en la carpeta siguiente:
C:\Program Files\Microsoft Business Solutions-Navision\Application Server\
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV Application Server.
-
Haga clic en Sí para sobrescribir los archivos en el directorio.
-
Inicie Microsoft Dynamics NAV Application Server.
-
-
Si tiene instalado el controlador ODBC de Microsoft Dynamics NAV, sustituya los archivos siguientes en la instalación del controlador ODBC de Microsoft Dynamics NAV.
Nombre del archivo
Versión del archivo
Tamaño de archivo
Fecha
Hora
Plataforma
Cfront.dll
4.0.3.24843
873,936
01-Jul-2007
21:32
x86
Dbm.dll
4.0.3.24843
345,552
01-Jul-2007
21:32
x86
Nc_netb.dll
4.0.3.24843
79,312
01-Jul-2007
21:31
x86
Nc_tcp.dll
4.0.3.24843
83,408
01-Jul-2007
21:31
x86
Nc_tcps.dll
4.0.3.24843
91,600
01-Jul-2007
21:32
x86
Nodbc.dll
4.0.3.24843
1,227,728
01-Jul-2007
21:32
x86
Nodbccfg.cfg
4.0.3.24843
446,464
01-Jul-2007
11:25
No aplicable
Nodbccfg.hlp
No aplicable
12,940
14-Dec-2006
16:42
No aplicable
Nodbccfg.xml
No aplicable
2,360
14-Dec-2006
16:42
No aplicable
Slave.exe
4.0.3.24843
95,696
01-Jul-2007
21:32
x86
Para reemplazar los archivos existentes, siga estos pasos:
-
Busque el directorio de instalación del controlador ODBC de Microsoft Dynamics NAV. El controlador ODBC de Microsoft Dynamics NAV se instala normalmente en la carpeta siguiente:
C:\Program Files\Common Files\Navision\NODBC\
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en el directorio de instalación del controlador ODBC de Microsoft Dynamics NAV.
-
Haga clic en Sí para sobrescribir los archivos en el directorio.
-
Solución alternativa
Para evitar este problema, deshabilite la propiedad MaintainSIFTIndex en las claves de la tabla afectada. A continuación, habilite la propiedad MaintainSIFTIndex en esas claves. La tabla SIFT se volverán a generar ahora utilizando los importes correctos.
Estado
Microsoft ha confirmado que se trata de un error de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Más información
Para eliminar registros SIFT vacíos, utilice uno de los métodos siguientes.
Método 1
-
En la opción de de Microsoft SQL Server para Microsoft Dynamics NAV, seleccione base de datos en el menú archivo y, a continuación, haga clic en información.
-
Haga clic en tablas. A continuación, haga clic en optimizar.
Método 2
Utilizar secuencias de comandos SQL externos.
Referencias
Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft