El dispositivo USB conectado no se detecta en Windows

Se aplica a: Windows 8.1Windows 8.1 EnterpriseWindows 8.1 Pro

Importante Esta revisión solo es aplicable a Windows 8 y Windows Server 2012. Sin embargo, el resto de la información de este artículo es aplicable a Windows 8.1, Windows Server 2012 R2, Windows 8 y Windows Server 2012.

Síntomas


Imagine la siguiente situación:
  • Tiene un concentrador USB conectado a un equipo que ejecuta Windows 8.1, Windows Server 2012 R2, Windows 8 o Windows Server 2012.
  • Tiene un dispositivo USB conectado a un puerto USB en el concentrador.
  • Extraiga el dispositivo USB del puerto USB de forma segura.
  • Vuelva a conectar el mismo dispositivo USB o un dispositivo USB diferente al mismo puerto USB del concentrador.
En este escenario, el equipo no detecta el dispositivo USB. Nota Este problema afecta a los concentradores USB 2.0 y a los componentes USB 2.0 en los concentradores USB 3.0.

Causa


Este problema se produce porque el puerto USB está deshabilitado después de quitar el dispositivo del puerto de forma segura.

Resolución


Para resolver este problema, instale el paquete acumulativo de actualizaciones de Windows RT, Windows 8 y Windows Server 2012 2845533, o instale la revisión que se describe en este artículo.Además, debe establecer laclave del Registro que se describe en la sección "Información del registro" para habilitar este paquete acumulativo de actualizaciones o revisión.

Información de la actualización

Para obtener más información acerca de cómo obtener este paquete acumulativo de actualizaciones, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2845533 paquete acumulativo de actualizaciones de Windows RT, Windows 8 y Windows Server 2012: junio de 2013

Información de hotfix

Una revisión compatible está disponible en Microsoft. Sin embargo, esta revisión está diseñada para corregir solo el problema que se describe en este artículo. Aplique este hotfix solo a los sistemas que están experimentando este problema específico.Si la revisión está disponible para su descarga, hay una sección "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece esta sección, envíe una solicitud al servicio de atención al cliente y soporte técnico de Microsoft para obtener la revisión.Nota Si se producen problemas adicionales o si se requiere alguna solución de problemas, es posible que tenga que crear una solicitud de servicio independiente. Los costos de soporte técnico habituales se aplicarán a preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente y soporte técnico de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota El formulario "Descarga de revisión disponible" muestra los idiomas para los que está disponible la revisión. Si no ve el idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe ejecutar Windows 8 o Windows Server 2012.

Información de Registro

Importante En esta sección, método o tarea se incluyen pasos que le permitirán modificar el Registro. Sin embargo, se pueden producir problemas graves si modifica el Registro incorrectamente. Por tanto, asegúrese de que sigue estos pasos cuidadosamente. Para mayor protección, realice una copia de seguridad del Registro antes de modificarlo. De esta manera podrá restaurar el Registro en caso de que se produzca un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Hacer una copia de seguridad del Registro y restaurarlo en Windows
Importante  Debe aplicar los siguientes cambios del Registro para resolver este problema en Windows 8.1, Windows Server 2012 R2, Windows 8 o Windows Server 2012.Nota: En Windows 8 y Windows Server 2012, debe crear la clave del Registro antes de reiniciar el equipo (después de haber aplicado este hotfix).Para habilitar la actualización para un dispositivo específico, siga estos pasos:
  1. Deslice el dedo rápidamente desde el borde derecho de la pantalla y pulse Buscar. O bien, si usa un mouse, señale el extremo inferior derecho de la pantalla y haga clic en Búsqueda.
  2. En el cuadro de búsqueda, escriba regedity, a continuación, puntee o haga clic en regedit.
    Icono de aviso
    Si se le pide que introduzca una contraseña de administrador, escriba la contraseña. Si se le pide que proporcione la confirmación, proporcione la confirmación.
  3. Busque y, a continuación, puntee o haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\UsbFlags
  4. En el menú Edición, seleccione Nuevoy, a continuación, puntee o haga clic en Clave.
  5. Escriba un nombre para la nueva clave con el siguiente formato: Notas de vvvvpppprrrr
    1. "vvvv" representa un número hexadecimal de 4 dígitos que identifica el ID de proveedor del dispositivo.
    2. "pppp" representa un número hexadecimal de 4 dígitos que identifica el ID de producto del dispositivo.
    3. "rrrr" representa un número decimal codificado binario de 4 dígitos que contiene el número de revisión del dispositivo.
  6. En el menú Edición, seleccione Nuevoy, a continuación, puntee o haga clic en Valor DWORD (32 bits).
  7. Escriba DisableOnSoftRemove.
  8. Mantenga pulsado o haga clic con el botón derecho en DisableOnSoftRemovey, a continuación, puntee o haga clic en Modificar.
  9. En el cuadro Datos de valor , escriba 0y, a continuación, puntee o haga clic en Aceptar.
  10. Salga del Editor del Registro.
Para habilitar la actualización para todos los dispositivos USB que se enumeran en el equipo, siga estos pasos:
  1. Deslice el dedo rápidamente desde el borde derecho de la pantalla y pulse Buscar. O bien, si usa un mouse, señale el extremo inferior derecho de la pantalla y haga clic en Búsqueda.
  2. En el cuadro de búsqueda, escriba regedity, a continuación, puntee o haga clic en regedit.
    Icono de aviso
    Si se le pide que introduzca una contraseña de administrador, escriba la contraseña. Si se le pide que proporcione la confirmación, proporcione la confirmación.
  3. Busque y, a continuación, puntee o haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\usbhub
  4. En el menú Edición, seleccione Nuevoy, a continuación, puntee o haga clic en Clave.
  5. Escriba HubG.
  6. En el menú Edición, seleccione Nuevoy, a continuación, puntee o haga clic en Valor DWORD (32 bits).
  7. Escriba DisableOnSoftRemove.
  8. Mantenga pulsado o haga clic con el botón derecho en DisableOnSoftRemovey, a continuación, puntee o haga clic en Modificar.
  9. En el cuadro Datos de valor , escriba 0y, a continuación, puntee o haga clic en Aceptar.
  10. Salga del Editor del Registro.
Nota Cuando el valor de la entrada del Registro DisableOnSoftRemove se establece en 0, el sistema no hace nada cuando se quita un dispositivo USB. Cuando el valor de la entrada del Registro DisableOnSoftRemove se establece en 1, el sistema deshabilita el puerto desde el que se quita un dispositivo USB.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix o el cambio del Registro.

Información de la sustitución de revisión

Esta revisión no reemplaza una revisión publicada anteriormente.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".

Más información


Para obtener más información acerca de la entrada del Registro DisableOnSoftRemove y los efectos de habilitar o no deshabilitar un puerto USB en la eliminación temporal, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2401954 El puerto USB permanece activo para dispositivos USB deshabilitados o eliminados de forma segura
Para obtener más información acerca de la terminología de actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Para obtener más información acerca de cómo encontrar ID de hardware para dispositivos específicos, consulte Entradas del registro de dispositivos USB.

Información adicional de archivos

Información adicional de archivos para Windows 8 y Windows Server 2012

Archivos adicionales para todas las versiones compatibles basadas en x86 de Windows 8
Nombre de archivo Update-bf.mum
Versión del archivo No aplicable
Tamaño de archivo 1,763
Fecha (UTC) 03-May-2013
Hora (UTC) 15:04
Plataforma No aplicable
 
Nombre de archivo X86_usbhub3.inf_31bf3856ad364e35_6.2.9200.16603_none_f2e110b11e2c8fc0.manifest
Versión del archivo No aplicable
Tamaño de archivo 2,104
Fecha (UTC) 03-May-2013
Hora (UTC) 03:54
Plataforma No aplicable
 
Nombre de archivo X86_usbhub3.inf_31bf3856ad364e35_6.2.9200.20707_none_f36eaea4374694e6.manifest
Versión del archivo No aplicable
Tamaño de archivo 2,104
Fecha (UTC) 03-May-2013
Hora (UTC) 04:42
Plataforma No aplicable
 
Archivos adicionales para todas las versiones compatibles basadas en x64 de Windows 8 y Windows Server 2012
Nombre de archivo Amd64_usbhub3.inf_31bf3856ad364e35_6.2.9200.16603_none_4effac34d68a00f6.manifest
Versión del archivo No aplicable
Tamaño de archivo 2,108
Fecha (UTC) 03-May-2013
Hora (UTC) 07:10
Plataforma No aplicable
 
Nombre de archivo Amd64_usbhub3.inf_31bf3856ad364e35_6.2.9200.20707_none_4f8d4a27efa4061c.manifest
Versión del archivo No aplicable
Tamaño de archivo 2,108
Fecha (UTC) 03-May-2013
Hora (UTC) 07:05
Plataforma No aplicable
 
Nombre de archivo Update-bf.mum
Versión del archivo No aplicable
Tamaño de archivo 1,989
Fecha (UTC) 03-May-2013
Hora (UTC) 15:05
Plataforma No aplicable