JOSVIRHE-funktion avulla voit ottaa kaavoissa käytettävät virheet käyttöön ja käsitellä niitä. JOSVIRHE palauttaa arvon, jonka määrität, jos kaavan arvoksi tulee virhe. muussa tapauksessa se palauttaa kaavan tuloksen.

Syntaksi

JOSVIRHE(arvo; arvo_jos_virhe)

JOSVIRHE-funktion syntaksissa on seuraavat argumentit:

  • arvo    Pakollinen. Testattava argumentti.

  • value_if_error    Pakollinen. Palautettava arvo, jos kaavan arvo on virhe. Seuraavat virhetyypit arvioidaan: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? tai #NULL!.

Huomautuksia

  • Jos arvo tai value_if_error on tyhjä solu, JOSVIRHE käsittelee sitä tyhjänä merkkijonoarvona ("").

  • Jos arvo on matriisikaava, JOSVIRHE palauttaa tulos matriisin arvona määritetyn alueen kullekin solulle. Lisätietoja on jäljempänä olevassa toisessa esimerkissä.

Esimerkkejä

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel-laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä.

Kiintiö

Myydyt yksiköt

210

35

55

0

23

Kaava

Kuvaus

Tulos

=JOSVIRHE(A2/B2, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe (210 jaettuna 35:llä). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

6

=JOSVIRHE(A3/B3, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe (55 jaettuna nollalla). Koska funktio löytää jako nollalla -virheen, se palauttaa arvo_jos_virhe-argumentin arvon.

Virhe laskutoimituksessa

=JOSVIRHE(A4/B4, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe ("" jaettuna 23:lla). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

0

Esimerkki 2

Kiintiö

Myydyt yksiköt

Suhde

210

35

6

55

0

Virhe laskutoimituksessa

23

0

Kaava

Kuvaus

Tulos

=C2

Tarkistaa, onko matriisin ensimmäisen alkion ensimmäisen argumentin kaavassa virhe (A2/B2 eli 210 jaettuna 35:llä). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

6

=C3

Tarkistaa, onko matriisin toisen alkion ensimmäisen argumentin kaavassa virhe (A3/B3 eli 55 jaettuna nollalla). Koska funktio löytää jako nollalla -virheen, se palauttaa arvo_jos_virhe-argumentin arvon.

Virhe laskutoimituksessa

=C4

Tarkistaa, onko matriisin kolmannen alkion ensimmäisen argumentin kaavassa virhe (A4/B4 eli "" 23:lla). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

0

Huomautus: Jos käytössäsi on Microsoft 365-versio, voit syöttää kaavan tulosalueen vasemmassa yläkulmassa olevassa solussa ja vahvistaa sitten kaavan dynaamisena matriisikaavana painamalla ENTER-näppäintä. Muussa tapauksessa kaava on syötettävä vanhana matriisikaavana valitsemalla ensin tulosalue, syöttämällä kaava tulostusalueen vasemmassa yläkulmassa olevassa solussa ja vahvistamalla se painamalla näppäinyhdistelmää CTRL+VAIHTO+ENTER. Excel lisää puolestasi kaavan alkuun ja loppuun aaltosulkeet. Katso lisätietoja matriisikaavoista kohdasta Matriisikaavoihin liittyviä ohjeita ja esimerkkejä.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta tai saada tukea yhteisön vastauksista.

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Office Insidersiin

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteestasi.

×