Operaattorit määrittävät, minkä tyyppisiä laskutoimituksia haluat suorittaa kaavan osille, kuten lisäykselle, vähennyslaskulle, kertolaskulle tai jakolaskulle. Tässä artikkelissa opit oletusjärjestyksen, jossa operaattorit toimivat laskennan elementtien perusteella. Opit myös, miten voit muuttaa tätä järjestystä sulkeiden avulla.

Operaattoreiden lajit

Käytettävissä on neljänlaisia laskentaoperaattoreita: aritmeettisia operaattoreita, vertailu-, teksti- ja viittausoperaattoreita.

Käytä tämän taulukon aritmeettisia operaattoreita, jos haluat suorittaa matemaattisia peruslaskuja, kuten yhteen-, vähennys- tai kertolaskuja tai yhdistää lukuja tai tuottaa numeerisia tuloksia.

Aritmeettinen operaattori

Merkitys

Esimerkki

+ (plusmerkki)

Yhteenlasku

=3+3

– (miinusmerkki)

Vähennyslasku
Negation

=3–1
=–1

* (tähti)

Kertolasku

=3*3

/ (vinoviiva)

Jakolasku

=3/3

% (prosenttimerkki)

Prosentti

=20 %

^ (sirkumfleksi)

Potenssiin korotus

=

Voit verrata kahta arvoa alla olevassa taulukossa olevia operaattoreita operaattorien avulla. Kun kahta arvoa verrataan näillä operaattoreilla, tuloksena on totuusarvo TOSI tai EPÄTOSI.

Vertailuoperaattori

Merkitys

Esimerkki

= (yhtäläisyysmerkki)

Yhtä suuri kuin

=A1=B1

> (suurempi kuin -merkki)

Suurempi kuin

=A1>B1

< (pienempi kuin -merkki)

Pienempi kuin

=A1<B1

>= (suurempi tai yhtä suuri kuin -merkki)

Suurempi tai yhtä suuri kuin

=A1>=B1

<= (pienempi tai yhtä suuri kuin -merkki)

Pienempi tai yhtä suuri kuin

=A1<=B1

<> (eri suuri kuin -merkki)

Eri suuri kuin

=A1<>B1

Et-merkin (&) avulla voit yhdistää yhden tai useamman tekstimerkkijonon ja tuottaa yhden tekstikappaleen.

Tekstioperaattori

Merkitys

Esimerkki

& (et-merkki)

Muodostaa yhteyden tai yhdistää kaksi arvoa yhden jatkuvan tekstiarvon tuottamiseksi.

="Pohjoinen"&"tuuli"

Yhdistä solualue laskutoimituksia varten näiden operaattoreiden kanssa.

Viittausoperaattori

Merkitys

Esimerkki

: (kaksoispiste)

Alueoperaattori, joka tuottaa yhden viittauksen kaikkiin kahden viittauksen välisiin soluihin, mukaan lukien kaksi eri viittausta.

=SUMMA(B5:B15)

; (puolipiste)

Union-operaattori, joka yhdistää useita viittauksia yhdeksi viittaukseksi.

=SUMMA(B5:B15,D5:D15)

(väli)

Leikkaa-operaattori, joka tuottaa viittauksen soluihin, jotka ovat yhteisiä kahdelle viittaukselle.

=SUMMA(B7:D7 C6:C8)

# (punta)

#-merkkiä käytetään useissa kontekstissa:

  • Käytetään osana virhenimeä.

  • Käytetään ilmaisemaan, ettei hahmonneta riittävästi tilaa. Useimmissa tapauksissa voit leveyden sarakkeen, kunnes sisältö näkyy oikein.

  • Levittynyt alue -operaattori, jonka avulla viitataan koko alueeseen dynaamisessa matriisikaavassa.

  • #ARVO!

  • #####

  • =SUMMA(A2#)

@ (at)

Viittausoperaattori, jota käytetään osoittamaan kaavan implisiittinen leikkaaminen. 

=@A1:A10

=SUMMA(Taulukko1[@[Tammikuu]:[Joulukuu]])

Kaavojen laskentajärjestys Excelissä

Joissakin tapauksissa laskentajärjestys voi vaikuttaa kaavan palautusarvoon, joten on tärkeää ymmärtää järjestys ja se, miten voit muuttaa järjestystä, jotta saat odottamiasi tuloksia.

Kaavat laskevat arvoja tietyssä järjestyksessä. Excel-kaava alkaa aina yhtäläisyysmerkillä (=). Yhtäläisyysmerkki kertoo Excel, että seuraavat merkit muodostavat kaavan. Tämän yhtäläisyysmerkkiä seuraavan jälkeen voi olla laskettava osasarja (operandit), jotka erotetaan toisistaan laskentaoperaattoreilla. Excel laskee kaavan vasemmalta oikealle operaattorien mukaan määräytyvässä järjestyksessä.

Jos kaavassa on useita operaattoreita, Excel suorittaa laskutoimitukset seuraavassa taulukossa kuvatussa järjestyksessä. Jos kaavassa on keskenään samanarvoisia operaattoreita  (esimerkiksi sekä kerto- että jakolaskuoperaattoreita) , ne suoritetaan vasemmalta oikealle.

Operaattori

Kuvaus

: (kaksoispiste)

(yksi väli)

; (puolipiste)

Viittausoperaattorit

Vastaluku (esimerkiksi –1)

%

Prosentti

^

Potenssiin korotus

* ja /

Kerto- ja jakolasku

+ ja –

Yhteen- ja vähennyslasku

&

Kahden merkkijonon yhdistäminen

=
< >
<=
>=
<>

Vertailu

Voit muuttaa laskentajärjestystä lisäämällä kaarisulkeet ensimmäiseksi laskettavan osan ympärille. Esimerkiksi seuraavan kaavan tulos on 11, koska Excel laskee kertolaskun ennen laskemista. Kaava kertoo ensin tuloksen 2 luvulla 3 ja lisää sitten tulokseen 5.

=5+2*3

Jos sen sijaan muutat syntaksia sulkeiden avulla, Excel 5 ja 2 yhteen ja kertoo sitten tuloksen luvulla 3, jotta saadaan 21.

=(5+2)*3

Alla olevassa esimerkissä kaavan ensimmäisen osan ympärille tulevat sulket pakota Excel laskemaan ensin B4+25 ja sitten jakamaan tuloksen solujen D5, E5 ja F5 arvojen summalla.

=(B4+25)/SUM(D5:F5)

Katso lisätietoja tästä Excel Operaattorien tilaus -videosta.

Arvojen Excel muuntaminen kaavoissa

Kun kirjoitat kaavan, Excel on odotettavissa tietyntyyppisiä arvoja kullekin operaattorille. Jos kirjoitat odotettua erilaisen arvon, arvo Excel muuntaa arvon.

Kaava

Tuottamiset

Kuvaus

= "1"+"2"

3

Kun käytät plusmerkkiä (+), Excel kaavassa on odotettavissa lukuja. Vaikka lainausmerkit tarkoittavat, että "1" ja "2" ovat tekstiarvoja, Excel muuntaa tekstiarvot automaattisesti luvuiksi.

= 1+"4,00 $"

5

Kun kaava odottaa lukua, Excel muuntaa tekstin, jos se on muodossa, joka yleensä hyväksytään lukuun.

= "1.6.2001"-"1.5.2001"

31

Excel tulkitsee tekstin päivämääräksi kk/pp/vvvv-muodossa, muuntaa päivämäärät järjestysluvuiksi ja laskee niiden välisen eron.

=QRT ("8+1")

#ARVO!

Excel tekstiä ei voi muuntaa numeroksi, koska tekstiä "8+1" ei voi muuntaa numeroksi. Voit muuntaa tekstin tulokseksi 3 käyttämällä "9" tai "8"+"1" sijaan "8+1".

= "A"&TOSI

ATRUE

Kun teksti on odotettavissa, Excel ja totuusarvot, kuten TOSI ja EPÄTOSI, muunnetaan tekstiksi.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta tai saada tukea yhteisön vastauksista.

Katso myös

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Insider-käyttäjille

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteestasi.

×