Operaattorit määrittävät laskutoimituksen tyypin, jonka haluat suorittaa kaavan elementeille, kuten yhteenlaskulle, vähennyslaskulle, kertolaskulle tai jakolaskulle. Tässä artikkelissa kerrotaan oletusjärjestys, jossa operaattorit toimivat laskutoimituksen elementtien mukaan. Opit myös muuttamaan tätä järjestystä käyttämällä sulkeita.

Operaattoreiden lajit

Käytettävissä on neljänlaisia laskentaoperaattoreita: aritmeettisia operaattoreita, vertailu-, teksti- ja viittausoperaattoreita.

Jos haluat suorittaa matemaattisia perustoimintoja, kuten yhteenlaskun, vähennyslaskun tai kertolaskun tai yhdistää lukuja, ja tuottaa numeerisia tuloksia, käytä tämän taulukon aritmeettisia operaattoreita.

Aritmeettinen operaattori

Merkitys

Esimerkki

+ (plusmerkki)

Yhteenlasku

=3+3

– (miinusmerkki)

Vähennyslasku
Negaation

=3–1
=–1

* (tähti)

Kertolasku

=3*3

/ (vinoviiva)

Jakolasku

=3/3

% (prosenttimerkki)

Prosentti

=20 %

^ (sirkumfleksi)

Potenssiin korotus

=2^3

Alla olevan taulukon operaattorien avulla voit verrata kahta arvoa. Kun näitä operaattoreita verrataan kahteen arvoon, tuloksena on totuusarvo joko TOSI tai EPÄTOSI.

Vertailuoperaattori

Merkitys

Esimerkki

= (yhtäläisyysmerkki)

Yhtä suuri kuin

=A1=B1

> (suurempi kuin -merkki)

Suurempi kuin

=A1>B1

< (pienempi kuin -merkki)

Pienempi kuin

=A1<B1

>= (suurempi tai yhtä suuri kuin -merkki)

Suurempi tai yhtä suuri kuin

=A1>=B1

<= (pienempi tai yhtä suuri kuin -merkki)

Pienempi tai yhtä suuri kuin

=A1<=B1

<> (eri suuri kuin -merkki)

Eri suuri kuin

=A1<>B1

Käytä et-merkkiä (&) yhden tai useamman tekstimerkkijonon liittäminen tai ketjuttaminen yksittäisen tekstikappaleen tuottamiseen.

Tekstioperaattori

Merkitys

Esimerkki

& (et-merkki)

Yhdistää tai yhdistää kaksi arvoa yhden jatkuvan tekstiarvon tuottamiseksi.

="Pohjoinen"&"tuuli"

Yhdistä solualueet laskutoimituksia varten näiden operaattoreiden kanssa.

Viittausoperaattori

Merkitys

Esimerkki

: (kaksoispiste)

Alueoperaattori, joka tuottaa yhden viittauksen kaikkiin kahden viittauksen välisiin soluihin, mukaan lukien kaksi eri viittausta.

=SUMMA(B5:B15)

; (puolipiste)

Yhdistämisoperaattori, joka yhdistää useita viittauksia yhdeksi viittaukseksi.

=SUMMA(B5:B15;D5:D15)

(väli)

Leikkausoperaattori, joka tuottaa viittauksen kahteen viittaukseen yleisiin soluihin.

=SUMMA(B7:D7 C6:C8)

# (pauna)

#-symbolia käytetään useissa yhteyksissä:

  • Käytetään virhenimen osana.

  • Käytetään ilmaisemaan, että hahmontamiseen ei ole riittävästi tilaa. Useimmissa tapauksissa voit leventää saraketta, kunnes sisältö näkyy oikein.

  • Levittyneen alueen operaattori, jota käytetään viittaamaan koko alueeseen dynaamisessa matriisikaavassa.

  • #ARVO!

  • #####

  • =SUMMA(A2#)

@ (at)

Viittausoperaattori, jota käytetään kaavan implisiittisen leikkauskohdan ilmaisemiseen. 

=@A1:A10

=SUMMA(Taulukko1[@[Tammikuu]:[Joulukuu]])

Kaavojen laskentajärjestys Excelissä

Joissakin tapauksissa laskutoimitusten suoritusjärjestys voi vaikuttaa kaavan palautusarvoon, joten on tärkeää ymmärtää järjestys ja se, miten voit muuttaa järjestystä ja saada odotetut tulokset.

Kaavat laskevat arvoja tietyssä järjestyksessä. Excel-kaava alkaa aina yhtäläisyysmerkillä (=). Yhtäläisyysmerkki kertoo Excel, että seuraavat merkit muodostavat kaavan. Tämän yhtäläisyysmerkin jälkeen voidaan laskea joukko elementtejä (operandeja), jotka on erotettu toisistaan laskentaoperaattoreilla. Excel laskee kaavan vasemmalta oikealle operaattorien mukaan määräytyvässä järjestyksessä.

Jos kaavassa on useita operaattoreita, Excel suorittaa laskutoimitukset seuraavassa taulukossa kuvatussa järjestyksessä. Jos kaavassa on keskenään samanarvoisia operaattoreita  (esimerkiksi sekä kerto- että jakolaskuoperaattoreita) , ne suoritetaan vasemmalta oikealle.

Operaattori

Kuvaus

: (kaksoispiste)

(yksi väli)

; (puolipiste)

Viittausoperaattorit

Vastaluku (esimerkiksi –1)

%

Prosentti

^

Potenssiin korotus

* ja /

Kerto- ja jakolasku

+ ja –

Yhteen- ja vähennyslasku

&

Kahden merkkijonon yhdistäminen

=
< >
<=
>=
<>

Vertailu

Voit muuttaa laskentajärjestystä lisäämällä kaarisulkeet ensimmäiseksi laskettavan osan ympärille. Esimerkiksi seuraavan kaavan tuloksena on arvo 11, koska Excel laskee kertolaskun ennen yhteenlaskua. Kaava kertoo ensin luvun 2 luvulla 3 ja lisää sitten tulokseen luvun 5.

=5+2*3

Jos sen sijaan muutat syntaksia sulkeiden avulla, Excel laskee yhteen luvun 5 ja 2 ja kertoo sitten tuloksen luvulla 3 tuottaakseen tuloksen 21.

=(5+2)*3

Alla olevassa esimerkissä kaavan ensimmäisen osan sulkeet pakottavat Excel laskemaan ensin luvun B4+25 ja jakamaan sitten tuloksen solujen D5, E5 ja F5 arvojen summalla.

=(B4+25)/SUM(D5:F5)

Katso lisätietoja katsomalla tämä video operaattorin järjestyksestä Excel.

Kaavojen arvojen muuntaminen Excel

Kun kirjoitat kaavan, Excel odottaa kullekin operaattorille tietyntyyppisiä arvoja. Jos annat erityyppisen arvon kuin odotettiin, Excel voi muuntaa arvon.

Kaava

Tuottaa

Kuvaus

= "1"+"2"

3

Kun käytät plusmerkkiä (+), Excel odottaa lukuja kaavassa. Vaikka lainausmerkit tarkoittavat, että "1" ja "2" ovat tekstiarvoja, Excel muuntaa tekstiarvot automaattisesti luvuiksi.

= 1+"$4.00"

5

Kun kaava odottaa lukua, Excel muuntaa tekstin, jos se on muodossa, joka yleensä hyväksytään lukua varten.

= "1.6.2001"-"1.5.2001"

31

Excel tulkitsee tekstin päivämääräksi kk/kk/vvvv muodossa, muuntaa päivämäärät järjestysluvuiksi ja laskee sitten niiden välisen eron.

=NELIÖJUURI ("8+1")

#ARVO!

Excel ei voi muuntaa tekstiä luvuksi, koska tekstiä "8+1" ei voi muuntaa luvuksi. Voit muuntaa tekstin luvuksi käyttämällä "9" tai "8"+"1" sanan "8+1" sijaan ja palauttaa tuloksen 3.

= "A"&TOSI

ATRUE

Kun tekstiä odotetaan, Excel muuntaa luvut ja totuusarvot, kuten TOSI ja EPÄTOSI, tekstiksi.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta tai saada tukea yhteisön vastauksista.

Katso myös

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Office Insidersiin

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteesta!

×