Luvun pyöristäminen haluttuun desimaalitarkkuuteen

Jos haluat piilottaa tarpeettomat desimaalit, koska soluissa näkyy ######-merkintöjä tai et tarvitse tietoa yhtä täsmällisellä tarkkuudella, määritä haluamasi desimaalimäärä solun muotoiluasetuksiin.

Luvun pyöristäminen lähimpään pääyksikköön

Jos haluat pyöristää luvun lähimpään pääyksikköön, kuten tuhansiin, satoihin, kymmennumeroisiin tai kokonaislukuihin, käytä kaavassa funktiota, toimi seuraavasti:

Painikkeen käyttäminen:

  1. Valitse muotoiltavat solut.

  2. Lisää tai vähennä desimaalipilkun jälkeen näytettävien numeroiden määrää valitsemalla Aloitus-välilehdessä Lisää desimaaleja tai Vähennä desimaaleja.

Valmiin lukumuotoilun käyttäminen:

  1. Napsauta Aloitus-välilehden Luku-ryhmässä lukumuotoilujen luettelon vieressä olevaa nuolta ja valitse Lisää lukumuotoja.

Aloitus-välilehden Numero-ryhmä

  1. Valitse Luokka-luettelosta käyttämäsi tietotyypin mukaan Valuutta, Laskenta, Prosentti tai Tieteellinen.

  2. Lisää Desimaalit-ruutuun desimaalimäärä, jonka haluat näkyviin.

Kaavassa olevan funktion käyttäminen:

Pyöristä lukua haluamallasi tarkkuudella PYÖRISTÄ-funktiolla. Tällä funktiolla on vain kaksi argumenttia (argumentit ovat tietoja, jotka kaavan on suoritettava).

  • Ensimmäinen argumentti on pyöristettävä luku, joka voi olla soluviittaus tai numero.

  • Toinen argumentti on numeroiden määrä, jonka mukaisesti luku pyöristetään.

Oletetaan, että solussa A1 on luku 823,7825. Toimi seuraavasti sen mukaan, mihin tarkkuuteen haluat luvun pyöristää:

  • Lähimpään tuhantee n

    • Kirjoita =PYÖRISTÄ(A1,-3), jolloin luvuksi saadaan 1,000

    • 823,7825 on lähempänä tuhatta kuin nollaa. (Nolla on tuhannen kerrannainen.)

    • Käytä tässä negatiivista lukua, koska haluat, että numeroa pyöristetään desimaalipilkun vasemmalta puolelta. Sama pätee kahteen seuraavaan kaavaan, joissa luku pyöristetään satoihin ja kymmeniin.

  • Lähimpään sataan

    • Kirjoita =PYÖRISTÄ(A1,-2), jolloin luvuksi saadaan 800

    • 800 on lähempänä lukua 823,7825 kuin lukua 900. Toimintaperiaate alkaa varmaan olla selvä.

  • Lähimpään kymmeneen

    • Kirjoita =PYÖRISTÄ(A1,-1), jolloin luvuksi saadaan 820

  • Lähimpään kokonaislukuun

    • Kirjoita =PYÖRISTÄ(A1,0), jolloin luvuksi saadaan 824

    • Jos haluat pyöristää luvun lähimpään kokonaislukuun, käytä nollaa.

  • Lähimpään kymmenesosaan

    • Kirjoita =PYÖRISTÄ(A1,1), jolloin luvuksi saadaan 823,8

    • Kun pyöristät numeroa desimaalien tarkkuudella, käytä positiivista lukua. Sama pätee kahteen seuraavaan kaavaan, joissa luku pyöristetään sadasosiin ja tuhannesosiin.

  • Lähimpään sadasosaan

    • Kirjoita =PYÖRISTÄ(A1,2), jolloin luvuksi saadaan 823,78

  • Lähimpään tuhannesosaan

    • Kirjoita =PYÖRISTÄ(A1,3), jolloin luvuksi saadaan 823,783

Pyöristä lukua ylöspäin käyttämällä PYÖRISTÄ.DES.YLÖS-funktiota. Funktio toimii samalla tavoin kuin PYÖRISTÄ-funktio vain sillä erotuksella, että se pyöristää numeron aina ylöspäin. Jos esimerkiksi haluat pyöristää luvun 3,2 ylöspäin kokonaisluvuksi, kaava on seuraava:

  • =PYÖRISTÄ.DES.YLÖS(3,2;0), jolloin luvuksi saadaan 4

Pyöristä lukua alaspäin käyttämällä PYÖRISTÄ.DES.ALAS-funktiota. Funktio toimii samalla tavoin kuin PYÖRISTÄ-funktio vain sillä erotuksella, että se pyöristää numeron aina alaspäin. Jos esimerkiksi haluat pyöristää luvun 3,14159 alaspäin kolmen desimaalin tarkkuuteen, kaava on seuraava:

  • =PYÖRISTÄ.DES.ALAS(3,14159;3), jolloin luvuksi saadaan 3,141

Vihje:  Jos haluat tutkia muita esimerkkejä tai harjoitella Excel Online -esimerkkitiedostolla, lisätietoja on PYÖRISTÄ- ,PYÖRISTÄ.DES.YLÖS- ja PYÖRISTÄ.DES.ALAS-artikkeleissa.

  1. Napsauta tyhjää solua.

  2. Valitse Kaavat-välilehden Funktio-ryhmässä Kaavan luominen.

  3. Tee jokin seuraavista:

    Toiminto

    Etsi kaavan muodostimella ja kaksoisnapsauta sitten

    Argumentit-kohdassa

    Luvun pyöristäminen ylöspäin

    PYÖRISTÄ.ERÄ

    Kirjoita luku-kenttään luku, jonka pyöristät ylöspäin. Kirjoita num_digits-ruutuun 0, jos haluat pyöristää luvun ylöspäin lähimpään kokonaislukuun.

    Luvun pyöristäminen alaspäin

    PYÖRISTÄ ALASPÄIN

    Kirjoita luku-kenttään alaspäin pyöristysluku. Kirjoita num_digits-ruutuun 0, jos haluat pyöristää luvun ylöspäin lähimpään kokonaislukuun.

    Ylöspäin pyöristäminen tasalukuun

    TASAINEN

    Kirjoita luku-kenttään pyöristysluku.

    Pyöristä ylöspäin parittomaan numeroon

    PARITON

    Kirjoita luku-kenttään pyöristysluku.

    Luvun pyöristäminen toisen luvun lähimpään kerrannaisiin

    MROUND

    Napsauta useita ruutuja -kohdan vieressäja kirjoita sitten luku, jonka lähimpänä olevaa kerrannaista haluat.

  4. Paina RIVINVAIHTONÄPPÄINTÄ.

Excelin asetuksissa voit määrittää oletusarvoisen desimaalipilkun numeroille.

  1. Valitse Asetukset (Excel 2010 Excel 2016) tai Microsoft Office-painike Office-painikkeen kuva > Excel asetukset (Excel 2007).

  2. Valitse Lisäasetukset-luokan Muokkausasetukset-kohdasta Lisää desimaalipilkku automaattisesti -valintaruutu.

  3. Kirjoita Desimaaleja-ruutuun positiivinen luku desimaalipilkun oikealle puolella näkyviä numeroita varten tai negatiivinen luku desimaalipilkun vasemmalla puolella näkyviä numeroita varten.

    Huomautus: Jos kirjoitat Desimaaleja-ruutuun esimerkiksi luvun 3 ja kirjoitat sen jälkeen soluun luvun 2834, arvoksi tulee 2,834. Jos kirjoitat Desimaaleja-ruutuun luvun -3 ja kirjoitat sen jälkeen soluun luvun 283, arvoksi tulee 283000.

  4. Valitse OK.

    Kiinteät desimaaliluvut -ilmaisin näkyy tilarivillä.

  5. Napsauta laskentataulukon solua ja kirjoita haluamasi luku.

    Huomautus: Ennen Kiinteät desimaaliluvut -valintaruudun valitsemista kirjoittamasi tiedot eivät muutu.

  • Voit ohittaa Kiinteät desimaaliluvut -asetuksen tilapäisesti kirjoittamalla lukuun desimaalipilkun.

  • Jos haluat poistaa desimaalipilkun luvusta, johon olet jo valinnut kiinteän desimaaliluvun, toimi seuraavasti:

    1. Valitse Asetukset (Excel 2010 Excel 2016) tai Microsoft Office-painike Office-painikkeen kuva > Excel asetukset (Excel 2007).

    2. Valitse Lisäasetukset-luokan Muokkausasetukset-kohta ja poista Lisää desimaalipilkku automaattisesti -valintaruudun valinta.

    3. Kirjoita tyhjään soluun luku, esimerkiksi 10, 100 tai 1 000, sen mukaan, kuinka monta desimaalia haluat poistaa.

      Kirjoita soluun esimerkiksi 100, jos luvussa on kaksi desimaalia ja haluat muuttaa sen kokonaisluvuksi.

    4. Valitse Aloitus-välilehdenLeikepöytä-ryhmässäKopioi Painikkeen kuva tai paina näppäinyhdistelmää CTRL+C.

    5. Valitse laskentataulukossa solut, jotka sisältävät luvut, joiden desimaalit haluat muuttaa.

    6. Napsauta Aloitus-välilehden Leikepöytä-ryhmässä Liitä-painikkeen alapuolella olevaa nuolta ja valitse Liitä määräten.

    7. Valitse Liitä määräten -valintaikkunan Toiminto-kohdassa Kerro.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta tai saada tukea yhteisön vastauksista.

Katso myös

Luvun pyöristäminen

Miksi luku näkyy pyöristettynä?

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Insider-käyttäjille

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteestasi.

×