Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

Procédure de désinstallation ou de suppression des suites Microsoft Office 2007

Résumé
Cet article fournit des méthodes que vous pouvez suivre pour désinstaller ou supprimer des suites Microsoft Office 2007.

Voulez-vous désinstaller une autre version de Microsoft Office ?

Pour afficher des informations sur la procédure de suppression ou de désinstallation d'une autre version de Microsoft Office, cliquez sur le lien qui correspond à votre version d'Office :

Procédure de désinstallation ou de suppression des suites Microsoft Office 2010
Procédure de désinstallation ou de suppression des suites Microsoft Office 2003
Procédure de désinstallation ou de suppression de Microsoft Office pour Mac 2011
Procédure de désinstallation ou de suppression de Microsoft Office pour Mac 2008
Résolution
Nous vous recommandons de suivre les méthodes fournies dans cet article dans l'ordre. Toutefois, si vous avez déjà essayé l'une des méthode de suppression d'Office et si elle a échoué, vous pouvez passer à une autre méthode rapidement à partir de cette liste :

Méthode 1 : Désinstallation des suites Microsoft Office 2007 à partir du Panneau de configuration

Pour supprimer Microsoft Office 2007 à partir du Panneau de configuration, procédez comme suit :
  1. Ouvrez Programmes et fonctionnalités depuis le Panneau de configuration.
  2. Recherchez l'entrée Microsoft Office dans la liste des programmes installés.
  3. Sélectionnez-la, puis cliquez sur Désinstaller (ou Supprimer dans Windows XP).
  4. Répétez cette étape si vous voyez plusieurs produits Office dans la liste.
  5. Redémarrez l'ordinateur.

Méthode 2 : Désinstallation des suites Microsoft Office 2007 à l'aide de la solution de réparation rapide

Remarque La solution de réparation rapide ne supprime pas les programmes Office individuels qui ont été installés séparément sur votre ordinateur. Par exemple, si vous avez Microsoft Office Professionnel 2007 et Microsoft Office Visio 2007, la solution de réparation rapide ne supprime que Microsoft Office Professionnel 2007. Visio 2007 n'est pas supprimé.
En outre, vous devez redémarrer votre ordinateur si vous utilisez l'une des solutions de réparation rapide.

Pour supprimer la suite Microsoft Office 2007 automatiquement, cliquez sur le bouton Télécharger ou sur le lien. Dans la boîte de dialogue Téléchargement de fichier, cliquez sur Exécuter ou sur Ouvrir, puis suivez la procédure indiquée par l’Assistant de réparation rapide.
  • La solution de réparation rapide pour les suites Microsoft Office 2007 supprime toutes les éditions d'Office 2007, notamment toutes les éditions d'évaluation d'Office 2007.
  • Si vous avez un système d'exploitation Windows 64 bits, téléchargez et enregistrez la solution de réparation rapide sur votre Bureau, puis double-cliquez dessus pour l'exécuter sur votre ordinateur. Si vous tentez d'exécuter la solution directement depuis l'article, vous ne parviendrez pas à l'exécuter correctement.
  • Cet Assistant peut n'exister qu'en anglais. Toutefois, la résolution automatique fonctionne aussi pour d'autres versions linguistiques de Windows.
Pour Windows 8


Pour Windows 7, Windows Vista, Windows Server 2008 ou Windows XP

Méthode 3 : Suppression manuelle des suites Microsoft Office 2007

Remarque Pour exécuter cette méthode, vous devez ouvrir une session avec un compte administrateur. Si votre ordinateur fait partie d'un réseau, vous risquez de devoir demander de l'aide à l'administrateur système. Si vous n'êtes pas sûr d'avoir ouvert une session avec un compte administrateur, reportez-vous à l'article Comment faire pour déterminer votre type de compte d'utilisateur dans Windows pour obtenir de l'aide.

Dans le cadre de cette méthode, vous devez commencer par afficher les fichiers et dossiers cachés. Pour cela, procédez comme suit :
  1. Ouvrez l'Explorateur Windows.
  2. Dans le menu Outils, cliquez sur Options des dossiers. Dans Windows 7 ou Vista, appuyez sur la touche Alt pour afficher la barre de menus.
  3. Cliquez sur l'onglet Affichage.
  4. Dans le volet Paramètres avancés, sous Fichiers et dossiers cachés, cliquez sur Afficher les fichiers et dossiers cachés.
  5. Désélectionnez Masquer les extensions des fichiers dont le type est connu.
  6. Cliquez sur OK, puis fermez les fenêtres.

Vidéo : Procédure de suppression manuelle de la suite Microsoft Office (vidéo en anglais)

Cette vidéo vous indique comment désinstaller ou supprimer manuellement Office 2010 dans Windows 7. Vous pouvez vous reporter à cette vidéo pour exécuter la procédure de suppression manuelle de votre suite Office 2007.
Étape 1 : Suppression de tous les packages Windows Installer restants de Microsoft Office System 2007
  1. Ouvrez le dossier %windir%\Installer. Pour ce faire, cliquez sur Démarrer, cliquez sur Exécuter, tapez %windir%\Installer, puis cliquez sur OK.
  2. Dans le menu Affichage, cliquez sur Choisir les détails.
  3. Activez la case à cocher Objet, tapez 340 dans la zone Taille de la colonne sélectionnée (en pixels), puis cliquez sur OK.
    Remarque L'affichage des objets en regard de chaque fichier .MSI peut prendre plusieurs minutes.
  4. Dans le menu Affichage, pointez sur Trier par dans Windows 7 ou Vista ou pointez sur Réorganiser les icônes par dans Windows XP, puis cliquez sur Objet.
  5. Si la boîte de dialogue Contrôle de compte d'utilisateur s'affiche, cliquez sur Autoriser pour continuer.
  6. Cliquez avec le bouton droit sur chaque fichier .MSI dont le nom est « Microsoft Office <nom_produit> 2007 », puis cliquez sur Désinstaller.
    Remarque L'espace réservé <nom_produit> représente le nom du produit Microsoft Office 2007.
Étape 2 : Arrêt du service Office Source Engine.
  1. Ouvrez la fenêtre Services. Pour ce faire, cliquez sur Démarrer, sur Exécuter, tapez services.msc, puis cliquez sur OK.
  2. Dans la fenêtre Services, déterminez si le service Office Source Engine est en cours d'exécution (« Démarré » apparaît dans la colonne État). Si c'est le cas, cliquez avec le bouton droit sur le nœud Office Source Engine, puis cliquez sur Arrêter.
  3. Fermez la fenêtre Services.
Étape 3 : Supprimez tous les dossiers restants de l'installation de Microsoft Office 2007.
  1. Ouvrez le dossier %CommonProgramFiles%\Microsoft Shared. Pour ce faire, cliquez sur Démarrer, sur Exécuter, tapez %CommonProgramFiles%\Microsoft Shared, puis cliquez sur OK.
    Remarque Sur un ordinateur qui exécute une version 64 bits de Windows 7 ou Vista, tapez %CommonProgramFiles(x86)%\Microsoft Shared, puis cliquez sur OK.
  2. Si les dossiers suivants sont toujours présents, supprimez-les :
    • Office12
    • Source Engine
  3. Ouvrez le dossier %ProgramFiles%\Microsoft Office. Pour ce faire, cliquez sur Démarrer, sur Exécuter, tapez %ProgramFiles%\Microsoft Office, puis cliquez sur OK.
    Remarque Sur un ordinateur qui exécute une version 64 bits de Windows 7 ou Vista, tapez %ProgramFiles(x86)%\Microsoft Office, puis cliquez sur OK.
  4. Supprimez le dossier Office12.
  5. Dans le dossier racine de chaque disque dur, recherchez et ouvrez le dossier MSOCache. Si vous ne voyez pas ce dossier, vous devez afficher les fichiers et dossiers cachés.
  6. Ouvrez le dossier All Users dans le dossier MSOCache, puis supprimez tous les dossiers dont le nom contient 0FF1CE}-.
    Remarque Cette chaîne contient un zéro et un un pour les lettres « O » et « I ».
    Par exemple, {90140000-001B-0409-0000-0000000FF1CE}-C.
Étape 4 : Suppression de tous les fichiers d'installation restants de Microsoft Office 2007
  1. Ouvrez le dossier %AppData%\Microsoft\Templates. Pour ce faire, cliquez sur Démarrer, sur Exécuter, tapez %appdata%\microsoft\templates, puis cliquez sur OK.
  2. Supprimez les fichiers suivants :
    • Normal.dotm
    • Normalemail.dotm
  3. Ouvrez le dossier %AppData%\Microsoft\Document Building Blocks. Pour ce faire, cliquez sur Démarrer, sur Exécuter, tapez %appdata%\microsoft\document building blocks, puis cliquez sur OK.
  4. Ouvrez le sous-dossier qui se trouve dans le dossier des blocs de construction de document.
    Remarque Le titre du sous-dossier est un nombre à quatre chiffres correspondant à la langue de la suite Microsoft Office.
  5. Supprimez le fichier building blocks.dotx.
  6. Fermez tous les programmes avant de poursuivre la procédure.
  7. Ouvrez le dossier %Temp%. Pour ce faire, cliquez sur Démarrer, sur Exécuter, tapez %temp%, puis cliquez sur OK.
  8. Dans le menu Edition, cliquez sur Sélectionner tout.
  9. Dans le menu Fichier, cliquez sur Supprimer.
  10. Ouvrez le dossier %AllUsersprofile%\Application Data\Microsoft\Office\Data. Pour ce faire, cliquez sur Démarrer, sur Exécuter, tapez %AllUsersprofile%\Application Data\Microsoft\Office\Data, puis cliquez sur OK.
  11. Supprimer le fichier opa14.dat (et UNIQUEMENT ce fichier).
Étape 5 : Suppression des sous-clés de Registre de Microsoft Office System 2007
Important Suivez attentivement les étapes de cette section. Des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Avant de modifier celui-ci, sauvegardez le Registre pour une restauration en cas de problèmes.

Recherchez et supprimez les sous-clés de Registre Office 2007 si elles sont présentes. Pour ce faire, procédez comme suit :
  1. Ouvrez l'Éditeur du Registre. Pour cela, cliquez sur Démarrer, sur Exécuter, tapez regedit, puis cliquez sur OK.
  2. Recherchez la sous-clé de Registre suivante et cliquez dessus :

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  3. Dans le menu Fichier, cliquez sur Exporter, tapez DeletedKey01, puis cliquez sur Enregistrer.
  4. Dans le menu Edition, cliquez sur Supprimer, puis sur Oui pour confirmer.
  5. Répétez ces étapes (2 à 4) pour chaque sous-clé de Registre de la liste suivante. Remplacez le nom de la clé exportée par celui de l'une des sous-clés.
    Par exemple, tapez DeletedKey02 pour la deuxième clé, DeletedKey03 pour la troisième, etc.

Clés de Registre à supprimer dans les versions 32 bits de Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office12*
Clés de Registre à supprimer dans les versions 64 bits de Microsoft Windows
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\*F01FEC
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose
  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC
  • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office12*
Remarque L'astérisque (*) dans les clés de Registre représente un ou plusieurs caractères du nom de la sous-clé.

Continuez à supprimer les clés de Registre correspondantes.
  1. Ouvrez l'Éditeur du Registre et recherchez la sous-clé de Registre suivante :

    Pour les versions 32 bits : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    Pour les versions 64 bits : HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  2. Dans le menu Fichier, cliquez sur Exporter, tapez UninstallKey01, puis cliquez sur Enregistrer.
  3. Sous la sous-clé Uninstall trouvée à l'étape 1, cliquez sur chaque sous-clé, puis vérifiez si la valeur suivante lui est affectée :
    • Nom : UninstallString
    • Données : chemin chemin nom_fichier\Office Setup Controller\Setup.exe

      Remarque L'espace réservé nom_fichier représente le nom d'un programme d'installation, tandis que l'espace réservé chemin représente le chemin d'accès du fichier.
  4. Si la sous-clé contient le nom et les données indiqués à l'étape 3, cliquez sur Supprimer dans le menu Edition. Sinon, passez à l'étape 5.
  5. Répétez les étapes 3 et 4 jusqu'à ce que vous ayez identifié et supprimé toutes les sous-clés correspondant au nom et aux données indiqués à l'étape 3.
  6. Fermez l'Éditeur du Registre.
Étape 6 : Redémarrez l'ordinateur.
Redémarrez l'ordinateur. Si la suppression réussit, vous avez terminé et pouvez à présent réinstaller Microsoft Office si vous le souhaitez.
OFF2007 Office2007 Office 2007 cleansweep clean sweep manual manually fixit fix it remove uninstall control panel
Propriétés

ID d'article : 928218 - Dernière mise à jour : 10/29/2015 11:35:00 - Révision : 12.0

  • Microsoft Office Professional Plus 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Basic 2007
  • kbexpertiseinter kberrmsg kbregistry kbsetup kbinstallation kbtshoot kbprb kbfixme kbmsifixme kbcip KB928218
Commentaires