KB2289254 - Package de mise à jour cumulative 1 pour SQL Server 2008 Service Pack 2

S’applique à
SQL Server 2008 Standard SQL Server 2008 Developer SQL Server 2008 Enterprise SQL Server 2008 Workgroup SQL Server 2008 Web SQL Server 2008 Express SQL Server 2008 Express with Advanced Services

INTRODUCTION

Les correctifs logiciels Microsoft SQL Server 2008 sont créés pour des Service Packs SQL Server spécifiques. Vous devez appliquer un correctif logiciel de SQL Server 2008 Service Pack 2 à une installation de SQL Server 2008 Service Pack 2. Par défaut, tout correctif logiciel fourni dans un Service Pack SQL Server est inclus dans le Service Pack SQL Server suivant.

La mise à jour cumulative 1 pour SQL Server 2008 Service Pack 2 (SP2) est conçue comme un correctif cumulatif post-Service Pack pour les clients de SQL Server 2008 qui envisagent d’effectuer une mise à niveau vers SQL Server 2008 SP2 tout en conservant les correctifs logiciels de SQL Server 2008 SP1Mise à jour cumulative 9 vers SQL Server 2008 SP1Mise à jour cumulative 10.

Remarque : cette version du package de mise à jour cumulative est également appelée build 10.00.4266.00.

Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif de SQL Server 2008. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif.
  Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2402659 Les builds SQL Server 2008 publiées après SQL Server 2008 Service Pack 2

Remarques importantes sur le package de mise à jour cumulative

  • Les correctifs logiciels de SQL Server 2008 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.
  • Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.

Informations supplémentaires

Comment obtenir la mise à jour cumulative 1 pour SQL Server 2008 Service Pack 2

Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par l’un de ces problèmes, nous vous recommandons d’attendre la prochaine version du Service Pack SQL Server 2008 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.

Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles la mise à jour cumulative est disponible. Si votre langue n’est pas répertoriée, aucun package de mise à jour cumulative n’est disponible pour cette langue.

Correctifs logiciels inclus dans la mise à jour cumulative 1 pour SQL Server 2008 Service Pack 2

  Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.

  Pour plus d’informations sur les bogues de SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

Numéro de bogue VSTS Numéro d’article de la Base de connaissances Description
561807 942712 CORRECTIF : le processus W3WP.exe d’Internet Information Services s’arrête de façon inattendue lorsque vous configurez une réplication de fusion qui utilise la synchronisation Web dans SQL Server 2005 et SQL Server 2008
549033 aucun La tâche de capture CDC peut rencontrer la condition d’assertion suivante lorsque CDC est activé sur des tables de base de données qui ont des colonnes XML ou d’autres colonnes de type de données blob :

Assertion : Fichier : <nom du fichier>
line=<numéro> de ligne Assertion ayant échoué = 'fNoWriters' -ET-
line=<numéro> de ligne Échec de l’assertion = 'fNoReaderWriterConflict'
576988 979212 CORRECTIF : une valeur DateTime est remplacée par une valeur NULL lorsqu’un conflit est résolu à l’aide d’un résolveur personnalisé dans Microsoft SQL Server 2005, Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2 Réplication de fusion
576899 980142 CORRECTIF : Un message d’erreur « Échec du chargement du fournisseur » s’affiche ou le processus Wmiprvse.exe cesse de répondre lorsque vous utilisez un fournisseur WMI SQL Server pour obtenir des informations sur les services SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2.
548967 980350 CORRECTIF : L’analyseur lexical polonais entraîne le renvoi d’un résultat incomplet par une requête Full-Text dans SQL Server 2008
548983 980570 CORRECTIF : Message d’erreur « Erreur d’index de texte intégral pendant la compression ou la décompression » lors de la reconstruction de l’index de recherche en texte intégral dans Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2
548985 980832 CORRECTIF : message d’erreur « Une assertion système case activée a échoué » lors de l’exécution d’une requête Transaction-SQL dans Microsoft SQL Server 2008 ou dans Microsoft SQL Server 2008 R2
576971 980849 CORRECTIF : Vous constatez une latence élevée pour les agents de distribution pair à pair dans Microsoft SQL Server 2005, Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2
548999 980883 CORRECTIF : La mise en cache proactive démarre de manière inattendue lorsque vous insérez des données dans SQL Server 2005, SQL Server 2008 R2 ou SQL Server 2008
576984 980948 CORRECTIF : Les métadonnées sont endommagées lorsque vous déplacez des dossiers de données SSAS 2005, SSAS 2008 R2 ou SSAS 2008 d’un ordinateur à un autre
548987 981120 CORRECTIF : Message d’erreur lors de l’activation de TDE sur une base de données pour laquelle l’isolation de capture instantanée est activée dans SQL Server 2008 ou SQL Server 2008 R2
549015 981502 CORRECTIF : une requête qui utilise un plan de requête parallèle retourne des résultats différents chaque fois que vous exécutez la requête dans SQL Server 2005, SQL Server 2008 R2 ou SQL Server 2008
576985 981713 CORRECTIF : une requête retourne un résultat incorrect si elle utilise un index en cours de reconstruction en ligne dans SQL Server 2005, SQL Server 2008 R2 ou SQL Server 2008
576992 981867 CORRECTIF : Un membre calculé qui utilise des membres de dimension filtrés retourne un résultat incorrect dans SSAS 2005, SSAS 2008 R2 ou SSAS 2008
576993 981888 CORRECTIF : « Le moniteur de blocage n’a pas pu résoudre ce blocage. Le serveur peut nécessiter un redémarrage pour récupérer à partir de cette condition » lorsqu’une base de données est en cours de récupération dans Microsoft SQL Server 2005, Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2
548989 982034 CORRECTIF : la fonctionnalité de traduction ne fonctionne pas lorsque vous effectuez une action de regroupement dans un tableau croisé dynamique Excel qui utilise SSAS 2008 ou SSAS 2008 R2 comme source de données
577024 982363 CORRECTIF : SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2 peut nécessiter un temps long pour exécuter une instruction ALTER TABLE qui modifie une colonne de type de données XML de « NOT NULL » à « NULL » dans une table
576999 982376 CORRECTIF : Une erreur de planificateur non productif ou une erreur 8623 se produit lorsque vous exécutez une requête qui contient une clause IN volumineuse dans SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2
561817 982808 Un rapport d’extraction peut ne pas fonctionner correctement si l’option « Demander des informations d’identification » est utilisée dans les sources de données dans SQL Server 2008 Reporting Service
548995 982854 CORRECTIF : message d’erreur « La mémoire système est insuffisante dans la liste de ressources « interne » pour exécuter cette requête lors de l’exécution d’une requête en texte intégral qui utilise des mots composés dans Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2
548997 982857 CORRECTIF : Message d’erreur lors de la configuration d’une réplication transactionnelle pour une base de données dans SQL Server 2008 ou SQL Server 2008 R2
577003 982932 Les performances des requêtes diminuent après l’application de la mise à jour cumulative 7 de SQL Server 2005 SP2 ou d’une version ultérieure
577002 983429 CORRECTIF : Un blocage se produit lorsque vous exécutez une requête ou une procédure stockée contenant une colonne XML dans SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2
549007 983446 Un rapport SSRS 2008 affiche la première ligne dupliquée pour chaque groupe d’un sous-état lorsque vous exportez le rapport au format CSV
577006 983480 CORRECTIF : divers problèmes se produisent lorsqu’une base de données est impliquée dans une session de mise en miroir de bases de données et dans une réplication transactionnelle si l’indicateur de trace 1448 est activé
577007 983500 CORRECTIF : le processus de synchronisation des rôles est retardé lorsqu’un basculement automatique de mise en miroir se produit dans SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2
549013 983577 CORRECTIF : Le processus d’exportation ne se termine jamais lorsque vous exportez un rapport qui a imbriqué des éléments de tableau matriciel dans SSRS 2008 ou dans SSRS 2008 R2 vers les extensions prises en charge par les convertisseurs de saut de page dur
442541 2022254 SQL Server peut signaler l’erreur 18272 pendant les opérations de restauration
549017 2028406 CORRECTIF : des espaces vides entre certains éléments sont générés de manière incorrecte dans un rapport SQL Server 2008 ou SQL Server 2008 R2
561732 2028727 CORRECTIF : les valeurs de groupe de colonnes ne s’affichent que dans le dernier groupe de lignes enfant des groupes de lignes adjacents dans SSRS 2008
549020 2028755 CORRECTIF : un résultat incorrect est renvoyé lorsque vous exécutez une requête LIKE avec des caractères génériques et le classement Latin1_General_100_CS_AS dans Microsoft SQL Server 2008 ou dans Microsoft SQL Server 2008 R2
561809 2028830 CORRECTIF : les composants partagés sont installés à un emplacement incorrect lorsque vous implémentez une installation de cluster de basculement SQL Server 2008
561744 2121407 CORRECTIF : Message d’erreur lors de l’utilisation de l’utilitaire sqlcmd pour exécuter la requête Transact-SQL dans SQL Server 2008 et SQL Server 2008 R2
549026 2152148 CORRECTIF : Message d’erreur « Erreur interne : Une exception inattendue s’est produite » lorsque vous exécutez une requête MDX (Multidimensional Expressions) à l’aide de Time Intelligence dans Microsoft SQL Server Analysis Services 2008
549039 2200755 CORRECTIF : Message d’erreur lors de l’exécution d’une requête MDX dans SSAS 2008 ou SSAS 2008 R2
561746 2214666 CORRECTIF : Un package SSIS qui utilise la transformation Unpivot peut produire des résultats incohérents dans SQL Server 2008
549041 2220252 CORRECTIF : Un rapport de SQL Server 2005 utilisant la fonctionnalité de bascules de visibilité ne s’exécute pas correctement dans SQL Server 2008 ou dans SQL Server 2008 R2
577012 2222998 CORRECTIF : une estimation de cardinalité incorrecte est renvoyée lorsque vous exécutez une requête dans SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2
549031 2248999 CORRECTIF : un index est corrompu lorsque vous mettez à jour un affichage dans Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2
549043 2255410 Une requête renvoie des résultats incohérents avant la préparation du cache de données dans SSAS 2008 ou SSAS 2008 R2
561750 2256829 CORRECTIF : Un certain nombre des dernières colonnes XML peut ne pas être répliqué correctement si vous utilisez la synchronisation web pour la réplication de fusion dans SQL Server 2008
561757 2260502 CORRECTIF : les performances de requête diminuent après la mise à niveau vers SQL Server 2008 à partir de SQL Server 2000 si la requête utilise une fonction scalaire définie par l’utilisateur
561760 2261403 CORRECTIF : L’objet de performance « SQL Server :SSIS Pipeline 10.0 » n’apparaît pas dans la liste « Objet de performance » alors qu’un autre utilisateur accède à des compteurs de pipeline SSIS dans SQL Server 2008 ou dans SQL Server 2008 R2
549028 2264562 CORRECTIF : l’exécution d’une requête en texte intégral qui utilise le prédicat CONTAINS ou FREETEXT avec l’opérateur « OU » est longue dans SQL Server 2008 ou dans SQL Server 2008 R2
577013 2268122 CORRECTIF : Le message d’erreur « L’utilisateur 'invité' n’est pas autorisé à exécuter DBCC checkdb pour la base de données 'mssqlsystemresource' » lorsque vous exécutez la commande DBCC CHECKDB('master') sur un ordinateur exécutant SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2
561766 2276330 CORRECTIF : la fonction « CHANGETABLE » est lente dans SQL Server 2008 et dans SQL Server 2008 R2
561768 2276717 CORRECTIF : code d’erreur 1456 lorsque vous ajoutez un témoin à une nouvelle session de mise en miroir de bases de données portant le même nom de base de données qu’une session de mise en miroir de bases de données existante dans Microsoft SQL Server 2005, Microsoft SQL Server 2008 et Microsoft SQL Server 2008 R2
577014 2277207 CORRECTIF : La valeur de l’étiquette « Axe » apparaît dans chaque colonne et la valeur « Intervalle du quadrillage » n’est pas honorée après la mise à niveau d’un fichier RDL de SSRS 2005 vers SSRS 2008
561770 2278042 CORRECTIF : une transformation de colonne dérivée peut générer des résultats incorrects dans SSIS 2008 ou SSIS 2008 R2 lorsqu’une colonne est dérivée à la fois en lecture seule et en lecture/écriture
561773 2282743 CORRECTIF : Les caractères spéciaux s’affichent de manière incorrecte dans un contrôle « Zone de texte » d’un fichier PDF lorsque vous rendez un rapport dans SSRS 2008
577017 2283072 CORRECTIF : Un correctif logiciel est disponible pour permettre à SQL Server 2008 Reporting Services et à SQL Server 2008 R2 de Reporting Services d’utiliser une clé RSA 2048 bits pour chiffrer une clé Reporting Services pour la conformité FIPS
561791 2287990 CORRECTIF : la transformation « Colonne dérivée » peut produire des résultats incorrects lorsque vous exécutez un package dans Microsoft SQL Server 2008 Integration Services
561789 2292725 CORRECTIF : vous rencontrez une diminution des performances lors de l’exécution d’une requête MDX dans SQL Server 2008 SP1 pour lequel la mise à jour cumulative 5 ou une version ultérieure du package de mise à jour est installée
577020 2297308 CORRECTIF : Une tentative de configuration filestream précédente était incomplète et une violation d’accès se produisent lorsque vous effectuez une configuration post-installation de la fonctionnalité FILESTREAM sur un cluster de basculement SQL Server 2008 ou SQL Server 2008 R2
561783 2297709 CORRECTIF : Un message d’erreur peut s’afficher lorsque vous exécutez une requête « BULK INSERT » sur une base de données qui utilise le modèle de récupération « BULK_LOGGED » ou « Simple » dans SQL Server 2008
577018 2297903 CORRECTIF : l’ID d’événement 322 est enregistré lorsqu’un audit de serveur est généré dans SQL Server 2008 ou SQL Server 2008 R2
561801 2300689 CORRECTIF : Vous ne pouvez pas restaurer la sauvegarde d’une base de données sur une autre instance de SQL Server si vous désactivez le chiffrement transparent des données avant de créer la sauvegarde dans SQL Server 2008 ou dans SQL Server 2008 R2
561787 2306162 CORRECTIF : Des performances médiocres et quelques erreurs occasionnelles de planification non productives se produisent lorsque vous créez une vue complexe qui référence un grand nombre de vues ou de tables imbriquées dans SQL Server 2008
561785 2316135 CORRECTIF : Une erreur interne « Une exception inattendue s’est produite » et un tas corrompu se produisent lorsque vous exécutez une requête MDX générée par un logiciel tiers dans SSAS 2008
561793 2344600 CORRECTIF : L’erreur « Planificateur non productif » peut se produire lorsque vous utilisez la fonction CONTAINSTABLE avec de nombreux prédicats OU et ET dans SQL Server 2008
561795 2352413 CORRECTIF : Un échec de requête et un message d’erreur « Nom de colonne non valide » se produisent lorsque vous exécutez une requête de serveur lié sur une autre instance de SQL Server 2008
561742 2379466 CORRECTIF : le code d’erreur « 0x84B10001 », l’échec de l’installation de SQL Server 2008 et une exception non gérée se produisent lors de l’installation de SQL Server 2008
561797 2380361 CORRECTIF : Message d’erreur lors de l’exécution de la procédure stockée « sp_createstats » dans SQL Server 2008 ou SQL Server 2008 R2 si la table contient une colonne calculée non déterministe
561799 2380435 CORRECTIF : le plan de requête pour une procédure stockée n’est pas mis en cache si la procédure stockée utilise une variable BLOB et que la variable est utilisée dans une fonction de chaîne dans Microsoft SQL Server 2008 ou Microsoft SQL Server 2008 R2
561803 2384766 CORRECTIF : la propriété ANSI_NULLS d’une vue indexée prend la valeur FALSE après la réplication de la vue indexée dans la base de données d’abonnement dans SQL Server 2008 ou dans SQL Server 2008 R2
561805 2387686 CORRECTIF : Le message d’erreur « Une erreur de syntaxe MOF s’est produite » apparaît lorsque vous essayez d’installer SQL Server 2008 ou SQL Server 2008 R2
561813 2399715 CORRECTIF : L’instruction « UPDATE CUBE » renvoie un message d’erreur incorrect lorsque vous essayez de mettre à jour une mesure calculée ou un membre calculé dans SSAS 2008
561811 2407172 CORRECTIF : Une exception se produit avant que la sortie d’erreur pour les données non valides d’une tâche « Source XML » ne soit redirigée dans SSIS 2005 ou SSIS 2008

Informations sur le package de mise à jour cumulative

Configuration requise

Microsoft SQL Server 2008 Service Pack 2
Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

968382 Comment obtenir le dernier Service Pack pour SQL Server 2008

Informations sur le redémarrage

  Vous devrez peut-être redémarrer votre ordinateur après avoir appliqué ce package de mise à jour cumulative.

Informations sur le Registre

  Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.

Références

  Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

935897
  Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés

  Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

822499
  Nouveau schéma d’appellation pour les packages de mise à jour logicielle Microsoft SQL Server
   Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684
  Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft