KB2617148 - Mise à jour cumulative 7 pour SQL Server 2008 Service Pack 2

S’applique à
SQL Server 2008 Service Pack 2 SQL Server 2008 Standard SQL Server 2008 Standard Edition for Small Business SQL Server 2008 Web SQL Server 2008 Workgroup SQL Server 2008 Enterprise SQL Server 2008 Express SQL Server 2008 Express with Advanced Services

INTRODUCTION

Le package de mise à jour cumulative 7 pour SQL Server 2008 Service Pack 2 contient des correctifs logiciels pour les problèmes de SQL Server 2008 qui ont été résolus après la publication de Microsoft SQL Server 2008 Service Pack 2 (SP2).

Remarque : cette version du package de mise à jour cumulative est également appelée build 10.00.4323.00.

Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle version de mise à jour contient tous les correctifs logiciels et toutes les mises à jour de sécurité inclus dans la version précédente de la mise à jour de SQL Server 2008. Nous vous recommandons d’envisager d’appliquer la mise à jour la plus récente qui contient ce correctif.

  Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2402659 Les builds SQL Server 2008 publiées après SQL Server 2008 Service Pack 2

Remarques importantes sur le package de mise à jour cumulative

  • Chaque package de mise à jour cumulative de SQL Server 2008 prend désormais en charge plusieurs langues. Par conséquent, un package de mise à jour cumulative peut être appliqué à n’importe quelle langue prise en charge.
  • Un package de mise à jour cumulative comprend des mises à jour pour tous les packages de composants. Toutefois, un package de mise à jour cumulative ne met à jour que les composants installés sur un système.

Informations supplémentaires

Comment obtenir ce package de mise à jour cumulative

Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par l’un de ces problèmes, nous vous recommandons d’attendre la prochaine version du Service Pack SQL Server 2008 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.

Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :

/contactus/ ?ws=support Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles la mise à jour cumulative est disponible. Si votre langue n’est pas répertoriée, aucun package de mise à jour cumulative n’est disponible pour cette langue.

Correctifs logiciels inclus dans ce package de mise à jour cumulative

  Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.

  Pour plus d’informations sur les problèmes liés à SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

Numéro de bogue VSTS Numéro d’article de la Base de connaissances Description
799306 2515286 CORRECTIF : « Il n’existe aucune fonction '{urn :schemas-microsoft-com :xml-sql} :variable() » pour une requête XQuery qui met à jour la valeur d’une colonne XML dans SQL Server 2005, dans SQL Server 2008 ou dans SQL Server 2008 R2
806150 2531172 CORRECTIF : erreur « Impossible d’obtenir le membre actuel » lors de l’exécution d’une requête MDX dans SQL Server 2008 R2 Analysis Services
799294 2583994 CORRECTIF : le point de contrôle SSIS restaure une valeur de variable incorrecte pour un élément de tâche Execute SQL d’un élément de conteneur For Loop dans SSIS 2008 si un package SSIS s’exécute à nouveau après son échec ou son arrêt
776912 2588506 CORRECTIF : la fonction SQLGetDiagRec ne renvoie pas d’erreurs dans SQL Server 2008 R2 si plus de 2 100 paramètres de requête sont envoyés
799291 2591461 CORRECTIF : erreur « Erreur inattendue de l’interface SE OLEDB » lors de l’exécution d’une requête de recherche en texte intégral dans SQL Server 2008
799303 2598903 CORRECTIF : la tâche de l’SQL Server Agent s’arrête de façon aléatoire lorsque vous planifiez l’exécution de la tâche après minuit à certains jours dans SQL Server 2005 ou dans SQL Server 2008
788324 2603910 CORRECTIF : la sauvegarde échoue dans SQL Server 2008 ou dans SQL Server 2008 R2 si vous activez le suivi des modifications sur la base de données
801804 2618676 CORRECTIF : la sauvegarde du journal des transactions est créée même si aucune sauvegarde complète valide n’existe dans SQL Server 2008
801802 2618680 CORRECTIF : erreur « Non enregistré correctement » lorsque vous utilisez un abonnement par extraction et le résolveur de conflits interactif de réplication
804390 2619077 CORRECTIF : violation d’accès lorsqu’une requête lit un index manquant dans SQL Server 2008
801134 2625989 Erreur « Impossible de télécharger les informations demandées » dans SSRS 2008 lorsque vous cliquez sur un lien de rapport d’extraction
814972 2628126 CORRECTIF : erreur « Erreur d’index de texte intégral pendant la compression ou la décompression » lors de la création d’un index de recherche en texte intégral dans SQL Server 2008 si la clé primaire est définie sur une colonne BIGINT
823528 2635540 CORRECTIF : Message d’erreur lors de l’utilisation d’une base de données de catalogue dont le nom contient des caractères spéciaux dans SSRS 2008
823667 2635827 CORRECTIF : violation d’accès lorsque vous exécutez une commande DBCC CHECKDB sur une base de données qui contient une table contenant un index spatial dans SQL Server 2008
817085 2638448 CORRECTIF : violation d’accès lorsqu’une requête est compilée dans SQL Server 2008
819357 2638932 CORRECTIF : erreur lors de l’exécution de la commande ProcessUpdate sur un cube qui comporte des partitions qui utilisent des conceptions d’agrégation dans SSAS 2008
823699 2640110 CORRECTIF : erreur sp_execute_policy si SQL Server 2008 R2 et SQL Server 2008 sont installés
806841 2643872 CORRECTIF : erreur « HRESULT 0xE06D7363 » lorsqu’une application cliente utilise Microsoft.SqlServer.Types.dll composant sur un ordinateur sur lequel SQL Server 2008 SP2 est installé

Informations sur le package de mise à jour cumulative

Configuration requise

Pour appliquer ce package de mise à jour cumulative, vous devez exécuter SQL Server 2008 SP2.

Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

968382 Comment obtenir le dernier Service Pack pour SQL Server 2008

Informations sur le redémarrage

  Vous devrez peut-être redémarrer votre ordinateur après avoir appliqué ce package de mise à jour cumulative.

Informations sur le Registre

  Pour appliquer l’un des correctifs logiciels contenus dans ce package de mise à jour cumulative, il n’est pas nécessaire de modifier le Registre.

Références

  Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

935897
  Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés

  Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

822499
  Nouveau schéma d’appellation pour les packages de mise à jour logicielle Microsoft SQL Server
   Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

824684
  Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft