KB5022375 - Mise à jour cumulative 1 pour SQL Server 2022

Date de publication : 16 février 2023
Version : 16.0.4003.1

Résumé

Cet article décrit le package de mise à jour cumulative 1 (CU1) pour Microsoft SQL Server 2022. Cette mise à jour contient 64 composants de correctifs et de mises à jour dans les builds suivantes :

  • SQL Server - Version du produit : 16.0.4003.1, version du fichier : 2022.160.4003.1
  • Analysis Services - Version du produit : 16.0.43.208, version du fichier : 2022.160.43.208

Remarque

Cette mise à jour cumulative inclut le GDR pour SQL Server 2022 (KB5021522 récemment publié - Description de la mise à jour de sécurité pour SQL Server GDR 2022 datée du 14 février 2023). Pour plus d’informations sur les versions de maintenance SQL, voir Modèles de maintenance pour SQL Server.

Problèmes connus dans cette mise à jour

Comportement incorrect de SESSION_CONTEXT dans les plans parallèles

Les requêtes qui utilisent la fonction intégrée SESSION_CONTEXT peuvent retourner des résultats incorrects ou déclencher des fichiers de vidage de violation d’accès (AV) lorsqu’elles sont exécutées dans des plans de requête parallèles. Ce problème se produit en raison de la manière dont SESSION_CONTEXT interagit avec les threads d’exécution parallèles, en particulier si la session est réinitialisée en vue de sa réutilisation.

Pour plus d’informations, consultez la section Problèmes connus dans SESSION_CONTEXT.

Améliorations et corrections incluses dans cette mise à jour

Un classeur Excel téléchargeable contenant une liste récapitulative des builds, ainsi que leur cycle de vie de support actuel, est disponible. Le fichier Excel contient également des listes de correctifs détaillées pour SQL Server 2022, SQL Server 2019 et SQL Server 2017. Sélectionnez cette option pour télécharger ce fichier Excel maintenant.

Remarque

Les entrées individuelles du tableau suivant peuvent être référencées directement par le biais d’un signet. Si vous sélectionnez un ID de référence de bogue dans le tableau, une balise de signet est ajoutée à l’URL à l’aide du format « #NNNNNNN ». Vous pouvez ensuite partager cette URL avec d’autres personnes afin qu’elles puissent accéder directement au correctif souhaité dans le tableau.

Pour plus d’informations sur les bogues corrigés et les améliorations incluses dans cette mise à jour cumulative, consultez les articles suivants de la Base de connaissances Microsoft.

Référence de bogue Description Domaine du correctif Composant Plateforme
2078803 Corrige les violations potentielles d’accès à la mémoire et les résultats incorrects lors de l’exécution de requêtes DAX (Data Analysis Expressions) spécifiques qui déclenchent l’optimisation des requêtes de fusion horizontale internes.

Remarque Avant d’appliquer la mise à jour cumulative, vous pouvez désactiver la fonctionnalité en définissant l’option de DAX\HorizontalFusion configuration sur 0 comme solution de contournement.
Analysis Services Analysis Services Windows
2113832 Mises à jour des assemblys Microsoft.Data.SqlClient utilisés par le moteur mashup pour résoudre les vulnérabilités de sécurité décrites dans CVE-2022-41064. Analysis Services Analysis Services Windows
2115275 Amélioration de l’algorithme de chiffrement utilisé pour chiffrer les sources de données et les chaînes de connexion dans les modèles SQL Server Analysis Services (SSAS). Pour plus d’informations, voir Mettre à niveau le chiffrement. Analysis Services Analysis Services Windows

20826442089261
Résolution d’un problème selon lequel tout membre qui a le rôle Opérateur de base de connaissances DQS (dqs_kb_operator) ou un rôle de niveau de privilège plus élevé peut créer ou remplacer des fichiers arbitraires sur l’ordinateur hébergeant SQL Server en tant que compte qui exécute le service SQL Server (le compte par défaut est NT SERVICE\MSSQLSERVER). Data Quality Services Data Quality Services Windows
2008855 Résolution de l’erreur suivante qui se produit lorsque vous essayez de démarrer l’Assistant Importation et exportation de SQL Server après avoir installé le moteur de base de données SQL Server :

Une erreur s’est produite que l’Assistant SQL Server Integration Services n’était pas prêt à gérer. (Assistant Importation et exportation SQL Server)

===================================

Impossible de charger le fichier ou lʼassembly « Microsoft.DataTransformationServices.ScaleHelper, Version=16.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91 » ou lʼune de ses dépendances. Le fichier spécifié est introuvable. (DTSWizard)
Services d’intégration Services d’intégration Windows
2076990 Résout l’erreur suivante qui se produit lors de l’exécution de la capture des données modifiées (CDC) Échec de la tâche de contrôle :

Impossible de charger le fichier ou lʼassembly « Microsoft.SqlServer.DtsMsg, Version=16.100.0.0,Culture=neutral, PublicKeyToken=89845dcd8080cc91 » ou lʼune de ses dépendances. La définition de manifeste de l’assembly localisé ne correspond pas à la référence de l’assembly. (Exception de HRESULT : 0x80131040)
Services d’intégration Services d’intégration Windows
2159526 Rétablit la longueur de la ROUTINE_DEFINITION colonne à 4000 dans la INFORMATION_SCHEMA.ROUTINES vue, car la modification précédente de la longueur peut entraîner des incohérences inattendues. Services d’intégration Services d’intégration Tous
2042238 Correctifs : « Le flux du protocole d’appel de procédure distante (RPC) de flux de données tabulaires (TDS) entrant est incorrect. Paramètre 1 (« « ) : Type de données 0x00 est inconnu » qui se produit lors de l’utilisation de l’option de chiffrement strict dans vos paramètres de connexion. Pour obtenir un exemple de ce scénario, consultez Erreurs de Stream TDS non valides avec Encrypt=Strict lors de l’exécution de procédures stockées. Connectivité SQL Connectivité SQL Tous
2120777 Résolution d’un problème rare où l’altération de la mémoire dans le pilote ODBC peut se produire dans les communications entre deux instances de SQL Server. Ce problème se produit lorsque le SQL Server instance cible utilise une version de niveau inférieur du protocole TDS (Tabular Data Stream). Une version incorrecte case activée entraîne le décodage incorrect des types de données d’image du côté client de la connexion. Connectivité SQL Connectivité SQL Windows
2157874 Corrige une violation d’accès et INVALID_POINTER_READ_CPP_EXCEPTION_c0000005_sqldk.dll!ex_oomCheck des exceptions déclenchées par une exception de mémoire insuffisante (OOM) lorsque le SQL Server instance est soumis à une sollicitation de mémoire. Performances SQL Optimiseur de requêtes Tous
2069101 Résolution d’un problème en raison duquel Database Mail ne parvient pas à envoyer de messages électroniques et consigne le message d’erreur suivant dans le journal des erreurs de SQL Server, lorsqu’il est utilisé dans un groupe de disponibilité (AG) contenu :

Le proc activé '[dbo].[ sp_sysmail_activate]' exécuté dans la file d’attente '<DatabaseName>_msdb.dbo.ExternalMailQueue' affiche le résultat suivant : 'Impossible de trouver l’objet 'ExternalMailQueue' car il n’existe pas ou vous n’avez pas d’autorisations.'
Outils client SQL Server Messagerie de base de données Tous
2114695 Résolution d’un problème selon lequel la sauvegarde différentielle ignore les nouvelles pages de l’espace libre de page (PFS) après qu’un fichier de données s’agrandit autour d’une limite PFS (un multiple de 8 088 pages ; 64 704 Ko), ce qui entraîne une altération de la base de données et un vidage possible lors de la restauration de cette sauvegarde différentielle. Moteur SQL Server Sauvegarde et restauration Tous
2154919 Résolution d’un problème d’échec de la sauvegarde instantané Transact-SQL avec les erreurs suivantes lorsqu’une base de données est suspendue en mode mono-utilisateur :

Msg 3081, Niveau 16, État 9, Ligne <LineNumber
>La base de données «< DatabaseName> » a été précédemment suspendue pour instantané sauvegarde.
Msg 5069, Niveau 16, État 1, Ligne <LineNumber>
L’instruction ALTER DATABASE a échoué.
Moteur SQL Server Sauvegarde et restauration Tous
2138926 Amélioration : la procédure stockée sp_invoke_external_rest_endpoint n’est prise en charge que dans les environnements de base de données Azure SQL. Si vous essayez d’utiliser cette procédure dans des environnements locaux, vous recevrez une erreur erronée semblable à la suivante :

Msg 2812, Level 16, State 99, Procedure sys.sp_invoke_external_rest_endpoint_internal, Line <LineNumber> [Batch Start Line <LineNumber>]
Impossible de trouver la procédure stockée 'sp_invoke_external_rest_endpoint_internal'.

Le correctif améliore le message pour qu’il se lise comme suit :

« sp_invoke_external_rest_endpoint » n’est pas pris en charge dans cette édition de SQL Server.
Moteur SQL Server Extensibilité Tous
2075503 Résolution d’un problème selon lequel la requête de lecture sur un réplica secondaire lisible peut être abandonnée ou retourner des résultats inattendus si la requête utilise un segment de mémoire et que des enregistrements de transfert sont présents dans le tas. Moteur SQL Server Haute disponibilité et récupération d'urgence Tous
1948145 Corrige l’erreur 41842 qui s’affiche de manière incorrecte même quand les procédures stockées compilées en mode natif ou les transactions en mémoire n’insèrent pas beaucoup d’enregistrements dans une seule transaction. Voici le message d’erreur :

Erreur 41842 : trop de lignes insérées ou mises à jour dans cette transaction. Vous pouvez insérer ou mettre à jour un maximum de 4 294 967 294 lignes dans des tables à mémoire optimisée en une seule transaction.
Moteur SQL Server OLTP en mémoire Tous
1993393 Résout l’erreur 35221 qui se produit dans les scénarios suivants :

- Vous tentez d’ajouter un fichier à un groupe de fichiers FILESTREAM ou à un groupe de fichiers à mémoire optimisée.
- Vous essayez d’ajouter des fichiers journaux de transactions supplémentaires à une base de données.

Message d’erreur :

Msg 35221, Niveau 16, État 1, Ligne <LineNumber>
Impossible de traiter l’opération. Groupes de disponibilité Always On Le gestionnaire de réplica est désactivé sur cette instance de SQL Server. Activer les groupes de disponibilité Always On à l’aide du Gestionnaire de configuration SQL Server. Redémarrez ensuite le service SQL Server, puis recommencez l’opération en cours. Pour plus d’informations sur l’activation et la désactivation des groupes de disponibilité AlwaysOn, consultez la documentation en ligne de SQL Server.
Moteur SQL Server OLTP en mémoire Tous
2087479 Après avoir appliqué cette mise à jour, vous devez au moins disposer de l’autorisation du serveur de contrôle pour exécuter la procédure sys.sp_xtp_force_gc. Cette mise à jour modifie l’implémentation de la procédure en un seul appel pour les octets alloués et utilisés à libérer. Avant d’appliquer cette mise à jour, vous devez l’appeler deux fois. Pour plus d’informations, consultez Augmentation progressive de la consommation de mémoire XTP. Moteur SQL Server OLTP en mémoire Windows
2153494 Corrige un échec d’assertion (Emplacement : execcoll.cpp :1317 ; expression : 'savepointId > HkTxSavePointDefault') qui se produit pendant le nettoyage du point de sauvegarde dans une transaction Hekaton. Moteur SQL Server OLTP en mémoire Tous
2160880 Résolution d’un problème selon lequel les procédures stockées OLTP In-Memory qui ont des fonctions table de diffusion en continu (STVF), des expressions ou des vérifications de contraintes peuvent générer des hachages de plan de requête incohérents. Moteur SQL Server OLTP en mémoire Tous
2098401 Résolution d’un problème selon lequel un vidage mémoire peut se produire en raison d’incohérences CMIterStatsDisk::GetNextStatForLeadingColumn de métadonnées importantes. Moteur SQL Server Métadonnées Tous
2135970 Résout un DBCC CLONEDATABASE échec lors de la mise à niveau de la base de données source à partir d’une version antérieure de SQL Server. Moteur SQL Server Métadonnées Tous
2084307 Corrige l’incohérence d’index ou les résultats incorrects qui peuvent se produire dans le scénario suivant :

- Vous activez la récupération de base de données accélérée (ADR) et l’isolation des instantanés.
- Vous revenez à un point de sauvegarde.
- Vous mettez à jour en haut des lignes abandonnées et le nettoyage de version est en retard par rapport à cette mise à jour.
Moteur SQL Server Méthodes d’accès aux données stockées Tous
2081891 Résout une exception qui se produit lorsque JSON_ARRAY/JSON_OBJECT des valeurs de retour sont utilisées dans un paramètre dans des fonctions qui acceptent des chaînes. Une fois ce correctif appliqué, les valeurs de et JSON_OBJECT sont rendues coercibles et peuvent être utilisées comme paramètres de JSON_ARRAY chaîne. Moteur SQL Server Programmabilité Tous
2115768 Corrige un échec d’assertion qui se produit dans les modules compilés en mode natif lorsque l’opérateur est suivi d’un Inner FOR JSON opérateur qui met en mémoire tampon les objets correspondants, tels qu’un autre opérateur ou ORDER BY un autreFOR JSON. En outre, vous pouvez voir l’expression d’assertion suivante :

Emplacement : memilb.cpp :<LineNumber
>Expression : (*ppilb)->m_cRef == 0
SPID : <ID du processus SPID>
: <ProcessID>
Moteur SQL Server Programmabilité Tous
2118401 Avant d’appliquer cette mise à jour, le nom de la clé dans la sortie de la fonction JSON_OBJECT n’est pas entre guillemets lorsque le type de données est un type de données numérique, booléen ou JSON interne. Une fois que vous avez appliqué cette mise à jour, les clés sont mises entre JSON_OBJECT guillemets. Moteur SQL Server Programmabilité Tous
2043012 CORRECTIF : problèmes d’inlining UDF scalaire en SQL Server 2022 et 2019 (KB4538581) Moteur SQL Server Exécution de la requête Tous
1860413 Ce correctif résout les problèmes suivants qui peuvent se produire lorsque vous renommez des bases de données :

Problème 1 : SQL Server se bloque lorsqu’un utilisateur qui a un schéma autre que celui par défaut (par exemple : CREATE USER <user_name> FOR LOGIN <login_name> WITH DEFAULT_SCHEMA = <schema_name>) exécute des requêtes dans l’ordre suivant :

1. Exécute une requête comme celle-ci avec un nom implicite (un nom de schéma qui n’est pas explicitement spécifié nécessite que SQL Server détermine le même nom) :
SELECT * FROM <database_name>..<table_name>
2. Renomme la base de données.
3. Réexécute la requête implicite de l’étape 1.

Problème 2 : Résout SQL Server erreur 942 qui se produit lorsque vous effectuez les étapes suivantes dans le même ordre sur votre SQL Server instance :

1. Vous interrogez une table dans une base de données (par exemple : SELECT * FROM DatabaseA.sys.columns).
2. Vous renommez une base de données existante (par exemple : ALTER DATABASE DatabaseA MODIFY NAME = DatabaseA_old).
3. Vous prenez cette base de données renommée hors ligne (par exemple : ALTER DATABASE DatabaseA_old SET OFFLINE).
4. Vous renommez une autre base de données sur le serveur pour qu’elle porte le même nom que celle que vous avez renommée à l’étape 2 (par exemple : ALTER DATABASE DatabaseA_new MODIFY NAME = DatabaseA).
5. Maintenant, si vous interrogez une table dans cette base de données (par exemple : SELECT * FROM DatabaseA.sys.columns), vous recevrez l’erreur 942 suivante :

Msg 942, Niveau 14, État 4, Ligne <LineNumber>
La base de données « DatabaseA_old » ne peut pas être ouverte car elle est hors ligne.
Moteur SQL Server Exécution de la requête Tous
2009090 Résout l’erreur 8657 lors de l’exécution de requêtes qui utilisent le mode centile pour les commentaires d’allocation de mémoire. Moteur SQL Server Exécution de la requête Tous
2116378 Résout un échec à générer l’erreur de dépassement de capacité du type de données approprié lorsqu’un fichier de valeurs séparées par des virgules (CSV) a une valeur entière (int) supérieure à la valeur maximale de int et que vous exécutez SELECT <integer_column_name> FROM OPENROWSET sur ce fichier CSV. Moteur SQL Server Exécution de la requête Tous
2120696 Amélioration : active automatiquement la fonctionnalité de mémoire tampon de l’anneau de suivi des objets blob lorsqu’un échec d’assertion BLOB est détecté. Cette amélioration permet de mieux examiner ces problèmes. Moteur SQL Server Exécution de la requête Tous
2086044 Résolution d’un problème selon lequel un attaquant authentifié pourrait affecter la mémoire de SQL Server lors de l’exécution d’une instruction OR UPDATE STATISTICS spécialement conçueCREATE STATISTICS. Moteur SQL Server Optimiseur de requêtes Tous
2113374 Résolution d’une exception de violation d’accès qui se produit sur le réplica principal lorsque le réplica secondaire envoie des plans de curseur à la réplica principale pour un stockage en Magasin des requêtes (QDS). Moteur SQL Server Magasin de requêtes Tous
1959261 Corrige une condition d’utilisation élevée du processeur qui se produit lorsque vous activez le suivi des modifications sur un grand nombre de tables et effectuez un nettoyage automatique ou manuel des tables de suivi des modifications. Moteur SQL Server Réplication Windows
1967560 Corrige les erreurs 12300 (les colonnes calculées ne sont pas prises en charge) et 12301 (les colonnes nullables dans la clé d’index ne sont pas prises en charge) lorsque la réplication transactionnelle est activée sur les tables à mémoire optimisée avec des colonnes calculées et l’index sur des colonnes nullables, respectivement. Après avoir appliqué ce correctif, vous pouvez activer la réplication transactionnelle sur les tables à mémoire optimisée avec des colonnes calculées et l’index sur des colonnes nullables. Moteur SQL Server Réplication Windows
2049442 Prenons le scénario suivant :

- Vous disposez d’une configuration de réplication transactionnelle.
- Vous exécutez la sp_changearticle procédure stockée pour modifier la propriété d’un article sur l’éditeur, et des modifications du langage de manipulation de données (DML) se produisent sur la table publiée.

Dans ce scénario, le thread de lecture de l’agent de lecture du journal peut générer le vidage d’assertion suivant lors du traitement des enregistrements du journal :

* Emplacement : replrowset.cpp :<LineNumber
>* Expression : (LSN)m_curLSN <(LSN)(pSchemas-schema_lsn_begin>)
* SPID : <SPID*>
ID du processus : <ProcessID>
Moteur SQL Server Réplication Tous
2068781 Résolution d’une fuite de mémoire progressive dans le processus SQL Server (utilisation élevée sous MEMORYCLERK_SOSNODE) provoquée par l’agent de lecture des journaux dans la réplication transactionnelle. Moteur SQL Server Réplication Tous
2104416 Résolution d’un problème selon lequel le serveur lié temporaire créé par l’agent de lecture du journal n’est pas toujours correctement supprimé lorsque l’éditeur se trouve dans un groupe de disponibilité (AG) Always On et qu’il y a un basculement au niveau du serveur de distribution. Une fois ce correctif appliqué, le serveur lié est correctement supprimé. Moteur SQL Server Réplication Windows
2129326 Résolution de l’erreur 8992 [Vérifiez le catalogue Msg 3853, État 1 : l’attribut (owning_principal_id<=ID)> de la ligne (principal_id=<ID)> dans sys.database_principals n’a pas de ligne correspondante (principal_id=<ID)> dans sys.database_principals.] générée par DBCC CHECKDB lorsqu’elle est exécutée sur un clone de base de données d’une base de données source activée par la capture des données modifiées (CDC) qui possède des rôles définis par le système appartenant aux utilisateurs CDC. Moteur SQL Server Réplication Tous
2130492 Résout un problème de performances de requête qui affecte les requêtes de nettoyage automatique et de nettoyage manuel du suivi des modifications.

Remarque Vous devez activer les indicateurs de trace 8286 et 8287, car cela force la requête de nettoyage à utiliser les FORCE ORDER conseils et FORCESEEK pour accélérer les performances.
Moteur SQL Server Réplication Tous
2138330 Corrige une erreur de violation de clé primaire causée par un problème de minutage dans la capture des données modifiées (CDC) dans SQL Server 2022. Le processus de capture CDC peut essayer d’insérer une valeur en start_lsn double dans la cdc.lsn_time_mapping table, et vous pouvez voir un message d’erreur semblable à celui qui suit :

Violation de la contrainte PRIMARY KEY 'lsn_time_mapping_clustered_idx'. Impossible d’insérer une clé en double dans l’objet 'cdc.lsn_time_mapping'. Valeur de clé dupliquée (Value)

Remarque Ce correctif couvre toutes les causes de cette erreur. Pour le même problème qui se produit dans SQL Server 2019 avec une mise à jour cumulative précédente installée, SQL Server 2017 et SQL Server 2016, consultez le correctif précédent KB 4521739. Toutefois, le correctif précédent ne couvrait pas tous les cas.
Moteur SQL Server Réplication Tous
2138691 Corrige l’erreur 302 dans la réplication de SQL Server. Lorsque l’agent de distribution tente d’appliquer un instantané généré sur une table qui a une clé primaire avec la NEWSEQUENTIALID fonction comme valeur par défaut, l’erreur suivante se produit :

Msg 302, gravité 16
La fonction intégrée newsequentialid() ne peut être utilisée que dans une expression DEFAULT pour une colonne de type 'uniqueidentifier' dans une instruction CREATE TABLE ou ALTER TABLE. Il ne peut pas être combiné avec d’autres opérateurs pour former une expression scalaire complexe.
Moteur SQL Server Réplication Windows
2151109 Résout l’erreur 241 qui se produit pendant l’exécution de l’agent d’instantané, et le format de date système a été modifié dans un format différent de celui utilisé par SQL Server.

Message d’erreur :

Échec de la conversion lors de la conversion de la date et/ou de l’heure à partir d’une chaîne de caractères.
Moteur SQL Server Réplication Tous
2160907 Résolution d’un problème selon lequel l’Agent de distribution renvoie un code de message général 20046 au lieu du code de message d’échec de connexion 20084 lorsqu’il ne parvient pas à se connecter à l’Abonné à l’aide de la connexion non mise en cache. Ces erreurs sont spécifiques à l’Agent de distribution de réplication.

Message d’erreur :

20046 : Le processus a rencontré une erreur externe générale.
20084 : Le processus n’a pas pu se connecter au serveur.
Moteur SQL Server Réplication Tous

21143132158583
Ce correctif permet de protéger les problèmes pouvant entraîner une indisponibilité due à la capacité mémoire dans certaines requêtes rares (requêtes imbriquées effectuant des analyses de tables). Avant d’émettre ces requêtes, il tente de s’assurer que suffisamment d’espace est disponible et évite de provoquer d’autres problèmes de capacité. Moteur SQL Server Resource Governor Tous
2105584 Résolution d’un problème selon lequel la recherche en texte intégral génère des fuites de mémoire et des attentes élevées dans les requêtes en texte intégral. Moteur SQL Server Recherche Tous
2123504 Amélioration : fractionnez le type d’attente en types d’attente FT_IFTS_RWLOCK plus granulaires pour un diagnostics plus précis du problème. Pour plus d’informations sur ces types d’attente, consultez sys.dm_os_wait_stats (Transact-SQL). Moteur SQL Server Recherche Tous
2118499 CORRECTIF : problèmes d’accessibilité des bases de données avec les charges de travail client volumineuses qui utilisent EKM pour le chiffrement et la génération de clés (KB5023236) Moteur SQL Server Infrastructure de sécurité Windows
2058060 Après avoir appliqué cette mise à jour, vous pouvez auditer les événements (EXTERNAL GOVERNANCE TURNED ON et EXTERNAL GOVERNANCE TURNED OFF) qui correspondent aux actions d’activation/désactivation de la gouvernance externe (stratégies d’accès Microsoft Purview). L’exactitude des enregistrements d’audit est garantie lors de l’évaluation des autorisations du lecteur et de l’enregistreur de données. Cette mise à jour introduit l’indicateur de trace (TF) 12481 pour désactiver les informations d’audit de journalisation pour les autorisations externes dans le external_policy_permission_checked champ des enregistrements d’audit. Moteur SQL Server Infrastructure de sécurité Tous
2088539 Ajoute les requêtes et la catégorie de la télémétrie du Programme d’amélioration de l’expérience utilisateur (CEIP) de Microsoft à SQL Server 2022. Moteur SQL Server Infrastructure de sécurité Tous
2100518 Résout un problème où l’administrateur de Microsoft Entra n’est pas ajouté au groupe sysadmin après avoir configuré Microsoft Entra ID pour SQL Server 2022. Moteur SQL Server Infrastructure de sécurité Tous
2101033 Mises à jour du message d’erreur 37517 utilisé pour les stratégies d’accès Microsoft Purview dans SQL Server vers le message suivant :

Une erreur interne s’est produite lors de l’obtention d’informations sur les ressources ARC à partir du point de terminaison IMDS. Sous-état : ' %ls', status : 0x %08x.
Moteur SQL Server Infrastructure de sécurité Tous
2101035 Corrige une exception qui génère un fichier de vidage lors de l’utilisation des stratégies d’accès Microsoft Purview pour SQL Server 2022 et de l’exécution de la sp_external_policy_refresh procédure stockée en tant qu’utilisateur Microsoft Entra non administrateur. Moteur SQL Server Infrastructure de sécurité Tous
2117119 Supprime un cas d’héritage multiple dans le code de chiffrement RSA dans SQL Server 2022. Moteur SQL Server Infrastructure de sécurité Tous
2117122 Résout un problème d’orthographe dans l’erreur 33025 (Propriété du fournisseur de chiffrement non valide : %S_MSG) lors de l’utilisation de la fonctionnalité Gestion de clés extensibles (EKM). Moteur SQL Server Infrastructure de sécurité Tous
2117214 Corrige l’erreur suivante qui peut se produire lorsque vous chargez les journaux d’audit à partir de SQL Server Management Studio (SSMS) :

L’élément a déjà été ajouté. Clé dans le dictionnaire : « MNDO » Clé en cours d’ajout : « MNDO »
Moteur SQL Server Infrastructure de sécurité Tous
2125981 Ajoute une nouvelle sys.dm_external_provider_certificate_info vue de gestion dynamique (DMV), qui renvoie des informations sur les certificats cloud Azure utilisés dans SQL Server pour configurer et maintenir un administrateur Microsoft Entra pour l’authentification Microsoft Entra. Pour plus d’informations, reportez-vous à sys.dm_external_provider_certificate_info (Transact-SQL). Moteur SQL Server Infrastructure de sécurité Tous
2131225 Résolution des problèmes suivants avec les stratégies basées sur les attributs de Purview - Contrôle d’accès basé sur les attributs Azure (Azure ABAC) :

- Les attributs ne se synchronisent pas correctement.
- Le processus de synchronisation ne peut pas dépasser la table qui n’avait pas de synchronisation d’attributs.
- Lors d’une nouvelle tentative, le processus de synchronisation rencontre des exceptions car il s’attendait à ce que l’état de la base de données soit planifié et non synchronisé.
Moteur SQL Server Infrastructure de sécurité Windows
2021487 Corrige les problèmes d’orthographe dans les messages d’erreur du moteur de base de données dans SQL Server 2022. Moteur SQL Server Moteur SQL Server Tous
1862944 Cette mise à jour supprime la nécessité de l’indicateur de trace (TF) 809 pour le pool de mémoires tampons hybride avec la fonctionnalité d’écriture directe. Une fois cette mise à jour appliquée, cette fonctionnalité est activée par défaut dans SQL Server 2022. Cette mise à jour introduit TF 898 pour désactiver le Direct Write comportement du pool de mémoires tampons hybride à des fins de dépannage ou de débogage. Moteur SQL Server SYSTÈME D’EXPLOITATION SQL Tous
2137927 Résolution d’un problème selon lequel des verrous de modification de schéma (Sch-M) sont acquis sur les tables de clé étrangère lors de la modification de colonnes sur les tables primaires, même si la transaction n’est pas liée à la colonne de clé étrangère. Une fois ce correctif appliqué, SQL Server n’acquiert que les verrous de stabilité de schéma (Sch-S) sur les tables de clé étrangère. Pour plus d’informations, voir Verrouillages de schéma. Moteur SQL Server Table Index Partition Tous
2162849 Résout un problème d’interblocage automatique où les transactions statistiques de mise à jour internes conservent des verrous, ce qui peut provoquer des blocages non résolus avec des requêtes utilisateur. Le problème se produit car le verrou n’est pas libéré lorsque le système exécute les statistiques de requête de mise à jour. Une fois ce correctif appliqué, le verrou peut être libéré comme prévu. Moteur SQL Server Services transactionnels Tous

Comment obtenir ou télécharger ce package de mise à jour cumulative ou le dernier package de mise à jour cumulative

Comment obtenir ou télécharger le dernier package de mise à jour cumulative pour Windows (recommandé)

La mise à jour suivante est disponible sur le Centre de téléchargement Microsoft :

Remarque

  • Le Centre de téléchargement Microsoft présentera toujours la dernière version de la mise à jour cumulative de SQL Server 2022.
  • Si la page de téléchargement ne s’affiche pas, procurez-vous le package de mise à jour cumulative auprès du Support technique et du Service clientèle Microsoft.
Comment obtenir ou télécharger ce package de mise à jour cumulative pour Windows à partir du catalogue Microsoft Update

La mise à jour suivante est disponible dans le catalogue Microsoft Update :

Remarque

  • Le catalogue Microsoft Update contient cette mise à jour cumulative SQL Server 2022 et les versions précédemment publiées de la mise à jour cumulative SQL Server 2022.
  • Cette mise à jour cumulative est également disponible par le biais de Windows Server Update Services (WSUS).
  • Nous vous recommandons d’installer la dernière mise à jour cumulative disponible.
Comment obtenir ou télécharger le dernier package de mise à jour cumulative pour Linux

Pour mettre à jour SQL Server 2022 sur Linux vers la dernière CU, vous devez d’abord avoir configuré le référentiel de mises à jour cumulatives. Ensuite, mettez à jour vos packages SQL Server à l’aide de la commande de mise à jour spécifique à la plateforme.

Pour obtenir des instructions d’installation et des liens directs vers les téléchargements du package CU, consultez les notes de publication de SQL Server 2022.

Informations de fichier

Informations sur le hachage de fichier

Vous pouvez vérifier le téléchargement en calculant le hachage du fichier SQLServer2022-KB5022375-x64.exe à l’aide de la commande suivante :

certutil -hashfile SQLServer2022-KB5022375-x64.exe SHA256

Nom de fichier Hachage SHA-256
SQLServer2022-KB5022375-x64.exe 589F5609A99EDC07AAAD2C73FFE53E1259B6BC1BCDE3ED950468C8219D2C9594
Informations sur le fichier de mise à jour cumulative

La version anglaise de ce package dispose des attributs de fichier répertoriés dans le tableau suivant ou ceux d’une version ultérieure. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations du fichier, celles-ci sont converties en heure locale. Pour connaître le décalage entre l’heure UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’élément Date et heure du Panneau de configuration.

SQL Server 2022 Analysis Services

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Asplatformhost.dll 2022.160.43.208 336808 27-Jan-23 17 : 34 x64
Microsoft.analysisservices.server.core.dll 16.0.43.208 2903472 27-Jan-23 17 : 34 x86
Microsoft.data.mashup.sqlclient.dll 2.108.3243.0 24480 27-Jan-23 17 : 34 x86
Microsoft.data.sqlclient.dll 1.14.21068.1 1920960 27-Jan-23 17 : 34 x86
Microsoft.identity.client.dll 4.14.0.0 1350048 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.jsonwebtokens.dll 5.6.0.61018 65952 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.logging.dll 5.6.0.61018 26528 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.protocols.dll 5.6.0.61018 32192 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.protocols.openidconnect.dll 5.6.0.61018 103328 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.tokens.dll 5.6.0.61018 162720 27-Jan-23 17 : 34 x86
Msmdctr.dll 2022.160.43.208 38864 27-Jan-23 17 : 34 x64
msmdlocal.dll 2022.160.43.208 53920160 27-Jan-23 17 : 34 x86
msmdlocal.dll 2022.160.43.208 71755216 27-Jan-23 17 : 34 x64
Msmdpump.dll 2022.160.43.208 10335152 27-Jan-23 17 : 34 x64
Msmdredir.dll 2022.160.43.208 8132016 27-Jan-23 17 : 34 x86
Msmdsrv.exe 2022.160.43.208 71308720 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 954832 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1882576 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1669584 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1878992 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1846224 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1145296 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1138128 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1767376 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1746896 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 930768 27-Jan-23 17 : 34 x64
Msmdsrv.rll 2022.160.43.208 1835472 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 953296 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1880528 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1666512 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1874384 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1842640 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1143248 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1136584 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1763792 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1743312 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 931280 27-Jan-23 17 : 34 x64
Msmdsrvi.rll 2022.160.43.208 1830864 27-Jan-23 17 : 34 x64
msmgdsrv.dll 2022.160.43.208 8265648 27-Jan-23 17 : 34 x86
msmgdsrv.dll 2022.160.43.208 10083760 27-Jan-23 17 : 34 x64
Msolap.dll 2022.160.43.208 8744864 27-Jan-23 17 : 34 x86
Msolap.dll 2022.160.43.208 10970016 27-Jan-23 17 : 34 x64
Msolui.dll 2022.160.43.208 289696 27-Jan-23 17 : 34 x86
Msolui.dll 2022.160.43.208 308144 27-Jan-23 17 : 34 x64
newtonsoft.json.dll 13.0.1.25517 704448 27-Jan-23 17 : 34 x86
Sni.dll 1.1.1.0 555424 27-Jan-23 17 : 34 x64
Sql_as_keyfile.dll 2022.160.4003.1 137128 27-Jan-23 17 : 34 x64
Sqlceip.exe 16.0.4003.1 300968 27-Jan-23 17 : 34 x86
sqldumper.exe 2022.160.4003.1 227240 27-Jan-23 17 : 34 x86
sqldumper.exe 2022.160.4003.1 260008 27-Jan-23 17 : 34 x64
System.identitymodel.tokens.jwt.dll 5.6.0.61018 83872 27-Jan-23 17 : 34 x86
Tmapi.dll 2022.160.43.208 5884336 27-Jan-23 17 : 34 x64
Tmcachemgr.dll 2022.160.43.208 5575120 27-Jan-23 17 : 34 x64
Tmpersistence.dll 2022.160.43.208 1481136 27-Jan-23 17 : 34 x64
Tmtransactions.dll 2022.160.43.208 7197648 27-Jan-23 17 : 34 x64
xmsrv.dll 2022.160.43.208 35895712 27-Jan-23 17 : 34 x86
xmsrv.dll 2022.160.43.208 26594224 27-Jan-23 17 : 34 x64

SQL Server 2022 Database Services Common Core

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Instapi150.dll 2022.160.4003.1 104392 27-Jan-23 17 : 34 x64
Instapi150.dll 2022.160.4003.1 79776 27-Jan-23 17 : 34 x86
Microsoft.analysisservices.adomdclient.dll 16.0.43.208 2633672 27-Jan-23 17 : 34 x86
Microsoft.analysisservices.adomdclient.dll 16.0.43.208 2633680 27-Jan-23 17 : 34 x86
Microsoft.analysisservices.core.dll 16.0.43.208 2933152 27-Jan-23 17 : 34 x86
Microsoft.analysisservices.xmla.dll 16.0.43.208 2323408 27-Jan-23 17 : 34 x86
Microsoft.analysisservices.xmla.dll 16.0.43.208 2323360 27-Jan-23 17 : 34 x86
Microsoft.sqlserver.rmo.dll 16.0.4003.1 554912 27-Jan-23 17 : 34 x86
Microsoft.sqlserver.rmo.dll 16.0.4003.1 554920 27-Jan-23 17 : 34 x86
Msasxpress.dll 2022.160.43.208 32672 27-Jan-23 17 : 34 x64
Msasxpress.dll 2022.160.43.208 27600 27-Jan-23 17 : 34 x86
Sql_common_core_keyfile.dll 2022.160.4003.1 137128 27-Jan-23 17 : 34 x64
sqldumper.exe 2022.160.4003.1 227240 27-Jan-23 17 : 34 x86
sqldumper.exe 2022.160.4003.1 260008 27-Jan-23 17 : 34 x64

Qualité des données de SQL Server 2022

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Microsoft.ssdqs.core.dll 16.0.4003.1 599976 27-Jan-23 17 : 34 x86
Microsoft.ssdqs.dll 16.0.4003.1 173992 27-Jan-23 17 : 34 x86
Microsoft.ssdqs.dll 16.0.4003.1 173984 27-Jan-23 17 : 34 x86
Microsoft.ssdqs.infra.dll 16.0.4003.1 1857440 27-Jan-23 17 : 34 x86
Microsoft.ssdqs.infra.dll 16.0.4003.1 1857448 27-Jan-23 17 : 34 x86
Microsoft.ssdqs.proxy.dll 16.0.4003.1 370592 27-Jan-23 17 : 34 x86
Microsoft.ssdqs.proxy.dll 16.0.4003.1 370632 27-Jan-23 17 : 34 x86

SQL Server 2022 Database Services Core Instance

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Aetm-enclave-simulator.dll 2022.160.4003.1 4719016 27-Jan-23 21:19 x64
Aetm-enclave.dll 2022.160.4003.1 4673456 27-Jan-23 21:19 x64
Aetm-sgx-enclave-simulator.dll 2022.160.4003.1 4909088 27-Jan-23 21:19 x64
Aetm-sgx-enclave.dll 2022.160.4003.1 4874464 27-Jan-23 21:19 x64
Hadrres.dll 2022.160.4003.1 227232 27-Jan-23 21:19 x64
Hkcompile.dll 2022.160.4003.1 1410976 27-Jan-23 19:20 x64
Hkengine.dll 2022.160.4003.1 5760936 27-Jan-23 19:20 x64
Hkruntime.dll 2022.160.4003.1 190376 27-Jan-23 19:20 x64
Hktempdb.dll 2022.160.4003.1 71624 27-Jan-23 21:19 x64
Microsoft.analysisservices.applocal.xmla.dll 16.0.43.208 2322336 27-Jan-23 21:19 x86
Microsoft.sqlserver.xevent.linq.dll 2022.160.4003.1 333720 27-Jan-23 21:19 x64
Microsoft.sqlserver.xevent.targets.dll 2022.160.4003.1 96200 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 30664 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 38856 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 34760 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 38816 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 38856 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 30664 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 30624 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 34720 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 38856 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 30664 27-Jan-23 21:19 x64
Odsole70.rll 16.0.4003.1 38856 27-Jan-23 21:19 x64
Qds.dll 2022.160.4003.1 1779616 27-Jan-23 19:20 x64
Rsfxft.dll 2022.160.4003.1 55200 27-Jan-23 21:19 x64
Secforwarder.dll 2022.160.4003.1 83872 27-Jan-23 19:20 x64
Sql_engine_core_inst_keyfile.dll 2022.160.4003.1 137128 27-Jan-23 19:20 x64
Sqlaccess.dll 2022.160.4003.1 444360 27-Jan-23 21:19 x64
Sqlagent.exe 2022.160.4003.1 726944 27-Jan-23 21:19 x64
Sqlceip.exe 16.0.4003.1 300968 27-Jan-23 21:19 x86
Sqlctr160.dll 2022.160.4003.1 157600 27-Jan-23 21:19 x64
Sqlctr160.dll 2022.160.4003.1 128968 27-Jan-23 21:19 x86
Sqldk.dll 2022.160.4003.1 4028360 27-Jan-23 19:20 x64
Sqlevn70.rll 2022.160.4003.1 1742792 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 3835816 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4052904 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4556712 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4687816 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 3737544 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 3921832 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4556744 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4388776 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4458408 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 2434984 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 2377640 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4245448 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 3885000 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4397000 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4192168 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4175816 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 3958696 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 3835816 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 1681320 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4282280 27-Jan-23 21:19 x64
Sqlevn70.rll 2022.160.4003.1 4425672 27-Jan-23 21:19 x64
Sqllang.dll 2022.160.4003.1 48535464 27-Jan-23 19:20 x64
Sqlmin.dll 2022.160.4003.1 51300256 27-Jan-23 19:20 x64
Sqlos.dll 2022.160.4003.1 51112 27-Jan-23 19:20 x64
Sqlrepss.dll 2022.160.4003.1 137120 27-Jan-23 21:19 x64
Sqlscriptdowngrade.dll 2022.160.4003.1 51104 27-Jan-23 21:19 x64
Sqlscriptupgrade.dll 2022.160.4003.1 5830560 27-Jan-23 21:19 x64
Sqlservr.exe 2022.160.4003.1 722848 27-Jan-23 19:20 x64
Sqltses.dll 2022.160.4003.1 9389984 27-Jan-23 19:20 x64
Sqsrvres.dll 2022.160.4003.1 305056 27-Jan-23 21:19 x64
Svl.dll 2022.160.4003.1 247752 27-Jan-23 19:20 x64
Xe.dll 2022.160.4003.1 718752 27-Jan-23 21:19 x64

SQL Server 2022 Database Services Core Shared

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Distrib.exe 2022.160.4003.1 268200 27-Jan-23 17 : 34 x64
Logread.exe 2022.160.4003.1 788376 27-Jan-23 17 : 34 x64
Microsoft.analysisservices.applocal.core.dll 16.0.43.208 2933680 27-Jan-23 1 731 x86
Microsoft.data.sqlclient.dll 3.10.22089.1 2032120 27-Jan-23 17 : 34 x86
Microsoft.datatransformationservices.scalehelper.dll 16.0.4003.1 30624 27-Jan-23 17 : 34 x86
Microsoft.identity.client.dll 4.36.1.0 1503672 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.jsonwebtokens.dll 5.5.0.60624 66096 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.logging.dll 5.5.0.60624 32296 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.protocols.dll 5.5.0.60624 37416 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.protocols.openidconnect.dll 5.5.0.60624 109096 27-Jan-23 17 : 34 x86
Microsoft.identitymodel.tokens.dll 5.5.0.60624 167672 27-Jan-23 17 : 34 x86
Microsoft.sqlserver.replication.dll 2022.160.4003.1 1714088 27-Jan-23 17 : 34 x64
Microsoft.sqlserver.rmo.dll 16.0.4003.1 554912 27-Jan-23 17 : 34 x86
Msgprox.dll 2022.160.4003.1 313248 27-Jan-23 17 : 34 x64
Msoledbsql.dll 2018.186.4.0 2734072 27-Jan-23 17 : 34 x64
Msoledbsql.dll 2018.186.4.0 153584 27-Jan-23 17 : 34 x64
newtonsoft.json.dll 13.0.1.25517 704408 27-Jan-23 17 : 34 x86
Qrdrsvc.exe 2022.160.4003.1 530336 27-Jan-23 17 : 34 x64
Rdistcom.dll 2022.160.4003.1 939936 27-Jan-23 17 : 34 x64
Repldp.dll 2022.160.4003.1 337824 27-Jan-23 17 : 34 x64
Replisapi.dll 2022.160.4003.1 419752 27-Jan-23 17 : 34 x64
Replmerg.exe 2022.160.4003.1 604056 27-Jan-23 17 : 34 x64
Replprov.dll 2022.160.4003.1 890824 27-Jan-23 17 : 34 x64
Replrec.dll 2022.160.4003.1 1058760 27-Jan-23 17 : 34 x64
Replsub.dll 2022.160.4003.1 501664 27-Jan-23 17 : 34 x64
Spresolv.dll 2022.160.4003.1 300960 27-Jan-23 17 : 34 x64
Sql_engine_core_shared_keyfile.dll 2022.160.4003.1 137128 27-Jan-23 1 731 x64
Sqldistx.dll 2022.160.4003.1 268200 27-Jan-23 17 : 34 x64
Sqlmergx.dll 2022.160.4003.1 423848 27-Jan-23 17 : 34 x64
Xe.dll 2022.160.4003.1 718752 27-Jan-23 17:35 x64

SQL Server 2022 sql_extensibility

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Commonlauncher.dll 2022.160.4003.1 100256 27-Jan-23 17 : 34 x64
Exthost.exe 2022.160.4003.1 247752 27-Jan-23 17 : 34 x64
Launchpad.exe 2022.160.4003.1 1361824 27-Jan-23 17 : 34 x64
Sql_extensibility_keyfile.dll 2022.160.4003.1 137128 27-Jan-23 17 : 34 x64
Sqlsatellite.dll 2022.160.4003.1 1165256 27-Jan-23 17 : 34 x64

SQL Server 2022 Full-Text Engine

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Fd.dll 2022.160.4003.1 710568 27-Jan-23 17 : 34 x64
Fdhost.exe 2022.160.4003.1 153544 27-Jan-23 17 : 34 x64
Fdlauncher.exe 2022.160.4003.1 100264 27-Jan-23 17 : 34 x64
Sql_fulltext_keyfile.dll 2022.160.4003.1 137128 27-Jan-23 17 : 34 x64

SQL Server 2022 Integration Services

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Attunity.sqlserver.cdccontroltask.dll 7.0.0.133 79176 27-Jan-23 17:40 x86
Attunity.sqlserver.cdccontroltask.dll 7.0.0.133 79176 27-Jan-23 17:40 x86
Attunity.sqlserver.cdcsplit.dll 7.0.0.133 40312 27-Jan-23 17:40 x86
Attunity.sqlserver.cdcsplit.dll 7.0.0.133 40312 27-Jan-23 17:40 x86
Attunity.sqlserver.cdcsrc.dll 7.0.0.133 80728 27-Jan-23 17:40 x86
Isdbupgradewizard.exe 16.0.4003.1 120744 27-Jan-23 17:40 x86
Isdbupgradewizard.exe 16.0.4003.1 120776 27-Jan-23 17:40 x86
Microsoft.analysisservices.applocal.core.dll 16.0.43.208 2933664 27-Jan-23 1 731 x86
Microsoft.analysisservices.applocal.core.dll 16.0.43.208 2933680 27-Jan-23 1 731 x86
Microsoft.sqlserver.integrationservices.isserverdbupgrade.dll 16.0.4003.1 509856 27-Jan-23 17:40 x86
Msdtssrvr.exe 16.0.4003.1 219080 27-Jan-23 17:40 x64
Msmdpp.dll 2022.160.43.208 10165664 27-Jan-23 1 731 x64
newtonsoft.json.dll 13.0.1.25517 704408 27-Jan-23 17:40 x86
newtonsoft.json.dll 13.0.1.25517 704408 27-Jan-23 17:40 x86
Sql_is_keyfile.dll 2022.160.4003.1 137128 27-Jan-23 1 731 x64
Sqlceip.exe 16.0.4003.1 300968 27-Jan-23 17:40 x86
Xe.dll 2022.160.4003.1 640936 27-Jan-23 17:40 x86
Xe.dll 2022.160.4003.1 718752 27-Jan-23 17:40 x64

SQL Server 2022 sql_polybase_core_inst

Nom de fichier Version du fichier Taille du fichier Date Heure Plateforme
Instapi150.dll 2022.160.4003.1 104392 27-Jan-23 1,919 x64
Mpdwinterop.dll 2022.160.4003.1 296904 27-Jan-23 1,919 x64
Mpdwsvc.exe 2022.160.4003.1 7817120 27-Jan-23 1,919 x64
Secforwarder.dll 2022.160.4003.1 83872 27-Jan-23 1,919 x64
Sqldk.dll 2022.160.4003.1 4028360 27-Jan-23 1,919 x64
sqldumper.exe 2022.160.4003.1 260008 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 1742792 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 4556712 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 3737544 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 4556744 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 4458408 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 2434984 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 2377640 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 4192168 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 4175816 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 1681320 27-Jan-23 1,919 x64
Sqlevn70.rll 2022.160.4003.1 4425672 27-Jan-23 1,919 x64
Sqlncli17e.dll 2017.1710.3.1 1898432 27-Jan-23 1,919 x64
Sqlos.dll 2022.160.4003.1 51112 27-Jan-23 1,919 x64
Sqltses.dll 2022.160.4003.1 9389984 27-Jan-23 1,919 x64

Remarques concernant cette mise à jour

Configuration requise

Pour pouvoir appliquer cette mise à jour cumulative, vous devez utiliser SQL Server 2017.

Informations sur le redémarrage

Vous devrez peut-être redémarrer votre ordinateur après avoir appliqué ce package de mise à jour cumulative.

Informations sur le Registre

Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.

Avis importants

Cet article fournit également des informations importantes sur les situations suivantes.

Version de build de mise à jour cumulative d’Analysis Services

À compter de Microsoft SQL Server 2017, le numéro de version de build Analysis Services et le numéro de version de build du moteur de base de données SQL Server ne correspondent pas. Pour plus d’informations, voir Vérifier la version de build de la mise à jour cumulative Analysis Services.

Mises à jour cumulatives (CU)

  • Chaque nouvelle mise à jour cumulative contient tous les correctifs inclus dans la mise à jour cumulative précédente pour la version installée de SQL Server.
  • Les mises à jour cumulatives SQL Server sont certifiées pour les mêmes niveaux que les Service Packs et doivent être installées au même niveau de confiance.
  • Nous recommandons l’installation continue et proactive des mises à jour cumulatives à mesure qu’elles deviennent disponibles, conformément à ces instructions :
    • Les données historiques indiquent qu’un nombre important d’incidents de support concerne un problème déjà résolu dans une mise à jour cumulative publiée.
    • Les mises à jour cumulatives peuvent apporter une valeur ajoutée par rapport aux correctifs logiciels, notamment des mises à jour de capacité de prise en charge, de facilité de gestion et de fiabilité.
  • Nous vous recommandons de tester les mises à jour cumulatives de SQL Server avant de les déployer dans un environnement de production.
Déploiement dans un environnement hybride

Lorsque vous déployez les correctifs logiciels dans un environnement hybride (AlwaysOn, réplication, cluster et mise en miroir, par exemple), nous vous recommandons de consulter au préalable les articles suivants :

Prise en charge des langues

Les mises à jour cumulatives de SQL Server sont actuellement multilingues. Par conséquent, cette mise à jour cumulative n’est pas spécifique à une seule langue. mais à toutes les langues prises en charge.

Composants (fonctionnalités) mis à jour

Une mise à jour cumulative inclut toutes les mises à jour disponibles pour TOUS les composants de SQL Server 2017 (fonctionnalités). Toutefois, la mise à jour cumulative ne met à jour que les composants installés sur le système sur l'instance SQL Server que vous choisissez de desservir. Si une fonction SQL Server (par exemple Analysis Services) est ajoutée à l’instance après l’application de cette mise à jour cumulative, vous devez réappliquer cette mise à jour cumulative pour mettre à jour la nouvelle fonction à cette mise à jour cumulative.

Support pour cette mise à jour

Si d’autres problèmes surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à cette mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone du Support technique et du Service clientèle Microsoft ou pour créer une demande de service distincte, reportez-vous au site web Support Microsoft.

Comment désinstaller cette mise à jour

Comment désinstaller cette mise à jour sous Windows
  1. Dans le Panneau de contrôle, ouvrez l’élément Programmes et fonctionnalités , puis sélectionnez Afficher les mises à jour installées.
  2. Recherchez l’entrée correspondant à cette mise à jour cumulative sous SQL Server 2017.
  3. Appuyez longuement (ou cliquez avec le bouton droit) sur l’entrée, puis sélectionnez Désinstaller.
Comment désinstaller cette mise à jour sous Linux

Pour désinstaller cette mise à jour cumulative sous Linux, vous devez restaurer le package à la version précédente. Pour plus d’informations sur la restauration de l’installation, voir Restauration de SQL Server.

Références