Symptômes
Prenons le scénario suivant :
- Vous disposez d’une instance de SQL Server 2022 avec un groupe de disponibilité contenu déployé.
- Vous créez des objets au niveau du serveur (connexions et travaux) dans le contexte du groupe de disponibilité contenu.
Dans ce scénario, l’une des erreurs suivantes se produit après l’installation d’une mise à jour cumulative sur cette instance de SQL Server.
Erreur 1
La tâche de SQL Server Agent échoue avec le message d’erreur suivant :
Impossible de démarrer l’exécution de l’étape 2 (raison : JobOwner <JobOwner> n’est pas autorisé à utiliser proxy #> pour le <sous-système SSIS). L’étape a échoué.
Vous voyez que le journal des erreurs de l’agent SQL Server Agent enregistre des messages d’erreur semblables aux suivants :
<Timestamp> - ! [298] Erreur SQLServer : 208, nom d’objet « syssubsystems » non valide. [SQLSTATE 42S02]
<Timestamp> - ! [517] Erreur SQL numéro 208, gravité 16
À ce stade, la syssubsystems table est absente de la msdb base de données du groupe de disponibilité contenu et existe dans la base de données de niveau msdb instance. Pour corriger ces erreurs et permettre aux tâches de s’exécuter correctement, vous pouvez copier manuellement la table au niveau syssubsystems de l’instance dans la msdb base de données du groupe de disponibilité contenu en vous connectant à l’écouteur et en créant la table et les lignes de la table.
Erreur 2
Après avoir créé un groupe de disponibilité contenu, le message d’erreur suivant apparaît toutes les cinq secondes :
Le proc '[dbo]. [sp_syspolicy_events_reader]' exécuté dans la file d’attente '<AGName>_AG_SYNC_CONTAINED_msdb.dbo.syspolicy_event_queue' génère le résultat suivant : « Impossible d’exécuter en tant que principal de la base de données car le principal « ##MS_PolicyEventProcessingLogin## » n’existe pas, ce type de principal ne peut pas être emprunté ou vous n’avez pas d’autorisation. »
Erreur 3
Lorsque Database Mail cesse de fonctionner, la tentative d’exécution de la sysmail procédure stockée signale un message d’erreur semblable à celui qui suit :
L’objet '[dbo]. [sp_syspolicy_events_reader]' n’existe pas dans la base de données 'master' ou n’est pas valide pour cette opération.
Erreur 4
Après avoir créé un groupe de disponibilité contenu, si vous vous connectez à l’écouteur du groupe de disponibilité contenu et créez un principal de connexion SQL Server, vous recevrez l’erreur suivante dans SQL Server Management Studio (SSMS) lorsque vous vous connectez à l’aide du principal de connexion :
Erreur de connexion à <votre écouteur>
Impossible de récupérer les données pour cette requête. (Microsoft.SqlServer.Management.Sdk.Sfc)
Une exception s’est produite lors de l’exécution d’une instruction ou d’un lot Transact-SQL. (Microsoft.SqlServer.ConnectionInfo)
L’autorisation EXECUTE a été refusée sur l’objet 'xp_msver', la base de données 'mssqlsystemresource', le schéma 'sys'. (Microsoft SQL Server, Erreur : 229)
Cette erreur se produit parce que le public rôle n’a pas reçu l’autorisation EXECUTE sur la xp_msver procédure stockée étendue sur le master du groupe de disponibilité contenu (AG).
Résolution
Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :
Mise à jour cumulative 4 pour SQL Server 2022
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la version précédente. Nous vous recommandons d’installer la version la plus récente pour votre version de SQL Server :
Dernière mise à jour cumulative pour SQL Server 2022
État
Microsoft recherche actuellement une solution à ce problème. Cet article sera mis à jour au fur et à mesure que nous trouverons plus d’informations ou de conseils. En attendant, vous pouvez prendre les précautions nécessaires suivantes avant d’installer une mise à jour cumulative sur une installation qui a un groupe de disponibilité contenu :
- Scriptez les objets au niveau du serveur et SQL Server Agent objets.
- Supprimez le groupe de disponibilité contenu.
- Appliquer la mise à jour cumulative.
- Recréez le groupe de disponibilité contenu.
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.